PDA

View Full Version : Fixing the notorious black screen issue on a G53



DyreVaa
04-19-2014, 06:49 PM
Hello guys!

My computer: Asus G53SX with a 560m.

Its been a while since the black screen problem was a hot topic here, but ive been struggling with it for quite a while now. I bought the computer early in 2012, loooved it, and about a year later i got the problem after transporting the laptop in the backpack that came with the computer. Im sure it did not get hit or damaged in any way, but the vibration of travel seems to have been enough.

I turned it on, the keyboard lit up and i could hear everything starting like normal - but the screen was completely dead. Not blank, but off.

Like a lot of you, the sceen does not display on another screen or on anything else. Not with the Fn-tricks and not like anything. There just is no display coming out of it.

Windows starts up normal in the background. I can write my password, hear the chime, and Alt+F4 it off again. Its just the display.

There was no way to turn the screen on - not the magnet, not the emptying battery, no nothing - until i read the advice about lifting the laptop in the air by holding it tightly from the right corner. The pressure then is from the right corner and straight across. It just worked like normal again.

I have turned on the screen dozens of times like this now. After travel its 50-50 if i have to do it, and lately it has gotten worse - carefully moving the computer from one room to another can be enough to bring back the black screen now. It also takes more attempts to get it to turn back on again. If screen comes on, it works fine until the computer is moved.

Note: Once the computer is on with the screen working, i can move it around all i want. Its not like the scrren suddenly turns off. But: Once i restart, it could be back to black. This makes me think that the computer somehow imagines the problem on startup. But i dont know enought about the anatomy of computers to be sure...

So, obviously something has been shaken or squeexed just enough that the GPU doesent work/thinks it doesnt work, but it has not been shaken so much that its broken. During the last year i havent really had the time to be without my computer for 3-4 weeks for the RMA. Also, the chances of everything working perfectly after the computer being shaken in the mail would have been around 50-50. I just couldent take the annoyment of getting it back with a note about it working perfectly. Ive read horror stories about people experiencing this a lot.

Short story long, but now i want to open the thing myself and see if i can tighten whatever is loose. Ive seen some people write that some screws are loose, while others think its some kind of short because the metal plate under the keyboard is pressing on the gpu or its cable. They fixed this by putting some plastic between metal and gpu. Both are kind of consistent with the computer working when i holde it from the right corner. The pressure from holding it that way does spread across the whole thing, though. And i need som advice:

What am i looking for when i open it up? What steps should i take while its open to make sure i fix all possibilities? Im really looking for some advice from those of you who have had this thing open, and preferably have fixed the issue. I know opening this thing, even to put in an extra hard drive, is a major pita. How deep do i need to go to see the GPU? Is it located in the lower right corner?

I am not experienced with this kind of operation, but there are lots of guides and videos to disassemble. Im just afraid i wont know what to look for in there.

Whatever advice you guys have, it would really be appreciated. Apart from the black screen issue, i really love this laptop, and i want to upgrade it and be able to love it for a few more months or years. Help!

The problem is also explained by lots of guys here, including one who fixed by disasembling http://rog.asus.com/forum/archive/index.php/t-6123.html?

Problem explained, and in one of the last posted a member explains he fixed it by tightening loose screws: http://rog.asus.com/forum/archive/index.php/t-11049.html?