PDA

View Full Version : G750JS and driver problems



Ulveglis
04-23-2014, 01:27 PM
Hi. I recently received my ASUS G750JS. It has 12 GBs of RAM and a GeForce GTX 870M graphics card.

I found to my dismay that Starcraft 2: Heart of Swarm succumbs to massive frame rate drops at some occasions, forcing me to close the game. For example: The game runs smoothly on max settings, but should I alt-tab in the menue, the game succumbs to a massive frame rate drop that can't be resolved without closing the entire application and launching it again.

I downloaded a beta-driver via GeForce Experience, and the abovementioned issue disappeared. However, there are other instances that frankly leave the game unplayable. For example: I start a match, everything runs smoothly. Once the match is over, I click "Play again", and though it's the same map, everything is horribly laggy. It's as if something "jams" when loading.

The only way to prevent this issue entirely, in my experience, is to set the graphics to "low". However, that's hardly what I want to do, having spent my savings on an expensive gaming computer.

Any ideas on how to fix this problem? My driver version is 337.50, if that helps. I also haven't tampered with any settings; the computer is very much as it was when I got it.

senttel
04-23-2014, 01:49 PM
Hi. I recently received my ASUS G750JS. It has 12 GBs of RAM and a GeForce GTX 870M graphics card.

I found to my dismay that Starcraft 2: Heart of Swarm succumbs to massive frame rate drops at some occasions, forcing me to close the game. For example: The game runs smoothly on max settings, but should I alt-tab in the menue, the game succumbs to a massive frame rate drop that can't be resolved without closing the entire application and launching it again.

I downloaded a beta-driver via GeForce Experience, and the abovementioned issue disappeared. However, there are other instances that frankly leave the game unplayable. For example: I start a match, everything runs smoothly. Once the match is over, I click "Play again", and though it's the same map, everything is horribly laggy. It's as if something "jams" when loading.

The only way to prevent this issue entirely, in my experience, is to set the graphics to "low". However, that's hardly what I want to do, having spent my savings on an expensive gaming computer.

Any ideas on how to fix this problem? My driver version is 337.50, if that helps. I also haven't tampered with any settings; the computer is very much as it was when I got it.

Hi there,

Try going to Nvidia panel, 3d settings, then find "Power Management mode" field and change it to Performance from Adaptive.
See if it helps, and let us know!

HomieOC
04-23-2014, 01:55 PM
i had same issue with titanfall...... it was switching to integrated graphics card when i would minimize, and then not go back. Disabling integrated card fixed it :)

senttel
04-23-2014, 02:18 PM
Yes, HomieDC's suggestions makes more sense

Ulveglis
04-23-2014, 06:42 PM
Hi. Thanks for your quick responses.

Changing the power management mode to "performance" greatly improved the situation.

My graphics processor was set to "Automatic". I put it to the alternative to "integrated graphics" but experienced no improvement in performance.

The frame rate drops are far less frequent now, making the game playable. Though I'd of course like to hear some more suggestions, if you have any. Thanks in advance.

EDIT: The frame rate drop occurs after I've played about three games; once the map loads it laggs so badly I have to close the game. The game is effectively unplayable.