PDA

View Full Version : Weird internet problem with G750JX



basvdelsen
04-27-2014, 09:17 AM
Yesterday internet was suddenly not working on my G750JX which has an Atheros wifi card.

I was connected to my wifi like normally and sites just wouldn't load at all, while on my phone I was connected to the same wifi and internet was fast. And now the next day it's working again. I did download 16GB in one day yesterday on my laptop could that be a reason somehow, if so, how? Because that really annoying. Is it my wifi card? I'm looking to get a dual band anyway could anyone recommend a good one for my laptop?

pokerface
04-27-2014, 09:41 AM
Bigfoot Wireless Killer 1202 is what I bought to replace my crappy Atheros that ASUS put in thie top of the line G750JX that I had

changed all my WiFi Experience

no more conneciton @ 72 MBPS, now I connect @ 300 MBPS with no connection drops

I got it for 50 USD

http://www.amazon.com/gp/product/B008H5V9ZU/ref=oh_details_o01_s00_i00?ie=UTF8&psc=1

sasuke256
04-27-2014, 09:42 AM
try to see if the drivers are updated (not from asus site) manually and make sure the parameters of the WLAN card are correct.. (Dual Band : On or s.th like that)

Zygomorphic
04-27-2014, 10:08 AM
I've heard that Intel's are also good wireless cards. The Atheros cards are terrible as a rule.

basvdelsen
04-27-2014, 11:45 AM
Thanks guys

sasuke256
04-27-2014, 06:48 PM
I love my atheros :p always giving me full speed and nice ranges :D but Intel WLAN cards are the best..