PDA

View Full Version : Internet stops working when I close the lid (G750JX)



basvdelsen
04-28-2014, 05:58 PM
Anybody have had this issue? I posted about a weird internet issue few days ago, that the internet suddenly stopped working. I now figured out that it stops working when I close the lid. I got it hooked up to my TV and then I close the lid, which I always used to do with my old laptop, would really suck if I couldn't do that no more.

JeniCzech
04-28-2014, 06:51 PM
and it's only the internet or it went sleep? cause G750Js wake up when you open the lid...

basvdelsen
04-28-2014, 06:59 PM
Only the internet, it doesn't even disconnect it just stops transferring

JeniCzech
04-28-2014, 07:15 PM
tried updating Atheros driver? i don't have this issue on my JH..

hmscott
04-28-2014, 07:19 PM
Only the internet, it doesn't even disconnect it just stops transferring

It may be one of, or a combination of, network interface power saving, power plan, Power4Gear.

The network interface adapter has a setting to enable power saving, that might be part of it - I have it unchecked/disabled:

36182

36189

I uninstalled Power4Gear due to it adding nothing and taking over power plans, and I only use Balanced and High Performance WIndows power plans, you can try the same.

Check the Power plan you are using advanced settings, see if there are any power saving options that can affect network; change to max performance, or equivalent.

36183

36184

JeniCzech
04-28-2014, 07:35 PM
one thing: are you on cable or on wifi?

basvdelsen
04-28-2014, 08:24 PM
I'm on wifi, I'm gonna try the above

hmscott
04-28-2014, 08:59 PM
I'm on wifi, I'm gonna try the above

There is also a power off setting for the Wifi on my Killer 1202, not sure about yours...

36190

basvdelsen
04-28-2014, 09:56 PM
Okay I adjusted the power settings and unchecked that box and it's still the same.

hmscott
04-28-2014, 10:18 PM
Okay I adjusted the power settings and unchecked that box and it's still the same.

basvdelsen, seems to be a widespread (not just G750) Windows issue solved by updating wireless drivers, what card / driver version are you on? Windows 8.0 or Windows 8.1?

https://www.google.com/search?q=+Internet+stops+working+when+I+close+the+ lid&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a&channel=sb

JeniCzech
04-28-2014, 10:54 PM
gigabit ethernet controller is wired adapter, Killer Wireless-N is the adapter you want... i'm on 10.0.1.247 driver from 30. 5. 2013 and works flawlessly for me...

basvdelsen
04-28-2014, 10:55 PM
I'm on 8.1 but I just updated the driver already

hmscott
04-28-2014, 10:56 PM
Okay I adjusted the power settings and unchecked that box and it's still the same.

Did you reboot in between the changes?

hmscott
04-28-2014, 10:57 PM
I'm on 8.1 but I just updated the driver already

Did you update from the new G750 JM/JS/JZ download areas, or from the old JX area?

basvdelsen
04-29-2014, 08:59 AM
I rebooted, and it seems to work now, woohoo, thanks everyone :D

hmscott
04-29-2014, 09:18 AM
I rebooted, and it seems to work now, woohoo, thanks everyone :D

basvdelsen, that's great news :)

So, what was the last change before the reboot that fixed it? Disabling the power saving on the interfaces, or?

basvdelsen
04-29-2014, 10:05 AM
I cheered too early :( it's still the same. I did the update and then when I restarted I thought it worked but it was only a couple seconds.

hmscott
04-29-2014, 10:40 AM
I cheered too early :( it's still the same. I did the update and then when I restarted I thought it worked but it was only a couple seconds.

Maybe don't close the lid? ;)

https://www.google.com/search?q=+Internet+stops+working+when+I+close+the+ lid&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a&channel=sb

basvdelsen, so I realized I hadn't tried this myself. I set my lid action to none from sleep, and closed the lid, and am editing this on the external 50" while running a video from FX, and browsing in another tab, 10 minutes and still have internet.

IDK what is holding you back...but at least you know it is possible on a Windows 8.1 updated drivers G750JH :)

basvdelsen
04-29-2014, 11:37 AM
I already had lid action to none. But anyway, I'm keeping my lid open with a little rubber to keep internet working until there's a better solution.