PDA

View Full Version : Win7 G750JW Booting straight to BIOS only after flashing [solved]



pali1H
04-29-2014, 12:52 AM
Hey everyone,

I have a G750JW. I had BIOS version 203 installed from when I bought it. I put version 208 onto a flash drive in FAT32 format. Went into BIOS and used the "Start Easy Flash" option. I selected the 208 file on the flash drive and it went though its thing. It completed and then shut itself down as it said it would. Now whenever I turn the laptop on, it goes straight to BIOS and won't let me past! If I go to the Boot menu, "Boot Option Priorities" is greyed out and won't let me select the order in which to check for Windows. If I go to my SATA Configuration, it shows my 2 harddrives and optical drive. I now can't get past BIOS. I hit load defaults, save changes and exit. No matter what I do, it just goes to BIOS and will not load windows. Pulled the battery and put it back in. Turned it on and still only straight to BIOS! Did I just brick my new laptop? I am running Windows 7 by the way. I downgraded from 8. Any help would be super appreciated! I don't want a really expensive brick! <3

Update: It does seem to be a problem with the Boot Option Priorities. After the BIOS flash, it won't recognize my SSD, HDD or Optical drive. If I put a flash drive it, it does recognize that as a boot option. It shoes all my drives in the SATA Configuration under the Advanced tab but won't let me add them as boot options. SATA Mode selection is in AHCI mode. This is not good. I tried to put the original 203 BIOS version on but it won't downgrade. Easy Flash says it is too old! Please help!

pali1H
04-29-2014, 01:39 AM
I figured it out for anybody who has this problem as well. For some reason, in the new BIOS, it has Launch CSM and Launch PXE opROM policy disabled under the Boot tab. If you enable both of those, it should go through. All drives are now showing. I wonder why those would be turned off by default after flashing a new ROM? Very strange. Sigh of relief though. Thank you anyway guys. You are still the best!

Praz
04-29-2014, 01:45 AM
Hello

The PXE opROM should not need to be enabled if you are not booting over LAN. As the laptop shipped with Win8 is should have been configured to boot as UEFI not legacy which is why CSM would be disabled by default.

pali1H
04-29-2014, 02:18 AM
Oh ok so maybe it was because Launch CSM alone was disabled then?

JeniCzech
04-29-2014, 04:14 PM
CSM is legacy boot technology... you should use UEFI...

cl-Albert
04-29-2014, 04:30 PM
I am running Windows 7 by the way. I downgraded from 8.


Glad you could solve it paliH and thanks for letting us know how you fixed it.

fyi. If anybody is interested, the problem probably occurred because you are running Win7.
The G750JW should have shipped with Win8 originally and ran fine with the 'Launch CSM' setting disabled.

Since ASUS is not officially supporting Win7 on the G750JW or posting Win7 drivers for this model, it makes more sense that the default bios settings would disable Launch CSM.

Anyway, if any Win7 G750JW owners update the bios, this is something to watch out for.

JeniCzech
04-29-2014, 04:34 PM
I seeeee....

You have Windows 7 installed on MBR disk, then you are stuck with CSM... should you installed it on GPI disk, then it would support UEFI boot...

pali1H
04-29-2014, 08:45 PM
Glad you could solve it paliH and thanks for letting us know how you fixed it.

fyi. If anybody is interested, the problem probably occurred because you are running Win7.
The G750JW should have shipped with Win8 originally and ran fine with the 'Launch CSM' setting disabled.

Since ASUS is not officially supporting Win7 on the G750JW or posting Win7 drivers for this model, it makes more sense that the default bios settings would disable Launch CSM.

Anyway, if any Win7 G750JW owners update the bios, this is something to watch out for.

Yes I believe you are exactly correct. My laptop did come with Win 8 and I personally cannot stand Win 8 without having a touchscreen at the very least. Ever since I did wipe it and put Win 7 on it, it went to CSM but didn't notice it.

I found this little tid bit:
Windows 7 requires the CSM (compatibility support module, e.g. legacy mode) to be enabled in BIOS setup. Specifically, Windows 7 video drivers require the CSM. While it is technically true that Windows 7 itself can support a legacy-free (CSM disabled) UEFI installation, not all OEM component drivers were updated for legacy-free.

SadrikX
12-05-2014, 04:01 AM
I figured it out for anybody who has this problem as well. For some reason, in the new BIOS, it has Launch CSM and Launch PXE opROM policy disabled under the Boot tab. If you enable both of those, it should go through. All drives are now showing. I wonder why those would be turned off by default after flashing a new ROM? Very strange. Sigh of relief though. Thank you anyway guys. You are still the best!

I can now go to sleep tonight because of this post. LOL. Thank you for the update / fix. Worked perfectly. Was sweating after mine did the same thing. Again, THANK YOU!