PDA

View Full Version : G73Jh SATA controller(s)



abluejelly
05-02-2014, 06:33 PM
Okay so, recently my G73Jh started having issues. Extra slow boot time, random crashing, hard driver errors all day e'ry day, etc.

Ignoring the powersupply not being able to reliably battery (she's completely fine if she's plugged in; note however that if the SATA controller IS the problem, it might be that power to the HDD was failing due to a lower remaining battery), it was starting to look like it was the hard drive in her that was finally giving up. I was somewhat OK with this. I have had an SSD for a while, but couldn't muster up the resolve to actually go through with a fresh installation of Windows on it, and the 5400 (or rather, 5700) RPM was starting to actually get on my nerve to begin with.

So figured I should probably switch the drives so Disk0 was the SSD with the boot stuff, and Disk4 (the outermost slot) was the failing HDD awaiting replacement (bought a 7200 RPM 750gig WD Black before I started to deal with this). Now for some chassis modification... I had to break off two small plastic nubs and dig a trench in one side so the damn 2.5" mounting bracket would fit; I have the SSD braced with legos (25 of them, to be exact; the spaces between the chassis and the Neutron I have were exactly the right size, no unwanted pressure is being applied to the connector), and since SSDs run cooler (and this one is slimmer than the HDD) I decided that leaving the mounting bracket on the HDD was the better idea.

I finally turn her back on with everything plugged in

Loading windows onto the SSD all fresh-like, finishes installing, does the lovely "I boot in under 10 seconds" thing.
Stays working while I disable the pagefile (when you have 20 gigs of RAM, the "pagefile" is a joke) and hibernation (the first two things you need to disable on an SSD boot).
Start the update process... 154 updates... fun. Watch some anime during this.
And she crashes. Windows was fine, get her to start updating again....
Crashes again.
Cocking an eyebrow, I get an idea: Maybe it's the sata controller for Disk0 rather than the HDD like I thought it was.

So I boot from Disk4 instead, and she loads fine. Somewhat quicker than she used to, too. Overnight, I have her xfer over 220 gigs onto my external for backup purposes (also to test the drive, since last time I had her do this she crashed).
She was on, finished backing up, and quietly humming to herself when I checked on her this morning.



SO, I'm thinking the problem is with the SATA controller for Disk0. The question(s) then become:
1) Are the G73Jh's SATA controllers directly on the mobo or are they PCI/PCIe (or some other easily detachable chip)?
2) Irregardless of q1, are they "accessible" from behind the keyboard or will more disassembly be required?
3) Are the SATA mounts behind the expansion slot hardwired to the mobo?
4) Related to 3, would it potentially be possible to change the routing of the current Disk0 to a different SATA controller?
5) Any other fixes I didn't think of that I should try? (replace the controllers, reroute to a non-failing controller)


As a side note, I did manage to accidentally drop her about a foot and a half onto carpet before these problems started... is it possible that I simply jostled something loose? And yes, I did feel absolutely terrible when it happened. There was much apologizing to an inanimate object that day :(

Also, yes, the SSD was working fine when it was using Disk4's controller.


Good news, though, I've already got a 2.5" SSD and good HDD and two 8gig laptop-sized RAM chips. At the rate I'm going, in about a year the next laptop I buy is going to be only a chassis and a mobo, and I'll install all the other parts lol.

numanuk
05-12-2014, 02:39 AM
These ROG laptops are well built. You can beat someone to death with it then play COD on their torso. My rog has been through hell and back been dropped all over the gaffe mainly in the bag though but its fallen off my bed, coffee table when my dog ran past and tripped over the USB keyboard. Just has a few scuffs here and there.

Plug a standard drive into Sata0 not a SSD as this will rewrite alot of times and reduce it's life, Try a 35pass drive overwrite, if it finishes without error then you can rule out Sata controller problems.

I hope you sort it out, I hate these niggling problems