View Full Version : G750JZ GeForce Experience Shadowplay

05-12-2014, 12:33 PM
I was wondering, why shadowplay function is not available after i upgraded to the latest geforce experience app. It says geforce 332.82 driver or later needed. I tried to check for updates using the app but no update is listed. Im currently on 332.60 driver. I enabled the include beta drivers checkmark and installed the available beta driver but performace is horrible especially when playing diablo3. It just wont use the discrete graphics. Can't even select it in the nvidia control panel. Any of you guys have similar problems? Any suggestion would be nice. Thanks :)

05-12-2014, 07:56 PM
Shadow Play is for Desktop GPUs

05-12-2014, 08:14 PM
NOt true :) i have shadow play on my g750 jz... you need 337.50 for it to work


05-12-2014, 11:25 PM
You will have to update the drivers to the beta drivers. Before the update to GeForce 2.0, Asus managed to allow for shadowplay. Then Nvidia released shadowplay for laptops and imposed its own requirements, which did not match Asus' own tweaks.

05-13-2014, 02:36 AM
Thanks for your replies guys :). Much appreciated. I noticed that also, pre 2.0, there was no problem using shadowplay. But after that i need to upgrade to beta which in my case its horrible. Diablo 3 wont work with the gtx880. I guess ill just stick to the orignal drivers and wait for official one that supports shadowplay.

05-16-2014, 02:09 AM
Just an update on the issue. Hope it will help any of you guys having the same problem. This is how i resolved the diablo III not running on GTX880m with the latest NVIDIA beta drivers:

1) Download the beta drivers with the hotfix (v337.60) here:
a.Run the set up.exe file
b.Choose custom installation > click next.
c.Check all the boxes in the custom install options window and also check the box which states "Perform clean install"
d.Restart your computer.

2) Next, install the NVIDIA inspector tool here:

3) After downloading & installing this tool, click on the "Configuration Icon". You will see a list of editable options. In the top profiles dropdown list, select the game "Diablo 3" (or any application that refuses to use the discrete graphics chip) & scroll down to find the option "Enable Application for Optimus"

4) Here you may try different options in the dropdown next to it & try setting it to "SHIM_RENDERING_MODE_ENABLE" . Apply the settings & check if you are able to play the game from the NVIDIA card/NVIDIA control panel.

Doing the steps above enabled me to play diablo 3 without problems. Also, i can use the shadowplay feature now which is great XD. Let me know if this helped you guys.

Cheers :)

05-20-2014, 10:25 AM
Just wanted to say thanks for posting your work around with this issues. I was getting frustrated not being able to change the default graphic option, especially for Diablo 3. Thanks again. :cool:

05-20-2014, 11:49 AM
Thanks Jukkaz for your tip, that's work for me. So diablo problem is solved but the problem remain for Borderlands II. I tried your tip but that didn't work. With this setting : "SHIM_RENDERING_MODE_ENABLE" the game always continue to work with my integrated chipset, I've between 20-30 fps. I tried to disable the integrated graphic chipset, but i wascompletely freeze during the launching of the game (0-1 fps). Maybe I have to try with another setting in the list ?

I've a new G750JZ with GTX880M.

Thanks for your help.

05-20-2014, 12:14 PM
Shadow Play is for Desktop GPUs

When you don't have a clue about something... it's best if you just keep your mouth (hand) shut. Shadowplay is available on mobile gpus already. OP just needed the latest beta driver for it.

05-31-2014, 09:05 PM

Jus wanted to tell You, that after trying everything what was posted on nvidia and blizzard forums, the Jukkaz's solution almost worked fo me :) Almost because I had to add what blizzard wrote on the issue:

"For anyone still experiencing this issue, we'd like to have you try something to see if it resolves it.

In your Desktop App, without any games running, click on the blue icon in the top left to access the Battle.net menu. Click Settings, then Game Settings. Enable the box for Additional command line arguments below the Diablo III: Reaper of Souls entry. Enter the following: -usepageflip and click the Done button below on the right.

Try the game again and see if the issue remains."

After using nvidia inspector and adding -usagepageflip Diablo3 is running like crazy on max details. Thank You very much :)