View Full Version : Rog G75vw BIOS logo gone

05-24-2014, 05:20 PM
Hey guys. Yesterday I decided to do a clean windows install from my genuine windows 8 dvd. Inserted the disk, entered bios...chose to boot first from dvd. The computer restarted and entered directly to bios (?!). Boot options were all gone (though my drives were visible in the sata configuration tab). Restarted the notebook and somehow it entered windows setup. But when I had to choose a drive where to set it up, it wouldn't let me (an eror saying something with mbr). Tried all the things I found on the net and nothing worked. I've managed to format the ssd in my desktop PC and all went smooth. But after installing the windows my BIOS logo (the rog logo that went up in flames) is completely gone and in the bios the option that was controlling the logo's animation is COMPLETELY GONE. I'm running the latest (if you can say so) version of bios available for my g75: v.223

What the hell happened this time to it? Any ideas?

Service up to date: (in 1.5yrs)

-LCD panel replaced
-Battery replaced
-USB ports (left) + USB board replaced
-Motherboard replaced

Monday I'm RMAing it again (5th time) for:
-HDD (making a funny noise and begining to have errors) - needs replacing
-subwoofer terrible noise at some frequencies (getting worse) - needs replacing
-possible (?) motherboard failure (BIOS issue) again

WORST quality/value notebook I've ever had. My last ASUS product :)

05-25-2014, 01:32 PM
See this thread (http://rog.asus.com/forum/showthread.php?28758-GUIDE-G55-G75-Upgrade-Notes&country=&status=) to solve your problem.
Try on boot up hit the Esc key that will bring up a boot menu, there you will select the UEFI DVD to boot from and you will see your drives as that the way they come from the factory UEFI GPT