PDA

View Full Version : G75VX ignores bios "Enter Setup" on boot [solved]



domen.sch
05-26-2014, 08:49 PM
Hi everyone, a new guy here.

I bought my G75VX about a year ago and I love it. There is, however one problem - I can't get into BIOS.

Pressing F2 or DEL after power on causes the laptop to stop responding (booting). Pressing ESC displays a menu 2 options: Boot Manager and Enter Setup. If I select Boot Manager, Windows continues booting. If I select Enter Setup, it does nothing, just refreshes the screen. If I hit Enter Setup again, Windows continues booting - it flat out ignores my selection.

Does anyone have any ideas? I already disabled fast boot. Did I forget something?
Please help me get into BIOS.

Thank you.

Best Regards,
D

__________________________
SOLUTION: Flash BIOS to ver. 206.

domen.sch
05-27-2014, 10:07 AM
I tried to enter UEFI Firmware Settings, but after restart I just get black screen - same as when I press F2 of DEL. I am out of ideas.

Please help.

Regards,
D

-------

edit: After hours of research, it would seem that the problem is in the resolution of UEFI - this is the closest similar problem I could find. (http://www.tomshardware.co.uk/forum/328010-30-bios-screen-blank-screen)

The guy had HDTV connected and UEFI didn't display because of TV's resolution.

This is entirely different story on laptop, though, as LCD is wired directly from graphics card.

Any suggestions?

cl-Albert
05-27-2014, 04:44 PM
Sounds pretty strange to me and can't say that I've ever heard of it before if everything else is running okay.

If you're still under warranty, consider contacting your local ASUS support (http://support.asus.com/Hotlines.aspx?SLanguage=en) to send it back for repair in case there is some problem with the motherboard or motherboard bios.

More ideas to consider are below.

1. Compare your bios version with the latest posted bios version on the ASUS download site for the G75VX. If you run ASUS Winflash in Windows and load a bios file, it should show you the bios version before you flash, but you probably don't want to go through with the flash in case it kills your system.

2. Don't expect it to make a difference if Windows boots okay, but try unplugging your hard drive if you can do this without getting into problems with warranty to see if this makes any difference.
While you are at it you may also want to unplug the battery and any other extra or upgraded items like memory.

Good luck and hope others have some better suggestions.

domen.sch
05-28-2014, 07:55 AM
According to dxdiag my BIOS version is G75VX.204.

Asus page has BIOS 206 available:
Fix the bug that function hotkey Fn+F8 is workable (should be function-less) in setup menu when CSM disable.

But I don't think this pertains to my problem?

I could remove the 2 disks, but I'm afraid that would void my warranty. Would it?

I think I may have to send the computer to the local support company. Is there a way to easily backup my files to external drives and redeploy them later so the support gets only vanilla windows environment? I have some work-related software and confidential files (under non-disclosure agreement), and also a lot of personal stuff on the laptop and I don't want my work and personal files to get into someone else's hands.

domen.sch
05-28-2014, 09:59 AM
I sent a support ticket describing the problem, they suggested flashing BIOS as well.

Since cl-Albert suggested that, too, I gave it a go.

WE HAVE BIOS.

cl-Albert, I love you. No homo. Thank you.

cl-Albert
05-28-2014, 04:12 PM
Glad to hear you could solve it and thanks for letting us know what happened.

It was great that support suggested to flash the bios (while you were still under warranty?).

If you were out-of-warranty, it may not have been worth the risk flashing the bios if the system was still working okay otherwise.

domen.sch
05-29-2014, 10:01 AM
I still have about a year of warranty left but I didn't like the idea of having random people poking around my computer and not being able to use it while they're at it.

To me, not being able to access BIOS is like not being able to pop a car's hood.

No risk, no reward :)