PDA

View Full Version : G73JW Framerate Drop



mikeczyz
10-10-2011, 01:14 AM
Hi guys,

Lately, I've noticed a weird problem while playing games on my G73-JW. A game will boot, run 60FPS just fine and then, about 5-7 minutes in, suddenly experience a 33% drop in framerate. This has happened in both Mass Effect and Call of Juarez. I play games through steam.

I don't think it's scene rendering related because, just now, I booted CoJ and just let it sit there, in-game, for 5 minutes and, BAM, it dropped from 60 to 40 FPS while staring at a wall.

I would really like my frames back! Any ideas?

JRd1st
10-10-2011, 01:17 AM
Check out this thread - http://www.asusrog.com/forums/showthread.php?3322-Sandybridge-Throttle-Issue-and-Workaround

mikeczyz
10-10-2011, 01:21 AM
Thanks for the reply.

I don't know if that thread is applicable. It says that it is for Sandybridge and I am pretty sure my proc is in the Clarksfield family?

irdmoose
10-10-2011, 02:20 AM
It's not a throttling issue related to Sandybridge. I have a G73JW as well, and I don't have those issues. Two things to try: 1) do a clean reinstall of the latest NVidia drivers. 2) Update your other drivers from Asus.

Hopefully that solves the issue. If not, you might need to do a wipe/reinstall of windows. If that doesn't fix it, you will probably need to RMA your laptop.

mikeczyz
10-10-2011, 02:33 AM
Thanks, Moose.

I just spent some time with throttle stop and think that I can eliminate throttling as the root of my problem. I already have fully updated ASUS drivers so will prolly roll with a clean install of Nvidia drivers.