PDA

View Full Version : Disabling The G750JW Subwoofer



Hitchy
05-30-2014, 04:39 PM
Hello guys,

I ve got the Asus G750JW and i wanted to know if there is anyway to deactivate the subwoofer which is located under the laptop. I mean by that only deactivating the woofer (using a setting under windows) but keep the standard speakers going!

The main reason is that starting for a volume level of 70% I noticed that on some Loud Bass the Subwoofer goes like ZZZZZZ (i dont know how to describe) and the sound experience becomes bad... I don t know if u have the same problem but i think that mine is deteriorated.

Thank you for ur feed backs

Prostar Computer
05-30-2014, 08:20 PM
No, there is no way to deactivate it. As far as I know, the sub is not a "dedicated" speaker, and is instead a speaker employing a low pass filter.

Can you tell whether what you're hearing is vibration or distortion?

Asus_Man
05-30-2014, 08:26 PM
You can do that ! Just right click the speaker icon in the taskbar and click on "playback devices". on the "playback" tab right click "speakers" and choose "properties". go to "levels" tab and there you will see the "internal subwoofer" with a slider. move that slider to "0" and you are good to go.

hmscott
05-31-2014, 05:47 AM
Hello guys,
I ve got the Asus G750JW and i wanted to know if there is anyway to deactivate the subwoofer which is located under the laptop. I mean by that only deactivating the woofer (using a setting under windows) but keep the standard speakers going!
The main reason is that starting for a volume level of 70% I noticed that on some Loud Bass the Subwoofer goes like ZZZZZZ (i dont know how to describe) and the sound experience becomes bad... I don t know if u have the same problem but i think that mine is deteriorated.
Thank you for ur feed backs

While there isn't a subwoofer disable switch per se, you could change the Configuration option to set the Front Speakers to Full Range, that should stop low frequency signal from being sent to the Sub - I don't know how effective that will be for you, but it is worth a try.

37222

Axel92
05-31-2014, 07:34 AM
I have this in my settings page
37223

hmscott
05-31-2014, 07:41 AM
I have this in my settings page...

Axel92, you need to feed the low frequencies to the "front" speakers first, so that you don't lose audio - after that, if there is any sound coming out of the subwoofer, sliding to zero should silence it completely. I am hoping when he enabled Full Range audio to the front speakers it will stop the audio to the subwoofer without touching the level setting.

Here it is in English (tabs)

37224

Hitchy
05-31-2014, 05:20 PM
WOW thank you so much guys for ur support i rapidely tested the solution Axel92 and Asus Man proposed and it s already better :) I diminuished the Subwoofer level to 75% and now i can go beyond 85% general volume level without any distortion in the Bass (ZZZzzzZZZ)

I also set the full range speakers option (but honestly i didn t notice much difference with it the subwoofer is still working).

Truely Asus community rocks ;)

hmscott
06-01-2014, 01:22 AM
WOW thank you so much guys for ur support i rapidely tested the solution Axel92 and Asus Man proposed and it s already better :) I diminuished the Subwoofer level to 75% and now i can go beyond 85% general volume level without any distortion in the Bass (ZZZzzzZZZ)

I also set the full range speakers option (but honestly i didn t notice much difference with it the subwoofer is still working).

Truely Asus community rocks ;)

Hitchy, are you using ROG Audio Wizard? You can control the sound there too, and sound shaping through those options helps make the sound richer and more balanced. If you haven't gone into the wizard it might still be involved and the MaxxBass is set too high in the default option. You can also select the OFF template :)

You get into the settings by starting the Realtek HD Audio Manager, Speakers tab, AudioWizard tab, then Launch the Audio Wizard control panel, select the template - then click the obscure looking Gear icon on the top right to get the main knobs / sliders settings control panel. You can adjust the MaxxBass MaxxTreble, and use the sliders on the bottom to shape the Audio.

I would set the subwoofer volume slider back to 100%, and adjust the Bass from the MaxxAudio control panel.

37245

37246

37247

Hitchy
06-01-2014, 11:22 AM
tx hmscott,

In fact i m already using the MaXXaudio wizard and as u can see in the attach the Bass is at minimum.


As already said unfortunately i m pretty sure my Subwoofer is phisically disfunctionnal but tx to ur advices i managed to tweek it by lowering its level to 70% which supressed the ZZZZ sound from loud Bass but without compromising too much the sound experience!

37274

hmscott
06-01-2014, 01:08 PM
tx hmscott,

In fact i m already using the MaXXaudio wizard and as u can see in the attach the Bass is at minimum.

As already said unfortunately i m pretty sure my Subwoofer is phisically disfunctionnal but tx to ur advices i managed to tweek it by lowering its level to 70% which supressed the ZZZZ sound from loud Bass but without compromising too much the sound experience!


Hitchy, that's odd, turning down the MaxxBass that far should have been enough... although I do see the lowest frequency slider is up a tad.

What about Loudness? Do you have that enabled here?

37275

Or here?

37276

Hitchy
06-01-2014, 02:40 PM
Nah for loundness it isn t enabled : should it be? Will it help?

Just tried it out and it just sets the default Windows sounds louder which is in fact annoying since the default sound (when u touch/scroll the volume bar in the bottom right) is the one that makes the ZZZZZ parasite sound when volume is more than 80%.

As I said its a problem with my subwoofer and should keep it low to avoid the problem (and eventually more damage)

hmscott
06-01-2014, 11:26 PM
Nah for loundness it isn t enabled : should it be? Will it help?

Just tried it out and it just sets the default Windows sounds louder which is in fact annoying since the default sound (when u touch/scroll the volume bar in the bottom right) is the one that makes the ZZZZZ parasite sound when volume is more than 80%.

As I said its a problem with my subwoofer and should keep it low to avoid the problem (and eventually more damage)

Hitchy, yes, the point was that it sounded like the subwoofer was being over-driven, and you had already turned down MaxxBass, so something else might causing the over drive, which is why I asked you to check loudness. With this problem - loudness, MaxxBass, and anything else that pumps bass should be turned off, disabled, and turned down.

You should consider returning that G750 to the seller, and getting another one, if you are still in the return period.

Working around the problem is ok, but that is a problem that shouldn't be, and can be repaired.

You shouldn't have to wait for it to be repaired - and if you send it in to Asus, it will be gone for a while, a week to weeks; if you wait to get it fixed - outside the return period - your only choice will be to RMA it to Asus.

Let us know how it works out. :)