View Full Version : Asus G75VX black screen, no bios screen - Where is the BIOS chip?

06-01-2014, 02:23 PM

New member here. I am also a new member of Your-G75-Is-Bricked group haha.

What happened to my G75VX was that during the update phase of a clean installation - I forced it to shut down using the power button because it seemed to be stuck. The next thing I knew it was bricked: black screen and no BIOS option at all. Well I also, in my ignorance, wiped clean the HDDs so I believe the BIOS back-up is gone: when I tried to press Ctrl+Home, the notebook seems to be looking for the back-up because the HDD light keeps on blinking but then the HDD light turns off several seconds after.

I tried other methods: put BIN, AMIBOOT, or whatever in the CD and USB (with the CTRL+HOME combo) - nothing worked. The only thing left I have not tried was putting the BIN file in the HDDs themselves. But I decided to forgo with it and bought a new BIOS chip.

I bought the BIOS chip at BIOS Depot, opened the notebook but... where exactly is the BIOS chip of the G75VX? Can someone provide a picture or what the BIOS' adjacent hardware (Is it beside CMOS? the GPU? CPU?)? A million thanks in advance!


Jose Mikhail

* I apologise for the typo on the title, it is supposed to be G75VX

06-01-2014, 04:10 PM
If the computer is still responding to the keyboard, there is a chance that BIOS recovery will still work. You have to place the BIOS file on a FAT32-formatted USB key and reboot the computer You have to extract the BIOS file directly to the FAT 32 USB Chip, you can't copy the file as you can get an error.
As to where the BIOS chip is located I would think that once you have the actual Chip you shouldn't have any trouble matching it up on your motherboard?

There are a few different thread around of people changing out there BIOS Chip, I can only find this one just now it was for a G73 perhaps there will be some information for you there http://forum.notebookreview.com/asus-gaming-notebook-forum/668404-g73jh-bios-chip-replacement.html

06-02-2014, 04:52 AM
Hi Clintlgm,

You're right about the chip - it is a matter of finding the exact match (shape and size) of the one I bought. Just want to be extra sure - I might be de-soldering the wrong chip haha!

I will try to do a USB flash again - like what you just said. Curious though, what do you mean by extracting the BIOS file to the FAT32 USB? I assume you are referring to the one that can be downloaded from the Asus website (G75VXAS.206)? How do you extract it and not copy+paste directly to the USB? I apologise for my ignorance here.

06-02-2014, 06:25 PM
The files comes as a Zip file and must be extracted to your USB Thumb drive the is already formatted Fat 32

If you extract to your hard drive and then copy paste to your USB you take a chance to having a changed file not a good thing for a BIOS file.

06-02-2014, 08:47 PM
tried other methods: put BIN, AMIBOOT, or whatever in the CD and USB (with the CTRL+HOME combo) - nothing worked. The only thing left I have not tried was putting the BIN file in the HDDs themselves.

If it matters, the bios *.BIN file should be on the hard drive/C drive root directory for the CTRL+HOME combination to work, but it doesn't always work. Probably worth a try if it's not too difficult to arrange though.

Thanks for the clarification and the title has been changed to the G75VX model.

06-03-2014, 06:50 AM
Hi cl-Albert,

Thanks for the note. I am currently doing that one, I have accessed the C; Drive and I have tried it the first time with: G75VXAS.BIN and AMIBOOT.ROM but sadly nothing worked. Maybe it is looking for a certain filename - What should be the file name for the BIOS by the way? I'll try G75VX.BIN this time. More deets to come on my attempts to revive this laptop from comatose.

On the USB FAT32 side, nothing worked so far. Again, the laptop could be looking for a different file name and a file extension.

BTW the warranty has already expired on this laptop so I do not want to opt for an RMA - too expensive.

06-03-2014, 03:58 PM
Hi Josemikhail,

Unfortunately, I don't have a G75VX unit around to check, so we might want to ask G75VX owners running the ASUS Windows image which filename they see on the C: drive when they show the hidden files.

I have tried this procedure on the G75VW before though as mentioned in this post (#32) (http://rog.asus.com/forum/showthread.php?29307-Another-Briked-G75/page4), and the filename was G75VW.bin, so I would try G75VX.bin if you don't get better suggestions.

Also, curious where did you get the bios file? It's probably better to get the *.bin file from the original ASUS Windows image for your notebook model if possible, otherwise, if you are renaming a bios file from the ASUS G75VX download site, try the oldest version you can find since the G75VW.bin file that I was able to flash successfully turned out to be an older version. I also remember trying to rename some newer G75VW bios versions that didn't work with this procedure, but the G75VX may be different.

Not sure if your local ASUS repair office is able to re-flash bios chips without replacing the notebook motherboard, but if you think it's worth the trouble, thought you might want to discuss with them. If you're interested, try this contact page (http://support.asus.com/Hotlines.aspx?SLanguage=en).
I'm still wondering why the system stopped working though and if there is some problem with the bios chip or something else in the notebook.
You might also consider doing some general troubleshooting and removing extra sticks of memory (try 1 stick of memory at a time in different slots), the hard drive, battery, and anything else you don't need just to make sure they aren't related to the problem (I would be sure to check into the memory more).

Anyway, hope this helps and good luck in getting your system up and running soon!

06-04-2014, 01:33 AM
Hi cl-Albert,

Thanks for the response, I appreciate it. I am currently trying to recover the erased files in my HDD - see if I can find that .BIN file for the VX. I'll also try to ask the Asus service department in my place if they can just re-flash the BIOS for me instead of going through the hassle of replacing the motherboard.

I have tried the detaching the CMOS battery - that did not work. I'll consider removing the RAMs although I doubt they are the cause but still I'll try some time.

One probable cause that sent my notebook to comatose is that I attached a mobile WIFI (USB) during the installation/booting phase and if I am not mistaken the laptop tried to boot on that WIFI device. The same device does have a .BIN file in its folder so perhaps the BIOS tried to read that .BIN file. I don't know.

06-04-2014, 02:00 AM
Well, this thread (http://rog.asus.com/forum/showthread.php?30071-Asus-G75VX-Bios-(difference-between-downloaded-version-and-version-already-on-laptop)/page6)surfaced so hopefully I can find something there.

07-26-2015, 04:48 AM
I really need some help.. I had my bios modded to run with uefi disabled and I had a beautiful overclock on the 670mx running good... Then for some reason having uefi off bothered me, so I asked the same person to remake a modded bios for my g75vx to work with uefi enabled so I can oc while in uefi, cause before if I was in uefi I could not oc unless uefi disabled.. Anyways I flashed the newly uefi oc bios and it worked. I was able to boot in uefi and have my overclocks to my 670mx just fine, but 5 hours later after abit of gaming, I decided to install bluestacks, and during install... My laptop froze... And now after a reboot it dosent show screen.. All I see is the keyboard light up as usual and cd drive makes sound, I've tried so much and still can't recover from what I believe is a soft bricked state... I literally just paid 260$ for a new board for this g75vx due to me hard bricking the previous board in here... So if there is anything you can do to help me fix this... Or at least help me confirm that it is not recoverable so I can think of something else... That will be greatly appreciated.. Thank you.

I have removed my hard drives, and in trying to use the home+ctrl method.. No luck so far... I heard u need the bios file on the hdd in order to work but I'm not sure.. I'm using a fat32 USB and idk if I just don't have the right bios file.. Or what is going on..

07-26-2015, 05:23 AM
Did you try this yet?


07-26-2015, 09:43 AM
Did you try this yet?


I definitely want to, so I touch both together? Or just one at a time.. And can I just use a metal object? Such as a small scerw driver?

07-27-2015, 02:45 PM
If it was me I would use solder to bridge the points, a screwdriver or paperclip insulated with electrical tape should work as well.

If you research hard bios resets you'll find a variety of tutorials and videos all focused on the same basic principal. What we are trying to do here is short one or 2 pins of the bios chip. This will cause the bios to default and erase any settings the user has changed. I don't know if this will solve your issue but it's worth a shot.

What you want to do is connect (ie JRST2001) left point to right point then turn on the machine, I would let it sit for about 20 seconds connected. Disconnect and test. Then try the same procedure with JRST2002. You can also tap those connections when it's on (I've seen this work on older dell laptops).

Check out these videos, it will give you a good understanding of what you're going to do.





Worse case scenario you can use a spi flash programmer to reprogram your bios.


Good luck