PDA

View Full Version : Asus RMA is a NIGHTMARE!



Asuks
06-05-2014, 08:13 PM
Good Afternoon Everyone,

I recently bought a G750 (short of 2 months ago - Love this computer). About 2 weeks ago the charger stopped working and there was a slight ringing sound coming from it (sounded like something was loose).

I submitted an advance replacement form a week and a half ago. It was processed last Tuesday (May 27) and i had not heard anything back. I've called multiple times (4 or so) and everytime i'm told to wait patiently as they cannot confirm what is going on with this case. How is it possible that customer service does not have any clue as to what is going on with my RMA?

I called again last Thursday and they informed me that my seriel number was missing from their system. They then had to verify it with the motherboard department.

After speaking to 2 managers, I STILL could not get any information out of them. They always tell me it will be "soon" and in a "timely manner". They refuse to give me an ETA or update on the process.

They claim they have no contact with Bizcom (the servicer responsible for ASUS repairs) other than through email.
Now, me being proactive, I searched out Bizcom's # and gave them a ring today. A man informed me that he received an email YESTERDAY that the case has been processed. He still DID NOT receive an email from ASUS to go ahead and send out the AC Adapter.

How can such a big known company pull this ****? I'm very fed up with the run around. I had to go over Asus' heads and contact Bizcom who gave me more information than ASUS (albeit not much).

Has anyone else experienced this problem? And what can I do to have it resolved quickly?

Thank you!

(Also is there a post requirement to send PMs?)

cl-Albert
06-05-2014, 09:15 PM
Sorry to hear that advanced replacement hasn't gone better.

If you're interested, try to send me a PM at cl-Albert with your RMA number or notebook serial number and I'll look into it more.

Not sure if you were asking about this, but there may be a small delay before new members are allowed to send PMs although I'm guessing you will be able to since your join date shows May 2014.

Prostar Computer
06-05-2014, 09:16 PM
(Also is there a post requirement to send PMs?)

I believe it's 5 posts before that feature becomes available (that's the general rule of thumb on vBulletin forums). It may not be based on post count at all, though. Each forum varies.

Hegemon
06-05-2014, 10:57 PM
Good Afternoon Everyone,

About 2 weeks ago the charger stopped working and there was a slight ringing sound coming from it (sounded like something was loose).



The charger is totally busted. This can be caused by a number of things, most of which are out of your control. Has happened to me many times in the past although not with Asus products. You should get a replacement once the administrative stuff clears up.

Asuks
06-09-2014, 07:26 PM
Thank you all for your help.

I got in contact again with Asus today and my charger should arrive on Thursday.

**on a side note for all those interested - - I was informed by an administrator that it takes 5 posts for PMs to be enabled (although he quickly enabled my account to PM).

Once again thank you all for your help / suggestions and I'll keep you updated!