PDA

View Full Version : 60Hz Screen is a lie? Screen tearing up in World of Warcraft



Master Po
06-07-2014, 01:48 PM
I get huge tears in the screens, really awful! Waves chopped, just big and awful.
Screen isn't refreshing at 60 rate for sure. More like 40?? I don't get .it

My frame rate is 60 when it happens, I even have tried VSync ON and even after that Tripple Buffer.

Still the same, it is something wrong with the screen, but hey. I should had known this :confused:

It's been this with 5 x ASUS G74, same with ASUS G73, same with two ASUS G750JZ that I own.

So that makes me wonder, why?

Never had this issue with Dell laptops and I have owned 10 of them. Different versions.
Two Macbook that I owned, nothing like that on them either.

Just seem to me that ASUS use really low quality screen product for their suppose high quality laptop products...

hmscott
06-07-2014, 09:39 PM
I get huge tears in the screens, really awful! Waves chopped, just big and awful.
Screen isn't refreshing at 60 rate for sure. More like 40?? I don't get .it

My frame rate is 60 when it happens, I even have tried VSync ON and even after that Tripple Buffer.

Still the same, it is something wrong with the screen, but hey. I should had known this :confused:

It's been this with 5 x ASUS G74, same with ASUS G73, same with two ASUS G750JZ that I own.

So that makes me wonder, why?

Never had this issue with Dell laptops and I have owned 10 of them. Different versions.
Two Macbook that I owned, nothing like that on them either.

Just seem to me that ASUS use really low quality screen product for their suppose high quality laptop products...

Master Po, it is a long reported problem, it's not specific to the G750 - or a reflection on the screen refresh rate. The screen refresh is a hardware thing, it is rock stable at 60hz. It's not the screen :)

You turned on triple buffering, but you don't say whether you have *Adaptive* Vsync turned on, also, turn off Vsync inside WoW.

Next try turning OFF Vsync on everything, WoW and Intel/Nvidia control panel VSYNC, and set MAXFPS to 60 in the config file.

Config.wtf
SET maxFPS "60"

More info on settings in Config.wtf
http://wowpedia.org/Console_variables

With an Optimus system, you have a JZ - right?, you might need to set this all in the Intel GPU settings as it is controlling the output now - not the Nvidia control panel - that could be the problem - the Nvidia controller can't set the spec - it has to share control with the Intel Controller - this might take some additional experimentation - and/or bug reporting to Intel.

Some more reading:

Screen Tearing - World of Warcraft
https://www.google.com/search?num=50&safe=off&client=firefox-a&hs=QI5&rls=org.mozilla%3Aen-US%3Aofficial&channel=sb&q=world+of+warcraft+wow+screen+tearing&oq=world+of+warcraft+wow+screen+tearing&gs_l=serp.3...584996.584996.0.586289.1.1.0.0.0.0.7 8.78.1.1.0....0...1c.1.45.serp..1.0.0.KjoF8BCfFRw

Optimus World of Warcraft
https://www.google.com/search?num=50&safe=off&client=firefox-a&hs=Q8P&rls=org.mozilla%3Aen-US%3Aofficial&channel=sb&q=2014+optimus+world+of+warcraft&oq=2014+optimus+world+of+warcraft&gs_l=serp.3..30i10.30301.31259.0.35673.5.5.0.0.0.0 .97.408.5.5.0....0...1c.1.45.serp..1.4.332.SlSCbs_ WA6A