View Full Version : Unable to reset your PC. A required drive partition is missing.

One Sock
06-11-2014, 03:04 AM
I have a G75VX, Windows 8, single 1TB hard drive. I wanted to see if I could convert the hard drive to MBR instead of GPT, so that I can run TrueCrypt system encryption. I booted from the recovery flash drive, ran Diskpart, cleaned the hard drive, converted to MBR, made a couple partitions. I then did "Reset your PC," and it told me, "Unable to reset your PC. A required drive partition is missing." I figured, Oh well, it must be incompatible with MBR. So back to Diskpart, I converted it back to GPT... but when I try to reset, it still gives the same error message. It's the same whether I leave the disk blank, or create some partitions. If I try "Refresh your PC," it says "The drive where Windows is installed is locked. Unlock the drive and try again." What can I do? It seems pretty screwball if the recovery won't work on a clean drive!

06-25-2014, 02:23 AM
Sounds like you accidentally deleted your partition table. Are you familiar with PartedMagic or TestDisk? Both have tools that can help you rebuild the table and make the drive bootable again. Worst case scenario, PartedMagic comes with DD, and you can completely wipe the disk and start over from scratch. If you do that, you'll be wiping the disk back to factory destroying the recovery partition.

One Sock
08-29-2014, 01:25 PM
Sounds like you accidentally deleted your partition table.

No, I didn't "accidentally" delete the partition table. I did it on purpose. The whole point was to do a clean install on a clean drive, partitioned the way I like.

For the benefit of future web hikers, I will go ahead and answer my own question.


1. Boot up from the recovery USB drive and go to the command prompt.

2. At the command prompt, enter the following (note that this will give you a 150 GB Windows partition and a big user data partition; the data partition can be omitted if desired):
select disk 0
convert gpt
create partition primary size=300
format quick fs=ntfs label="Windows RE tools"
assign letter="T"
set id="de94bba4-06d1-4d40-a16a-bfd50179d6ac"
gpt attributes=0x8000000000000001
create partition efi size=260
format quick fs=fat32 label="System"
assign letter="S"
create partition msr size=128
create partition primary size=153600
format quick fs=ntfs label="Windows"
assign letter="W"
create partition primary
shrink minimum=15000
format quick fs=ntfs
create partition primary
format quick fs=ntfs label="Recovery image"
assign letter="R"
set id="de94bba4-06d1-4d40-a16a-bfd50179d6ac"
gpt attributes=0x8000000000000001

3. Now you should be out of Diskpart but still at the command prompt. Copy the recovery images to the recovery partition. Your recovery USB will probably be drive C, and the images will be several install.swm files in the Sources directory. Copy them to drive R. Like this:
cd sources
copy *.* r:

4. Apply the images to the Windows partition:
dism /apply-image /imagefile:install.swm /swmfile:install*.swm /index:1 /applydir:W:\

5. Copy the Windows RE tools to the Windows RE partition:
md T:\Recovery\WindowsRE
cd windows\system32\recovery
attrib winre.wim -h -s -r [use this line only if the next line fails]
copy winre.wim t:\recovery\windowsre\

6. Copy the boot files to the System partition:
bcdboot w:\windows

7. At this point, Windows will boot up, but will look funny. You can now do a Reset Your PC without getting the message about a missing partition, and everything will be back to normal!


When I have more time, I plan on making another attempt to get it to work in MBR instead of GPT :)

09-06-2016, 04:51 AM
I know this thread is 2 years old, but i have the same problem. Windows just won't start. I pressed f9 upon startup and tried every recovery option and it said either missing drive partition or there was a problem resetting your pc.so then I found this forum, and your steps were helpful sort of, but then i got stuck after step 2 on the command prompt. There was no drive C.so then I tried restoring it to factory defaults again and this time it said, recovery disk or installation media needed, which I don't have.so then I tried the option repair startup settings or something like that and the program ran this time but windows still wouldn't start and now f9 doesn't work anymore and I can't get back to the recovery options and I'm in an even bigger mess. Does anyone have any advice for me?

09-06-2016, 07:08 PM
Your recovery partition is either corrupt or gone. Many people delete it and have remorse later. I not only dont delete it, I clone the original drive, recovery partition and all, then pull the original drive and put it away for the aw crap factor!

09-21-2016, 02:55 AM
Oh you are so smart and helpful, no wonder your head is on fire :D.

I have the same problem and my partitions are not corrupt nor gone.
I installed a new SSD and wanted to restore to factory defaults from a USB I created without any problems from a working Windows.
My original HDD works still, but I want to replace it with an SSD.
Well. I get the same error messages when i boot and try to restore from the USB drive.
I did go through all the steps indicated by the very helpful gentlemen three posts ago.
My new Windows restored from the USB following the steps, did start, but since it is not a full recovery version,
I wanted to then restore it to factory defaults. But at about 17% it just throws a message that it was not able to restore.
No explanations, no nothing.

Crappy restore process by ASUS.