PDA

View Full Version : G74SX-3DE IR/ORG key problem



nathalamis
10-13-2011, 12:43 AM
i am having a problem that i cannot find an answer to anywhere in the manuals that it came with or anywhere on the Internet. it is with the ir emitter button that is supposed to turn the 3d games on and off, it does nothing when i press it. i have tryed to us it with multiple nvidia 3d vision ready games and the button dose not work. i have set up device and can get it working but i cant go from 2d to 3d using that button. i have to go to the nvidia control panel to turn 3d on and off, and i cannot change the hot-key there. this is a very crap situation since i have to exit what im doing and go to my desktop and i cant change the hotkey function from the menu.

Screen-17.3" 1920x1080 FDH (Matte-type) 120Hz nVidia 3D Vision w/built-in emitter
Graphics Controller-nVidia GeForce GTX 560M 3GB GDDR5, DX11
Processor-2nd Gen Intel Core i7-2860QM, 2.5-3.6GHz,32nm, 8MB, 45W
RAM-16GB DDR3 1866/PC3 15000 Dual-Channel (4G X 4)

Hohlraum
10-13-2011, 12:53 AM
Big fat ME TOO! on this one. I've got the same laptop as yourself and the show/hide option is disabled and the rog icon button next to power just toggles through the power profiles. so annoyed!

bgmkano
10-13-2011, 08:59 AM
Same problem for me!
Button doesn't work for 3D/2D switch and the hotkey on nVidia control panel is grayed out.

dstrakele
10-13-2011, 01:15 PM
Does the latest 1.0.00013 ATK Package (in http://www.asusrog.com/forums/showthread.php?1150-G73-74-53-Series-Driver-and-Application-Reference) offer you guys any relief? Be sure to uninstall the stock 1.0.0008 ATK Package from Control Panel - Uninstall Programs AND REBOOT prior to ATK 1.0.00013 installation.

chrsplmr
10-13-2011, 01:44 PM
Welcome Nathalamis, Hohlraum and Bgmkano, New ROG Forum Members.

Are you using the latest driver? HERE (http://www.nvidia.com/object/notebook-win7-winvista-64bit-280.26-whql-driver.html) [ver.280.26]
And Here (http://blogs.nvidia.com/2010/03/new-verde-drivers-bring-3d-vision-support-to-notebook-pcs/) is the Official Nvidia Verde page. (If you havent read it.)
3276 (http://www.nvidia.com/Download/PreScan.aspx?lang=en-us) or Automatically Find Drivers (http://www.nvidia.com/Download/PreScan.aspx?lang=en-us)For Your NVIDIA-Powered Notebook.(From Nvidia site Click Logo)

And.. HERE (http://news.softpedia.com/news/Download-NVIDIA-Verde-285-27-Graphics-Driver-fro-Notebooks-221766.shtml) is a beta (@ your own risk) from SoftPedia
Hang in there..Best of Luck..
If there is a different answer to this, someone will be by with it. No Worries.

JRd1st
10-13-2011, 02:15 PM
There's also an ATK 1.0.00014 package here - http://www.asusrog.com/forums/showthread.php?1150-G73-74-53-Series-Driver-and-Application-Reference&p=35001&viewfull=1#post35001

Don't know what's different in it yet, though. If you try it let us know if it helps. :D

bgmkano
10-13-2011, 04:55 PM
Thanks for your welcome!
I use nVidia WHQL drivers 280.26 and ATK 1.0.00014.
No relief :(

Brian@ASUS
10-13-2011, 05:13 PM
unfortunately, the ROG button is for power4gear. 3D will have to be turned on and off through the nvidia control panel.

if you want you can create shortcuts of the 3D vision enable disable and place them in your toolbar or desktop.

3277

Hohlraum
10-13-2011, 05:40 PM
Brian, the issue is that the 'hide/show 3d stereoscopic effects' keyboard shortcut is grayed out. Completely disabling and enabling 3D Vision is something different all together. There are a couple 3D Vision Ready games that won't work with the newest 280.26 WHQL drivers without setting the 3d vision default to 'hide' and then 'show' once inside the game.

nathalamis
10-13-2011, 06:23 PM
updated drivers and still having the same problem. i could care less about rog key if i could setthe hotkey to something other than rog but like everyone else having this problem it is grayed out in the nvidia control.

bgmkano
10-13-2011, 10:29 PM
Brian, the issue is that the 'hide/show 3d stereoscopic effects' keyboard shortcut is grayed out. Completely disabling and enabling 3D Vision is something different all together. There are a couple 3D Vision Ready games that won't work with the newest 280.26 WHQL drivers without setting the 3d vision default to 'hide' and then 'show' once inside the game.

That's the problem!
If we could set the standard CTRL-T command on the panel the issue with ROG button would be forgettable!

bgmkano
10-14-2011, 07:41 AM
unfortunately, the ROG button is for power4gear. 3D will have to be turned on and off through the nvidia control panel.

if you want you can create shortcuts of the 3D vision enable disable and place them in your toolbar or desktop.

3277

So you are saying that ASUS promised and specified in the manual a function that in fact is not present on the notebook?

grungeboy2
10-14-2011, 10:51 AM
starcraft 2 works with 3d vision but the ctrl-t on/off toggle does not work. so far it's the only game i've found that doesn't work right.

grungeboy2
10-14-2011, 10:55 AM
oh, this totally just hit me, and i know it's going to sound dumb, but the hotkeys won't work if stereoscopic 3d is disabled.

1) right click on desktop, go to nvidia control panel
2) on the right there is a column for nvidia 3d vision
3) in there is a tickbox for enable/disable

if the box is disabled 3d vision won't work. the ROG button has always been for toggling through the power4gear profiles.

if the box is enabled, you can still turn it off ingame, via ctrl-t. (except in starcraft 2)

bgmkano
10-14-2011, 12:44 PM
The manual says the ROG button on 3D models is for toggling stereoscopic 3D effects on/off in game.
That's exactly what CTRL-T should do, but on my nVidia control panel the option is grayed out so I can't set or use CTRL-T combination, even if 3D vision is enabled.

JRd1st
10-14-2011, 12:55 PM
I wonder if there's a program you need to install that makes the ROG button function differently when running a 3d app or something.

It wouldn't surprise me if there was such a thing and no one but the engineers at Asus that designed the laptop knew about it.

grungeboy2
10-14-2011, 01:23 PM
dude if the 3d vision tickbox is greyed out or not present, then you may not have a 3d model.

on my G51vx the option isn't there, unless i plug in a external monitor, then the option is there for 3d Discover mode. once it's enabled in the driver Ctrl-T works.

also, and remember this, it's important. Asus is a Taiwanese company, they make great hardware, worst documentation ever.

JRd1st
10-14-2011, 01:31 PM
The 3de IS a 3d model.

Hohlraum
10-14-2011, 01:31 PM
He has a 3D model. Check the thread subject for gosh sakes lol. I have a G74SX-3DE as well with the same problem. Other people are posting on other forums with the same problem. Right now the only option is fully enable/disable 3D Vision and honestly you get better game performance with it completely disabled when not using 3D Vision anyway so its kind of a moot point. My issue with it is that I have a game I WANT to play in 3D Vision that is hosed with the current stable drivers and the only way you can play it is to have 3D Effects (NOT 3D Vision) hidden when the game first launches and then show them afterwards (you cannot completely disable 3D Vision and then renable it inside a game, it won't work. you can only hide/show and have it still work). You cannot hide/show 3D Effects WITHOUT a way to toggle effects (normally done with the disabled control-t shortcut and the ENTIRE POINT of this thread).

grungeboy2
10-14-2011, 01:38 PM
no duh the 3de is the 3d model. but bgmkano never said what model he has.

oh, what i was actually getting at tho, i get sidetracked easily, ok forget the ROG button for a minute.

when you go to the nvidia control panel, is the tickbox for 3d vision enabled or disabled?

it it's disabled the hotkeys get disabled too.

http://www.legitreviews.com/images/reviews/889/driver_control.jpg

edit: nvm i thought hohlraum started the thread, not bgmkano.

ok so assuming you guys have that box enabled and such, what driver versions are you using? asus driver? nvidia driver? modded inf?

bgmkano
10-14-2011, 01:57 PM
I have a 3D model. It's the G74SX-91085V.
3D effect works just fine.
Here's a picture of the problem with the nVidia control panel.
It's in italian language but nevermind.

3278

grungeboy2
10-14-2011, 02:01 PM
so you remapped all the hotkeys, correct?

and when you run a 3d game, nothing? no 3d at all?

also, what driver are you using? asus or nvidia ones? what version?

if you click through the setup wizard, do you get any results? any 3d effect? what about the bottom one that shows the nvidia 3d demo?

also the pull down list for the monitor, any other options there? maybe one for the panel?

grungeboy2
10-14-2011, 02:17 PM
Hi all,
I will have the same problem with my g53jw ix093v (european version of the g53jw-3DE)
Asus support gave me a tip.
1) put the 211 Bios with winflash (if you allready have done it, ignore this step)
2) next enter the bios with F2 go to the EXIT windows and choose "BIOS MANUFACTURED DEFAULT" then F10 and ENTER.
Let windows start, it will re-install something and then TADAAAAAA! It's crazy!!!! it's work!!!

It possible that should work on the other notebook just try.


PS: sorry for my horrible english but i'm french.

This post has been edited by algorus: 30 August 2011 - 05:32 AM

found this on nvidia's site. i'd try it and see if it fixes the issue.

grungeboy2
10-14-2011, 02:24 PM
ok, been reading a bit on the issue. http://forums.nvidia.com/index.php?showtopic=212719

this dude seems to be having the same problem, and the people on the nvidia forums are kind of being dicks to him about it. here's what i gathered from reading tho, some of the older drivers work ok, and the newer 285 beta drivers seem to work ok, but i'm under the impression that the 280.26 drivers DONT WORK properly with it. i still don't know what version of the drivers you guys are using, that could be the issue.

bgmkano
10-14-2011, 02:39 PM
so you remapped all the hotkeys, correct?

and when you run a 3d game, nothing? no 3d at all?

also, what driver are you using? asus or nvidia ones? what version?

if you click through the setup wizard, do you get any results? any 3d effect? what about the bottom one that shows the nvidia 3d demo?

also the pull down list for the monitor, any other options there? maybe one for the panel?

I didn't remap anything.
Those are the standard combinations for hotkeys.
The problem is the first one, that you see grayed out, that should be mapped CTRL-T.
When I play a game 3D works just fine but I'm not able to toggle 3D on and off in games or in movies.
The drivers are 280.26.
The only other option for the monitor is 3D vision discover and it doesn't solve anything.

bgmkano
10-14-2011, 03:36 PM
And here's the page of the manual about the 3D Switch.

3279

dstrakele
10-14-2011, 03:43 PM
Ineresting info in that manual. I can also tell you the ROG key has nothing to do with Splendid on my non-3D G74SX-A1. So that ROG key description in the manual is completely wrong. I understand the issue you are reporting, but unfortunately don't know how to help you. But don't worry, maybe a more knowledgeble person will jump in on this thread. I'd recommend a PM to Chastity@ASUS. She has good knowledge of these laptops as well as gaming issues.

JRd1st
10-14-2011, 04:01 PM
Personally, after reading what grungeboy found I'd try the 285.38 beta Verde Drivers (http://www.geforce.com/Drivers/Results/38110) . I'm no stranger to beta nVidia drivers. I started TweaksRUs.com (now TweakForce.com (http://www.tweakforce.com/) and we used to mod drivers like crazy lol) and nVidia Betas were often the best damn drivers we had!

I'd do the Clean Install option, too.

bgmkano
10-14-2011, 05:34 PM
I've tried the 285.38 drivers.
Nothing has changed.

JRd1st
10-14-2011, 05:36 PM
Did you do a Clean Install? Sometimes settings from the last driver stay behind.

bgmkano
10-14-2011, 05:45 PM
Yes I did.

Alfonsus
10-14-2011, 06:23 PM
Flash BIOS 203.........3D KEY PROBLEM SOLVED.......!!!!!!!

THANKS JRd1st FOR THE INFO....

JRd1st
10-14-2011, 06:28 PM
No problem.

Does it fix the numlock too?

Chastity@ASUS
10-14-2011, 06:37 PM
I think they disabled the hotket Ctrl-T with the NV Ctrl Panel option "Hide stereoscopic 3D effects when game starts"

You can also assign hotkeys to the shortcuts for enable/disable 3D.

bgmkano
10-14-2011, 06:52 PM
Where can I find the 203 bios?

JRd1st
10-14-2011, 07:04 PM
http://www.asusrog.com/forums/showthread.php?1150-G73-74-53-Series-Driver-and-Application-Reference&p=35392&viewfull=1#post35392

bgmkano
10-14-2011, 07:14 PM
Thanks!
I'll try it as soon as I can!

JRd1st
10-14-2011, 07:25 PM
Not sure, but I think you'll need ATK Package 1.0.00014 (http://www.asusrog.com/forums/showthread.php?1150-G73-74-53-Series-Driver-and-Application-Reference&p=35001&viewfull=1#post35001) too.

bgmkano
10-14-2011, 07:44 PM
Installed both and now it works!
Thank you very much guys!!!

grungeboy2
10-14-2011, 10:15 PM
nice. so it ended up being the bios version?

JRd1st
10-14-2011, 10:20 PM
That's part of it. Dunno how much ATK1.0.00014 has to do with it, if anything.

Alfonsus
10-16-2011, 03:41 PM
I think that's part of BIOS 203 Revisions...no need ATK Package 1.0.00014...
http://id.asus.com/Notebooks/Gaming_Powerhouse/G74SX/#download