View Full Version : Asus G750JX, games crashing all the time!!!

06-16-2014, 05:57 PM
Hi guys,

Anytime i play a game, after 15-20 minutes later, the game crashes and this error pops out "DirectxFunction"Get Device Removed Reason" failed with DXGI_ERROR_DRIVER_INTERNAL_ERROR"

I have updated my GTX770m drivers to the latest there is but it still occurs. I have also updated my DIRECTX but it still happens.

This happens to all my games.

Are there any solution to this problem? I am really frustrated.

Prostar Computer
06-16-2014, 11:12 PM
I have not seen that error before. You may want to run some testing utilities on the card, such as Unigine: Heaven or Furmark (stress tests) and/or "video memory stress test" (aptly named for testing video RAM).

Hopefully that is only a DirectX problem.

06-17-2014, 10:36 PM
Where are you getting the drivers from? ASUS, nVidia, LaptopVideo2Go? other?

06-25-2014, 11:35 PM
Here is the same.

I tried with The Forest, game freezes and need to restart after 10-20min. Then tried with Watch_Dogs, game runs for a while then goes to desktop and Windows shows a "appcrash" box or a "vídeo stops and recovered" dialog. So I decided to try with an older games and got this message: DXGI_ERROR_DEVICE_REMOVED.

I tested on a default Windows, on Windows 8.1 and Windows 7. Download drivers from asus site and from nvidia site. Less some Windows 7 drivers. Also, used Windows 8.1 generic drivers. About VGA drivers, I tried some olders and newest and got the same problem.

The max temp registered was 68C. and game crashses with 100% GPU load.

Already tried install directX several times and nothing.

Someone has solved this issue?

I have a G750JX with nvidia GeForce GTX770M.

06-26-2014, 01:18 AM
I have the same problem. purchase an asus g750jx yesterday and all the games I've tried are bad and after a while get errors and crash, and install everything from scratch and the same thing keeps happening. sometimes I get an error saying the display driver stopped responding and recovered. Help please.

06-29-2014, 06:47 AM
Man, this didn't work for me but I have seen people solving this issue with a power usage or GPU fan control settings. Have you tried already?

Did you find another solution?

06-29-2014, 08:38 PM
try to reinstall the directx or even windows