View Full Version : AI Recovery : "Partition does not exist"

06-24-2014, 12:56 PM
Hi there!

Here's my Problem: I have an G55. When I first got it, I removed the original harddrive and replaced it with an SSD (Win7). Now I removed the SSD and put in the original harddrive. Windows 8 does its setup totally normal, no problem here. After that I wanted to save my Recovery files via Asus AI Recovery, but for some reason it keeps telling me, that the recovery partition does not exist.

Of course I tried to find some information about that problem but nothing seems to work:

The recovery partition has no drive letter assigned to it, so there is nothing i could remove
"ChangeHD.exe" does not work either (I guess all it does is remove the drive letter from the partition)
I cannot mark the "Recovery" or the "Restore" partition as active
I cannot access any recovery via function-key when booting up

It's a bit weird, since the partition seems to be there...:

http://i.imgur.com/pyx4R89l.png (http://i.imgur.com/pyx4R89.png)

Maybe someone out there has some more ideas of what I could try next.

Greetings from Germany - NSFW

06-24-2014, 01:28 PM
Okay, I found out that there is a software called "ASUS Backtracker". It is describes as a software that "helps you to back up and recover your system's settings". Does anyone know if it is able to create something like a real backup or does it just save the settings but no actual system files?

06-24-2014, 04:54 PM
Welcome to the forums!

ASUS Backtracker only saves the original ASUS Win8 factory recovery partition and nothing else, so use other software to back up the entire hard drive image if you prefer.

If you or others have not seen it and are interested, you can find a sticky thread about ASUS Backtracker at the thread below, but there may be others.
Backing up your ASUS factory Win8 Recovery Partition (clickable link) (http://rog.asus.com/forum/showthread.php?40548-Backing-up-your-ASUS-factory-Win8-Recovery-Partition&country=&status=)

06-24-2014, 06:15 PM
A backup of the pure recovery is all I need, thanks.

06-24-2014, 07:06 PM
Backtracker finished its recovery backup without a hassle. But now it tells me, that it failed to read or access the USB storage device (although booting was not a problem...). The flashdrive in use is a CnMemory Spaceloop flashdrive (32GB). I guess I'll be trying some different flashdrives now... Coming up next is a SanDisk Extreme USB 3.0 flashdrive (64GB).

06-24-2014, 08:08 PM
USB 3.0 Flash drive may not work since before window USB 3.0 has no drivers. I would stick to USB 2.0 Flash drives.
If you notebook is up and running use Macrium Reflect to create a Disk Image much less hassle than AI Recovery Win 7 or Backtracker Win 8, and faster to restore your disk back to the point you created the Image. The Free Version is all you need for Disk Images.

I'm not sure that backtracker will work, since your original OS Was Win 7 So your AI Recovery disk should put you back to factory shipped condition. I have used mine and that is exactly what they did. Backtracker is designed to create a factory restore from a Window 8 factory image or Restore partition, that you don't have.

06-24-2014, 08:55 PM
My G55 came with Win8 on the HDD I've put in now. My intention is to get that bloody system running off of my SSD. I just wonder why that is such a pain in the a**. Usually I would extract the Windows 8 OEM key from the BIOS and create a clean (free of bloatware) disc/flash drive. But I also want to be able to have some working(!) official recovery for when I am trying to sell my G55 one day in the future.

I really might reconsider buing Asus Laptops in the future though. You pay so much money for top of the line gaming notebooks but it comes shipped with outdated drivers, an operating system with a sh*tload of bloatware and even their tools just won't work as easy as they claim they would. I'm pretty disappointed right now.

06-24-2014, 09:01 PM
I am trying THIS (http://rog.asus.com/forum/showthread.php?26175-Help-with-Windows-8-transfer-on-G75&p=194143&viewfull=1#post194143) method right now.

06-24-2014, 09:03 PM
Not sure if this can help, but if you want to try newer versions of ASUS backtracker, you can find version 3.06 at the link below (I don't believe V3.07 is for normal hard drives) although it's listed under Win8.1 files.


These things aren't too likely to help, but it's easy to restart Win8 and try different USB ports, so probably worth a try if you plan to try again.

Good luck!

06-24-2014, 09:20 PM
Thanks, I will try that first. Also with different USB-Ports, although I did that before.

Also, USB 3.o should not make a big diffence, since Windows 8 does come with proper drivers. (@Clintlgm)

06-24-2014, 09:59 PM
Okay, as you've mentioned: The newer version of backtracker does not work either. I guess Macrium Reflect would do the job, if I leave out the "Data" partition and also shrink down the "OS" partition. But the question is, when I use the system restore (to factory default), what will happen then? We'll see.

06-25-2014, 12:14 AM
Macrium Reflect has some major issues with the partitions of the hard drive, even if I shrink their size. The problem is, that it tries to also fit the unallocated space (I don't even have the option not to) so that those partitions do not fit onto my smaller SSD.

So what the flip is it I that have to do in order to make my system run from the SSD AND have a working recovery? AI Recovery just won't work, Backtracker won't work, Reflect will not work... I could try several other options like TrueImage but slowly I'm getting tired of this sh*t. I've gone far beyond where any "casual customer" would/could go and still the result is disappointing.

06-25-2014, 10:32 AM
Okay guys... Here's what I did:

I downloaded a clean Windows 8 ISO. Then I prepared a flashdrive for UEFI/GPT install and threw the Win8 files on it (a software called RUFUS will do that just fine). After that I installed an mSATA SSD in my G55, leaving out the actual harddrive. Finally I installed Windows 8 with that flashdrive and it worked perfectly. The important thing for me was, that it would read the Windows install key which is stored in the BIOS. Yes, it did recognize the key and turned out to be fully activated after install.

This might not be an official recovery but unlike the crappy ASUS software that does nothing but wasting space at least this works. Important: This only works with a Windows 8 install, but not Windows 8.1! But you can upgrade to that after installation.

I really do like my G55 since the hardware is great. But as soon as it comes to the software side of things ASUS is as crappy as most other manufacturers. You guys should try to make things less bloated and complicated.

06-25-2014, 02:38 PM
All I can tell you is that many people have cloned 750 GB hard drive to 256 GB SSD with out any issues and using the MR free version. And if you create an Image and restore the image to your SSD you will at any point have an easy place to restore to should you have future problems.

Not sure if you received your notebook with from the factory with Win 7 then you can buy a restore to factor disk from Asus Store $50, AI recovery worked for my Notebook.

If your notebook came with windows 8 and backtracker failed as cl-albert said perhaps you didn't use the latest version although I think either version should work

I use True Image on my window 7 MBR BIOS systems, Acronis has advertised since 2012 that they are UEFI GPT compliant this was not true even through 2014 versions they still could not restore a booting UEFI GPT OS drive without jumping through hoops.
MR and Paragon will work paragon you have to pay for MR the free version works for Disk Images or Cloning. You will have to pay for it to back up files and folders

If you corrupted or deleted your original Asus recovery partition there is no way to recover it. That is the reason we create recovery disks first thing after receiving an new notebook and testing that disk set.

06-25-2014, 06:33 PM
My G55 shipped with Windows 8. I did not mess around or even delete the original recovery files. When I first got the G55, I took out the harddrive (replaced it with an SSD) and placed it somewhere safe.

Then I wonder how I am expected to use MR... I tried the cloning method but it just tells me that there is not enough space on the target device (the SSD), even when I deselect all but one partition. It won't give me any option to shrink certain partitions. If I shrink existing partitions manually and then try to clone, I still get the message.

I've looked into different threads on this forum to find out how to use Backtracker and I am wondering what I am doing wrong. I've tried version 3.0.3 and 3.0.6. Although I am able to create a backup flashdrive (no error messages), boot up the recovery, it still tells me that it cannot access the recovery files. I've tried that on all my four USB ports, with and without secure boot and/or CSM, with several flashdrives. After that I can see that the partitions have been created on my SSD, but that's about it.

I know that some people had no problems with moving to a ssd but why do I keep have those problems? I am doing nothing different from what all those orthers did before.

06-25-2014, 06:59 PM
Actualy with your win 8 product key you can clean install windows 8.1, you just need the ISO and a generic key to start the install, I would look for a ISO that has the update 1 embedded too, after the install is complete you use your win 8 product key to activate.

And for you information this forum is comprised of G series notebook user, were all here to help each other. Any comments to Asus made here are just here, Asus doesn't see them.

06-25-2014, 07:51 PM
Goggle reports on "how to use macrium reflect to clone a hard drive to SSD"


Here's a Video http://www.youtube.com/watch?v=duW_jYVCYEg

I have found MR support forum very useful I couldn't actually explain how to do it with the free version as I have the paid for Pro version.

essentially you can't shrink a partition smaller than the space the data takes up. So if you have more data than will fit on the SSD you'll need to make some adjustments before you try to clone. And you do need to clone the complete hard drive all partitions are necessary, except maybe the Asus Restore partition which you no longer have anyway. Another cool thing with MR is after a clean install and all updated you can create an image that will fit on a 32GB USB drive the same bootable drive you boot into MR with. Actualy even some software will fit they have a good compression routine.