View Full Version : G74SX-XC1 Keyboard / Track-pad problems ?

10-14-2011, 02:27 PM
Hello guys. New to the forum; this is my first ASUS computer, and I must say I am pretty impressed by the unit itself, although there seems to be a problem with my track-pad/keyboard, right out of the factory box.

When I unboxed the laptop, and powered it up for the first time - even in the windows first time usage system - I have absolutely no control of my mouse-pad and keyboard. I had to fetch an old Logitech Mouse, and complete the process. As the system booted, and logged into the OS ( Windows 7 ), I still had the same issue.

I managed to read on these forum about the track-pad drivers; which I uninstalled and re installed - to after a few boots, have a perfectly working keyboard and pad. I played around the computer, installing a few things, and rebooting multiple times, without the slightest issue. I then stored the laptop for a few hours - came back to it, and still no problem. I played a little L4D2, found it quite nice on the 1080 screen!

The following day (yesterday) I pop it up after work, and boom - no more keyboard nor track-pad usage. I managed to do my mouse thing, and on-screen keyboard, to read about the ATK Drivers, and the 202 Bios. I installed everything. Tried uninstalling the keyboard drivers, re installing. Again, multiple reboots in the process, and nothing working.

For some reason, tired of looking for the info on my iPhone, I decided to try and read on the Asus Gate Cloud. Once logged in the mini-OS, both they keyboard and track-pad worked perfectly. I figured maybe it was good, so I switched to Windows, and still nothing worked. I continued reading on the matter, and still couldn't figure it out. Wrote a e-mail to NCIX.com support, asking help, or a RMA.

Rebooted, and there you go, everything worked in Windows... NCIX told me to contact Asus tech-support, for they had never have such an experience (but the only review in the laptop's webpage does state "an original keyboard problem with the first unit"). I figured I may want to write on here, to see if anything comes up in this community first, for I have had mixed reviews of the actual Asus tech-support.

As from what I can see, no keys seem to stuck in, or to have too high or low sensitivity. I have read about some keyboards skipping letters, going loco on the track-pad, or similar issues, but nothing with an intermittent-working-in-Gate-Cloud issue, but not always in Windows.

When I power it up, I can access setup with Delete in the first seconds. If it does a check-disk, it does accept my "space-bar typing" to skip. But as soon as Windows logo appears, I lose the lights of the keyboard, and all functionality (when it doesn't work). Also, for some reason, I've had a few "explorer.exe" not responding when logging on Windows. And, it seems when I turn-off the machine, for a brief millisecond, I can see that a process/software is always force-closed, but don't have enough time to actually see what this program is...

Any ideas, or is this juste a Steve Jobs curse, and revenge on my poor soul, for switching from a MBP to this beast ?

Thanks ahead guys.

10-14-2011, 02:32 PM
nah, it's asus's curse for switching to the sentilic touch pads. they seem to be finicky. at some point i believe asus was manufacturing some of the MBP or the boards to em. you've had asus hardware before, most likely.

oddly enough if you crack open a old mac peforma 6100 series you would see AMD chips inside. hows that for full circle.

also, grab a copy of VMWare and you can load up OSX on a Virtual Machine. if you're really interested in getting into it you can get some of the OSX86 copies to run on these things. MacBook Pro? more liek HackBook Pro, amirite?

10-14-2011, 02:38 PM
Try disabling ASUS Web Storage. I've seen reports of that causing EXPLORER.EXE to crash. Let us know if it changes the keyboard and touchpad behavior.

http://www.asusrog.com/forums/showthread.php?4116-G74-strange-issues/page2&highlight=web+storage discusses uninstalling ASUS Web Storage to resolve EXPLORER.EXE crashing on startup.

I've installed BIOS 202 and updated my Sentelic driver to (some G74SX laptops have a Synaptic touchpad, so this may not apply to you), and installed the ATK Package 1.0.00014. My touchpad is working better, but I never had serious touchpad or keyboard issues when I got my G74SX-A1 about a month ago.

10-14-2011, 02:40 PM
Actually, I had a i7 MBP 15" top of the line, for the last year. I decided I wad too bored, and wanted to be able to run my shop's software at home, also being able to play a few games - with decent graphics - without using bootcamp or whatnot.

I must admit that SWTOR did have an effect on me switching back to PC. I use a PC for my Roland printed at my shop, and was tired of going MAC/PC every evening.

So what is there to do with this keyboard thing ? Nothing !? I will have to live with an intermitent keyboard/track-pad for the life of the unit ? They can be sure I will have a RMA my way if that is the case; what's worth of a computer if it works today, and MAYBE tomorrow ?

dstrekele: Thanks, I will definitely try that this evening. I hope it's for the best!

10-14-2011, 09:20 PM
when i got mine straight out of the box, had keyboard and touchpad problems, new drivers will help. I did a new windows install, with all new drivers............... works 90% better

10-17-2011, 07:05 AM
....although there seems to be a problem with my track-pad/keyboard, right out of the factory box.
This really doesn't sound normal....completely losing the mouse and keyboard when Windows loads.

Since the computer is brand new, you probably haven't loaded much of your own stuff onto it yet. So I'd recommend a "do over." ;) I.e., do a complete restore of the factory installation, and then start over from the "Preparing your computer for first use" factory condition. Even with outdated drivers, the keyboard and touchpad should work well enough to set up the computer. If they don't, something is fundamentally wrong. Is it fixable? Maybe. But who wants to bother with a machine that's a problem from the get-go. Return it and get a different one.

To do a factory restore, press F9 during boot-up until the set-up screen appears. Be aware that everything on the OS drive will be overwritten, so if you do have any important files on it, back them up.

10-17-2011, 06:53 PM
Let's try this:

1) Update to BIOS 203, and reset to defaults in BIOS after install

2) Uninstall ATK and Keyboard Drivers and Touchpad drivers, reboot after each

3) Install KB Filter 1.0.0003 first, reboot, then ATK pack .00014, reboot, then Sentelic drivers reboot

10-18-2011, 06:53 PM
I'm having similar problems with my new G74sx, but I have the Synaptics touchpad; do the above instructions apply verbatim to my unit as well? (I've already updated everything to no avail, but the bios I downloaded was 202). Please advise.

10-18-2011, 06:58 PM
Well, you don't wanna use Sentelic drivers, of course . . . read this - http://www.asusrog.com/forums/showthread.php?883-Troubleshooting-ASUS-G73-Touchpad-Problems&p=36094&viewfull=1#post36094