PDA

View Full Version : Asus G72Gx having an unresponsive key issue



GiaantHobbit
06-29-2014, 04:45 PM
Hi,

I have an Asus G72Gx that has served me well for a few years with only minor issues, and this is the first one I have run into that I cannot solve. Recently the "e" key has started acting up. If untouched for a minute or so, it becomes unresponsive until I click it several times repeatedly or really press it hard. It works as normally for a while until it goes untouched again. As an avid League of Legends player, the "e" key is one I use very often and has become an issue in my game play.

-I have tried popping the key off and cleaning out underneath it with no luck, and I have tried popping off other keys to compare the key mechanism and it seems fine.
-I thought it might be a connection issue based on something I read, so opened the computer up to see if I could identify where they keyboard is connected, but the openings underneath do not seem to give me vision of anything like that. I was unable to take more of the case off despite removing every screw I could find, and I didn't want to use too much force and risk damaging the computer.

Help please! Thanks for your time.