PDA

View Full Version : Best size of Windows swap file [virtual mem] for 8GM RAM



xdon82
07-15-2014, 03:00 PM
8GB*

as in topic, any suggestions ?

redduc900
07-15-2014, 04:28 PM
Personally, I would just let Windows manage it. But you might want to check out Mark Russinovich's (author of the Sysinternals tool) blog...

Pushing the Limits of Windows: Virtual Memory
http://blogs.technet.com/b/markrussinovich/archive/2008/11/17/3155406.aspx


The Minimum should be Peak Commit – Physical RAM, and the Maximum should be double that.

dblkk
07-15-2014, 05:20 PM
Typically its recommended 10% I believe. I would leave it on automatic. You really don't have much ram with 8gb. Depending what you all plan to do, you might need to add more as well. I know that Sony Vegas Pro 13, takes 8-10gb alone, just to run. I'm sure that's probably based on a % as well as I have 32gb, but I'm just throwing it out there.

hmscott
07-15-2014, 06:51 PM
8GB*
as in topic, any suggestions ?

xdon82, in a practical sense, you only need as much memory as the software you are running requires. 8GB of RAM can completely fit all the software 99% of us need to have loaded in memory. So you can run without VM / pagefile / hiberfil.sys for RAM sizes 8GB and larger with Windows 7/8/8.1 .

For kernel debugging / dumps, you want to have a 200mb-800mb pagefile, and some software requires a pagefile - if after turning off the pagefile a program complains when you start it, enable 200MB and go up from there as needed.

If you need a pagefile because you need more memory than RAM available, you are already screwed - as performance will drop like a rock when disk paging / swapping becomes a key component of a programs running - you need to buy more RAM, not enable a pagefile :)

Disabling hibernation will also save you space on the C drive, which on SSD's is at a premium. I have saved 64GB on my C drive because I have 32GB of memory the System pagefile/hiberfil.sys were 32GB each. With 8GB of RAM you can save 16GB on your C drive.

Here is how to turn off pagefile, and hibernation:

38906

How to disable and re-enable hibernation on a computer that is running Windows
https://support.microsoft.com/kb/920730

In a command shell, run as Administrator:

powercfg.exe /hibernate off

Now that we have enough real RAM memory to meet the needs of our software / OS's, there is no need to have a pagefile in every day use. If you have an exceptional use that requires a pagefile, you will know it and can re-enable the pagefile sized as needed, otherwise you can disable it and gain back resources without penalty.

Make sure you have enough real RAM to support your needs before turning off the pagefile :)

Can You Get More Space Or Speed From Your SSD?
http://www.tomshardware.com/reviews/ssd-performance-tweak,2911-4.html

Prostar Computer
07-15-2014, 10:36 PM
Some decry enabling the pagefile altogether, but that's not ideal. As fast as RAM is, some applications may need to access the pagefile. It's generally fine to let Windows manage it.

xdon82
07-16-2014, 10:46 AM
I wanted to disable virtual memory because I have installed 8GB fast RAM. but when I did it, I used to get information that I had inssuficent memory, even if there was still 40% available free memory. Sorry for my english ;) please correct my sentence [syntax]

When I set windows to manage it - I saw 8gb virtual memory for 8gb physical mem - I did not get it - it was strange . why so large pagefile ?

Now I have set manually 512-1024MB and it seems ok..but I don't know. I completely do not understand why I get errors when I disable virtual mem while is not fully used

hmscott
07-16-2014, 12:19 PM
I wanted to disable virtual memory because I have installed 8GB fast RAM. but when I did it, I used to get information that I had inssuficent memory, even if there was still 40% available free memory. Sorry for my english ;) please correct my sentence [syntax]
When I set windows to manage it - I saw 8gb virtual memory for 8gb physical mem - I did not get it - it was strange . why so large pagefile ?
Now I have set manually 512-1024MB and it seems ok..but I don't know. I completely do not understand why I get errors when I disable virtual mem while is not fully used

xdon82, what G750 do you have? I did try to look at your previous posts, but after scanning a bunch I didn't see it mentioned...

If you have a JW/JX/JH, you might have program(s) that require a pagefile be enabled. Do you have Windows dumpfile / debugging info dump enabled?

38950

If you have a JM/JS/JZ, it might be this Windows 8.1 memory allocation change + new Intel/Nvidia GPU driver memory leak, still an ongoing issue...

You noted that system managed is allocating a full 8GB pagefile right off, it shouldn't have done more than 2GB to start, which leads me to believe it is likely this problem:

Virtual memory is @ 100% if i run a game at a different resolution than the desktop resolution!
https://communities.intel.com/message/238707#238707

Error when running games: “Your computer is low on memory. Save your files and close these programs.”
https://answers.microsoft.com/en-us/windows/forum/windows8_1-gaming/windows-81-x64-low-memory-while-playing-full/e4602805-a1e1-4704-b006-92f43247b9e8?page=1&tm=1405512200321

Wow, I wonder if this is the problem everyone is seeing with newer Nvidia driver versions BSOD'ing - it might actually be a Windows 8.1 memory allocation + Intel + Nvidia new driver memory leak issue.

The thread mentions a 2TB pagefile allows them to run for hours before BSOD...

Sooo, perhaps now isn't a good time to disable the pagefile on Windows 8.1 :)

You should have been able to disable the pagefile without an issue. The fact that you can't brought about this discovery - which may be linked to the BSOD's everyone is seeing. Making these kinds of optimizations can shake the tree and make visible problems that otherwise would go by mysteriously unexplained.

That threads above had helpful hints I can't test on my G750JH, so one of you with the new JM/JS/JZ will need to figure it out and post the solution.

xdon82, I am guessing the first test would be to enable a fixed pagefile - it seems to only need to be a large size, but doesn't get accessed per se - so you could put it on the 2nd Bay HD drive if you have an SSD boot drive. They mention 2TB, but start with maybe 2x memory size, and see how long it goes before getting the memory error / BSOD.

The other test would be to look at that thread and find the recommended Intel / Nvidia driver that doesn't have the leak. 332.60 is supposed to solve the problem, I wonder if instead an Intel Windows 8 GPU driver + a new Nvidia driver might work... which Nvidia / Intel driver versions do you have installed?

I also saw mentioned of Windows 8.1 update 1 fixing some memory related issues. Have you updated Windows 8.1 completely, including installing the latest Windows 8.1 drivers?

Here is the list I use to find the latest drivers:

G750 support areas - The JM download area has the latest of all the G750, with JS/JZ next, the G750JW/JX/JH are out of date:
http://support.asus.com/Search.aspx?SLanguage=en&keyword=g750&ps=10&pn=1

Here is the latest Notebook Audio - for G750 => Realtek driver package Version V6.0.1.7235
http://support.asus.com/Download.aspx?SLanguage=en&m=Audio&os=30

Here are the latest Notebook Bluetooth drivers
http://support.asus.com/Download.aspx?SLanguage=en&m=Bluetooth&p=3&ft=27&os=30

Here are the latest Notebook WLAN drivers
http://support.asus.com/Download.aspx?SLanguage=en&m=WLAN&os=3

Here are the latest Notebook LAN drivers
http://support.asus.com/download.aspx?SLanguage=en&p=3&s=589&m=LAN&os=&hashedid=n%2fa

Notebook Asus SmartGesture
http://support.asus.com/download.aspx?SLanguage=en&p=3&m=ASUS+Smart+Gesture&hashedid=n%2fa

Notebook ATK Package
http://support.asus.com/download.aspx?SLanguage=en&p=3&m=ATK%20Package&hashedid=n/a

Asus GPU Tweak for Graphics Cards, currently at release 2.6.4.0 for the G750JW/JX/JH
http://support.asus.com/download.aspx?SLanguage=en&p=9&m=ASUS%20GPU%20Tweak%20for%20Graphics%20cards&hashedid=n/a

Asus GPU Tweak for Laptops, currently at release v1.0.9 for the G750JS/JM/JZ
http://support.asus.com/download.aspx?SLanguage=en&p=3&m=ASUS+GPU+Tweak+for+Laptops&hashedid=n%2fa

Here are the Asus posted VGA drivers, it's better to get the latest from Nvidia - currently 337.88, except for the JM/JS/JZ owners you probably want to keep using 332.60 to avoid random crashes - as reported by a lot of people.
http://support.asus.com/Download.aspx?SLanguage=en&m=VGA&p=3&s=111

xdon82, when you are done updating, and have a large fixed pagefile, check out WatchDogs, BF4, or one of the other games that is causing the BSOD on Nvidia drivers newer than 332.60 - I wonder if 340.43 would be usable with a huge pagefile?

xdon82
07-16-2014, 02:30 PM
I have 3 computers with 8GB RAM, 2x Windows 7 and Windows 8.1 on my G56 - the same problem on all - 8GB is not enough when disabled virtual mem :)

hmscott
07-16-2014, 04:02 PM
I have 3 computers with 8GB RAM, 2x Windows 7 and Windows 8.1 on my G56 - the same problem on all - 8GB is not enough when disabled virtual mem :)

xdon82, that's strange, I have disabled pagefile on Windows 7 on a machine with 8GB, and on other machines with 16GB / 24GB / 32GB, and before on Windows 7 with 6GB, and Vista with 4GB, and XP with 1GB, all without problems, so I don't know why you are seeing what you are seeing.

There have been dozens of people disabling pagefile on this forum over the last year, and noone has come back and said it didn't work...except you...

What are you doing differently? :)

What programs are you running when you see the out of memory errors? Or, what errors are you seeing? And, how much memory are you using.

To debug this you will need to provide some details as to what memory is in use, what is running, etc. The more info the better.

There is a memory reserve where Windows complains somewhere between 70%-80% of memory, and there is a way to disable that warning - but then if you push too close to 8GB actual memory used you may crash when out of memory. I haven't needed to do this, even though I run lots of software + VM's - I haven't seen the out of memory errors you are seeing.

You may have loaded software that is requiring pagefile to operate without errors. Can you list what you have installed over and above the OS?

If you can run with 200mb-768mb pagefile, you can save yourself time and just live with it, or spend the time debugging what software is requiring a pagefile, it's up to you. :)

Just to see what happens, on my JH with 32GB I enabled system managed pagefile, and it created a 2GB pagefile. I ran on it for a while, and it is still at 2GB. IDK why your pagefile is jumping up to 8GB right away...

xdon82
07-18-2014, 12:51 AM
perhap you can do it on Windows 7, but not on Windows 8.1 - perhaps specific applications need pagefile - as you said. With SSD drive, little virtual mem do not makes any lags...

why it jumps to 8GB - typically I have many applications running. few png files opened in Fireworks, opened dreamweaver, phpstorm, and about 10-20 web pages, and some applications in modern mode, like mail, skype. :P however everything do not use more than 4-6GB [including Windows components]...so I don't know where is rest 2GB :P and while swap file increases to 8GB if I have still 2GB free.. I think it is bad managing of memory by Windows

recommended pagefile is 4GB for 8GB - this is information from configuration panel.. so it's very strange information made by Microsoft

I just noticed, that one tab with opened page in web browsers takes about 50-500mb of mem - its a lot and strange ??????????????????????

hmscott
07-18-2014, 04:40 AM
perhap you can do it on Windows 7, but not on Windows 8.1 - perhaps specific applications need pagefile - as you said. With SSD drive, little virtual mem do not makes any lags...

why it jumps to 8GB - typically I have many applications running. few png files opened in Fireworks, opened dreamweaver, phpstorm, and about 10-20 web pages, and some applications in modern mode, like mail, skype. :P however everything do not use more than 4-6GB [including Windows components]...so I don't know where is rest 2GB :P and while swap file increases to 8GB if I have still 2GB free.. I think it is bad managing of memory by Windows

recommended pagefile is 4GB for 8GB - this is information from configuration panel.. so it's very strange information made by Microsoft

I just noticed, that one tab with opened page in web browsers takes about 50-500mb of mem - its a lot and strange ??????????????????????

xdon82, if you are using 6gb+ out of 8GB, you should get more memory, and use a pagefile until then - I would switch to a fixed size pagefile after defragging your disk and put the pagefile on the HD not the SSD. You might as well make it an 8GB fixed size.

Like I mentioned earlier you can disable the warnings by removing a few resources from the registry, but you are playing close enough to the limit that I wouldn't remove the warnings.

The extra space is from the OS / disk cache - there are lots of hidden memory demands.

I have trouble living under 8GB too, so don't feel bad, the memory demands keep increasing over time. :)

Let us know when you replace/add memory and when you can disable the pagefile successfully.