PDA

View Full Version : Gaming Headset (Microphone) Issues



gammaRascal
07-19-2014, 11:21 PM
Got my G750 less than a month ago. The first thing I tried were my Krakens. They wouldn't work. I could hear, but the mic just wouldn't work. Works fine on my dekstop and MSI laptop. So I read maybe I should have a set with an amp, so here I am with a pair of Turtle Beach Z22's and the same thing. Except now, with the usb connection - not dual 3.5's - 8.1 is just bugging out. It didn't recognize them at all at first. And when it finally did, I just can't disable the webcam mic at all, and there doesn't seem to be any way to swap default mics. So it's always on and picking up audio unless I level it down. But then the Realtech Audio Manager just won't see the mic at all - teamspeak see's it, but for the few minutes it did work, it was stuttery and really bad quality.

What's going on? How do I fix this?

gammaRascal
07-28-2014, 05:21 AM
Bumping this up from page 5.

Also, if you [reading] can post what headset you use that actually works, at least if I can't get this issue resolved, I can buy a pair that work.

FalconFX
07-28-2014, 12:11 PM
hi, i dont know where the problem might come from, but i use some cheap 20$ headphones with 3.5mm jack, and i must say the sound out of this machine is stellar, amazing, im planing to buy a better pair soon, but with 3.5mm jack too, to take advantage of the soundcard/amp built in to my JH.

tru.kirby
07-28-2014, 02:14 PM
I too wouldn't have the first clue about your problem but I'm using a pair of a astro a50s and they work great, By no means cheap but they do work.

Edit: also I'm using the digital audio out.

gammaRascal
07-30-2014, 06:14 AM
Just to clarify, the audio out is fine. It's the mic in that is problematic. The Krakens sound great, but the mic wont go above a whipser and the TB i bought, when the mic did work it stutters and broken up. The Krakens were via 3.5 and the TB were via USB.