PDA

View Full Version : Got my brand new G750JZ yesterday and already came up with a problem.



Einari33
07-21-2014, 12:35 AM
Dear ROG forums...

So bought the G750JZ yesterday. Everything was going fine, I installed a few games via Steam and it really amazes me how powerful this thing is!
But then! Suddenly when I was playing Arma 3 my mouse stopped working (wireless Asus ROG USB Gaming Mouse). And of course, first I thought it was the batteries. Tried it to my other laptop and it worked fine. Tried many different USB devices to my new Computer without success, none of them worked except the one in the right side which is called "Asus express port" or something.
So, now I have my 1 day old, 2000$ laptop with only one working USB port. I also noticed that some of the upper left corner keys on the keyboard also doesn't work (keyboard brightness adjust buttons etc.).
I already tried to disable USB drivers from Device Manager and even re-installed the whole machine. I hope that it's a driver issue because I really don't want to return this to the retailer because in my country it would take weeks or even months to get a new one. Hopefully someone can help.

Thank you..

Darnassus
07-21-2014, 02:01 AM
Try do a killswitch (hold the button while your computer is on until it dies to a black screen)

Reboot, then check if your USBs are working.

Your mouse may have caused them to malfunction through short circuit.

Einari33
07-21-2014, 03:44 AM
Tried that, didn't work...

Darnassus
07-21-2014, 06:58 AM
Is it just your mouse? Or do all USB components not work with the slot?

Einari33
07-21-2014, 08:18 AM
No it's not just the mouse.

hmscott
07-21-2014, 08:43 AM
No it's not just the mouse.

Einari33, try uninstalling the Asus Gaming Mouse driver, and reboot and let the Microsoft driver load...

Einari33
07-21-2014, 11:10 AM
The mouse works fine. I tried multiple usb devices and none of them worked except in one USB port on the right. And the issue can't be only the USB driver it's probably a chipset failure or factory fault since my utility keys (screen brightness, keyboard backlight etc.) stopped working at the same time as the usb ports.
I'm returning it today to the retailer. Thank you very much for responding and your will to help. I appreciate it :)

hmscott
07-21-2014, 01:41 PM
The mouse works fine. I tried multiple usb devices and none of them worked except in one USB port on the right. And the issue can't be only the USB driver it's probably a chipset failure or factory fault since my utility keys (screen brightness, keyboard backlight etc.) stopped working at the same time as the usb ports.
I'm returning it today to the retailer. Thank you very much for responding and your will to help. I appreciate it :)

Einari33, the point wasn't to break the mouse it was to remove Asus Gaming Mouse driver which has been problematic in the past :)

Also, now that I think about it, remove the Asus Charger+ - it was causing USB failures before - if that solves it then dig in and find a newer version.

No need to take it back yet :)

Darnassus
07-21-2014, 02:36 PM
What video driver are you running, are you on 340? Uninstall and revert back to 337. See if that will help you.