PDA

View Full Version : Unexpected Battery Power-off issue when around 50% on G73JW



jsdvis
08-08-2014, 06:05 PM
I am having an issue with an aftermarket battery for my G73JW. I have tried 3 different batteries with the same problem. After about 20 to 30 minutes of use and with still over 50% of use left the G73 quits working. It is like I pulled the battery out of the compartment. This happens without any warning. It happens with no programs activly running. Just idle with only the desktop showing. Give it a few minutes and the computer will start back up with the same battery in it and do the same thing. I am reluctant to spend the $130.00 for a genuine battery from the ASUS store but maybe that will be my only solution. Does anyone have any thoughts or ideas on what the issue could be.

cl-Albert
08-08-2014, 07:32 PM
It's difficult to be sure, but I wouldn't rule out the possibility of a motherboard problem especially if you have tried batteries from different sources.

Not sure if it makes more sense to send the entire notebook back to ASUS (or somebody else?) for out-of-warranty service, but it's another option to consider just in case it turns out to be a motherboard problem (if you actually want to pay for a motherboard replacement, you may need to check availability though).

If you are moving the notebook around, try letting it sit on a desk without touching the unit as the battery drains just to confirm it's not related to moving the notebook which would indicate one type of motherboard issue, but would not expect the power offs would always occur at 50% battery charge in this case which may still be motherboard-related.

Good luck!

jsdvis
08-08-2014, 08:19 PM
I still have the original battery. It just does not have a lot of capacity left. It does give me a warning when it is low so I can hook it up to AC power. The computer does work fine on AC. It just has this issue on other batteries.