View Full Version : G75VW Keyboard and Trackpad no longer working after BIOS

08-12-2014, 06:02 PM

This problem occurred simultaneously when I wanted to reformat my system. When I am in the BIOS, the keyboard works fine. I can change settings, navigate through menus, and whatnot. When I start an install CD, the mouse and keyboard will work momentarily and then stop, or they won't work at all. I am able to use and external keyboard and mouse just fine though.

Originally, I thought the issue was with Windows, but once I tried to run Debian off of a USB drive, and the same issue happened, so I know it's not operating system specific.

Even though I knew this, I still checked the Device Manager and uninstalled/reinstalled the ATK Package, Synapsis Pointing Device, and Keyboard Filter drivers. The backlight worked fine, but the keyboard and trackpad still did not work.

Prior to this happening, I have had no issues with the G75. I just find it so strange that these components stopped working at the same time I decided to reformat.

My system had Windows 8.1 and the latest version of Ubuntu. If there is any other information any of you guys needs, please let me know. I wanted to come here before I ended up making a service call to Asus just to see if anyone had some insight on this issue.


08-13-2014, 12:18 AM
1. By the phrase "reformat", do you mean you did a clean install of Windows?
2. If so what version of Windows did you install?
3. Did you install the Intel INF driver (Chipset) from the support page for the G75VW?

08-13-2014, 04:09 PM
Thanks for your reply.

1. I completely reformatted the hard disk that the operating system was on, and attempted to reinstall Windows 7.

2. Windows 7, Windows 8, and Windows 8.1. I tried one, it didn't work, and I tried the next OS to see if that would help.

3. Yes, I installed that driver each time I tried a new operating system.

08-13-2014, 07:50 PM
If tyour notebook came with windows 8,
go into your BIOS and turn off Secure Boot and turn on CSM

It sounds to me that you are trying to use BIOS MBR disk to install to a UEFI system. Try again after you make those changes in your BIOS
on boot up Hit the Esc Key, that will bring up a Boot Menu, In this boot menu select UEFI DVD or UEFI USB however you have your media set up.
That should allow you to install to your Hard Drive.
See this sticky post (http://rog.asus.com/forum/showthread.php?28758-GUIDE-G55-G75-Upgrade-Notes&country=&status=)all the information you need is there

08-14-2014, 01:06 AM
Hey folks. So quick update... I probably should have given you guys more information regarding my system.

This machine was pre-loaded with Windows 7. My BIOS version is 223, so it does not have the option to select SecureBoot. I have always used MBR based partition to install Windows 7 and 8.

When I got home today, I decided to start trying to work on the laptop again. I was able to navigate through the BIOS for about 10 minutes, making sure all the options were properly set. Afterwards, I did a boot overide (MBR) into my Windows 7 Ultimate CD. I was able to use the keyboard and trackpad to delete the previous partitions and start fresh again. I was then able to start the install process. Shortly after choosing my install partition, both the keyboard and trackpad did not work again.

I will connect my external mouse and keyboard to continue the process and see what installing the chipset driver will do.

Thanks again for all your advice so far.

08-14-2014, 03:10 AM
Okay guys, I have great news so far. I downgraded the BIOS to version 222, at the keyboard and trackpad are indeed working way past the point where they normally cut out. Thank you for all your help guys, I really appreciate it!

08-14-2014, 04:09 AM
I know myself, and Clint are both using BIOS v.210!
We see no benefit on the newer BIOS versions.
There are many horror stories here on the forum, about bricked NBs from updating the BIOS to versions v.221, v.222, and v.223.
(I guess the BIOS update didn't complete fully, and bricked there systems)
I have tested all versions, and v.210 works the best for me!
IMO, I would downgrade to v.210