PDA

View Full Version : Strange sort of dead pixels - enough for an RMA?



Jaitsu
08-15-2014, 05:21 AM
I've been noticing one of these strange dead pixels for weeks, and have been trying to ignore it - but now that I really spend a moment searching, I've found that I have no less than six.

But they aren't the typical "dead pixel" or even subpixel, they don't show up against a pure white/black/grey background. But against a dim, red background, five fully-bright red dots appear, and against a dim green background, one fully-bright green dot appears.

Photos (apologies for the blurriness, camera doesn't like focusing this close:

Some of the red pixels:
http://i.imgur.com/UUrZRxy.jpg
http://i.imgur.com/p8GAe2c.png


It seems as though the pixel isn't "stuck" on or off, but it's somehow about 3 times as bright as it should be. Is this enough to qualify for an RMA? I don't want to play the game of "send it in, lose everything on my hard drive and have no laptop for a week, then get it back as-is because there's 'nothing wrong with it'."

Jaitsu
08-18-2014, 10:12 PM
Bumping to call some attention to this. I'd like to get this fixed, as it's juuust noticeable enough to be distracting at times when playing games or watching movies.

hmscott
08-18-2014, 10:31 PM
Bumping to call some attention to this. I'd like to get this fixed, as it's juuust noticeable enough to be distracting at times when playing games or watching movies.

Jaitsu, file a Technical Inquiry with Asus, with a zip of photo's showing the various angles/modes that the pixel problems show best, and just ask Asus for an RMA, do it now :)

https://vip.asus.com

Create a login, register your laptop, and file a Technical Inquiry asking for an RMA to replace the LCD.

Please come back and let us know how it works out :)