PDA

View Full Version : Asus G750JW World Of Warcraft Chopy/Laggy



Daani
08-22-2014, 09:43 AM
Hi guys I bought Asus G750JW I7 4700HQ, 6GB Ram, GTX 765M. I only play world of warcraft and my settings are on high with sunshaft, liquid and shadow on low or fair and multi sampling on x4 but in game every few minutes in combat or moving around i feel there is a lag and choppy freezing type movement its not smooth like it should be any advice? I have updated to latest nvidia graphics driver.

Any advice would be appreciated.

Daani
08-22-2014, 01:15 PM
Bump some help would be appreciated

Nate152
08-22-2014, 01:21 PM
Hello Daani,

Are you using anti antialiasing? If so turn it off.

Turn off multisampling.

In Nvidia control panel set max pre-rendered frames to 2.

Enable vertical sync.

How does it play now?

Daani
08-22-2014, 01:57 PM
reply feels better but why do I have to turn all these settings off I thought a machine like this can handle it. I have left multisampling in wow settings on x4

Nate152
08-22-2014, 02:09 PM
It's give and take, you just have to set your settings to where you are happy with performance.

Daani
08-22-2014, 09:40 PM
I still have choppy gameplay i dont understand what is wrong

Nate152
08-22-2014, 10:56 PM
Are you gaming with the power cord plugged in?

Daani
08-23-2014, 07:51 PM
yes of course

Nate152
08-23-2014, 07:59 PM
Are you gaming with the gtx 765m or the onboard cpu graphics?

Daani
08-23-2014, 08:33 PM
i hope its the gtx 765m how would i check thanks

Daani
08-23-2014, 09:02 PM
its really annoying random lag spikes and game goes choppy every few minutes

Nate152
08-23-2014, 09:21 PM
You can check that it is enabled in the bios. I'm not familiar with your bios so you will have to search in your bios until you find gtx765m. Your manual should tell you if you have one.

If it is already enabled it sounds like you might be having a heat issue which is causing it to throttle down hence the choppy gameplay.

Arcturus Fyr
08-25-2014, 07:32 AM
Is it possible for you to check if your Nvidia Control Panel is working? If so, we can rule out it being disable in the BIOS, do you have any obstructions near your laptop heat exhaust?

I you can check your NV Control Panel, try setting the game in the control panel via the "Manage 3D settings" option to "High-performance NVIDIA processor".

This may not be as important, but did you use an OEM driver or Generic Driver for your GPU? The generic diver would be the driver you get from NVIDIA and the OEM from the ASUS driver download page our particular model.

I heard that if the model itself uses Optimus technology, the drivers that are needed for both cards (integrated and discrete) to acivate properly in scenarios of which they would activate (desktop vs playing a game) have to be OEM. Nvidia and Intel claims that the best way to make sure things are working properly between the discrete gpu card and integrated one is to have the OEM drivers installed vs the generic ones.

Although I've installed generic drivers on laptops that use optimus technology without any issues, but who knows?

Hope this helps.
-Arcturus Fyr

Boby Joe
08-31-2014, 11:49 PM
Had the same issue and went into the Killer wireless application tab and put World of Warcraft as Highest priority. Also look to block any programs that you don't want auto updating during gameplay causing lag or latency issues.

Hope this helps if you haven't fixed the problem yet.