PDA

View Full Version : 5.1 surround from laptop to TV via HDMI doesn't work



Scave
08-23-2014, 10:39 PM
Here is my question on SuperUser. (http://superuser.com/questions/802145/5-1-surround-from-laptop-to-tv-via-hdmi-doesnt-work)

I have an ASUS G75VX with an NVidia GeForce 670MX card. I have it hooked up to my Sony Bravia xbr55x850 via HDMI. The Bravia is hooked to a Visio 5.1 surround system via Optical. Here is what my output device looks like:

http://i.stack.imgur.com/ASHI1.png

When I try to configure it, I get the following options:

http://i.stack.imgur.com/lCsjp.png

When I test either of the bottom two (one is for side surround channels) it outputs both rear and front to the front. The subwoofer test makes no sound at all.

Does anyone have any ideas how to make this work?

Clintlgm
08-24-2014, 03:44 AM
Maybe try using the Mini Display port either direct or adapted to HDMI??? Just a shot in the dark I really have no idea.

GottiBoi55
08-25-2014, 12:53 AM
Have you tried restarting you NB after you changed the settings to HDMI?
Sometimes that will work (works for me), leave HDMI hooked up then restart your NB.
You can also try the fn+f8, or try the windows key+p.

Hope any of these suggestions help!

taz291819
08-26-2014, 02:58 PM
It's because of the way you have it hooked up. The TV won't pass 5.1 uncompressed to your receiver.

You have two options:

1. If your receiver has HDMI inputs, connect the laptop to it, and then connect the receiver to the TV via HDMI.

2. If your receiver doesn't have HDMI inputs, use S/PDIF out of the laptop to the receiver for audio, and HDMI out of the laptop to the TV for video. (Note, this option will only give you surround when playing something that has been encoded to Dolby Digital or DTS, as S/PDIF only passes 2-channel uncompressed).