PDA

View Full Version : Asus G50JX Display Driver Crashing!!! Help Needed



shank
08-24-2014, 04:02 PM
Hey Guys, I have had the Asus G750JX GTX 770M for 8 months now. After the few months of my purchase, i had no problem what so
ever with this laptop i game on it all the time.

Couple of months ago, when i play certain games like Assassins Creed Blag Flag or Watch_Dogs, after few minutes of gaming, the game freezes up and i get this Error:

DirectX function "GetDeviceRemovedReason" faild with
DXGI_ERROR_DEVICE_HUNG: Device hung due to badly formed commands.. GPU: "NIVDIA GeForce GTX770", Driver 340.52

Note: This only happen with certain games. I can play Battlefield 4 Vanilla maps with no problem but when i try to play the Expansion
Pack Maps i get this error.

This is really annoying so can someone please find me a solution to this problem. RMA is not an option for me because its way passed the RMA period.

An alternate solution will surely be appreciated.

redduc900
08-24-2014, 09:42 PM
Try reverting to the latest official drivers available on the Asus support site.

shank
08-25-2014, 07:53 AM
I have done that too. It still occurs at random times while gaming..

tobelyan
08-25-2014, 11:01 AM
https://www.youtube.com/watch?v=roVB3TleVDY watch this video, then check videodescription for your videocard!

shank
08-25-2014, 12:28 PM
The video is for desktop GPU not for laptop

redduc900
08-25-2014, 04:08 PM
See if any of the suggestions in this thread over at the EA BF4 forum are of any help...

BF4 DirectX function GetDeviceRemovedReason failed with dxgi_error_device_hung
http://answers.ea.com/t5/Battlefield-4/BF4-DirectX-function-GetDeviceRemovedReason-failed-with-dxgi/td-p/1663657

shank
08-27-2014, 07:32 AM
See if any of the suggestions in this thread over at the EA BF4 forum are of any help...

BF4 DirectX function GetDeviceRemovedReason failed with dxgi_error_device_hung
http://answers.ea.com/t5/Battlefield-4/BF4-DirectX-function-GetDeviceRemovedReason-failed-with-dxgi/td-p/1663657

I tried it but im still having the same problem. :(