PDA

View Full Version : Asus Orion left sound issue



Animal1995
08-30-2014, 01:42 PM
I recently purchased the Asus Orion PRO headset.
It arrived this morning but I was dissappointed to find that no matter how I try to configure this I cannot get anything to come from the left speaker, and I am in fact hearing ALL sound in the right.
All my pan settings are set to the middles and im running an ASUS Z87-A motherboard.
Anybody know how to fix this? Thanks in advance!

ghostron
10-14-2014, 05:59 PM
i have the same problem just today i need help badly , i think its a lose solder , may i know how do i open up my headphone? i know how to solder dont worry :)

C4RN1
12-28-2014, 01:35 AM
Sorry I'm late to the party guys, my headset lasted a bit longer than yours did.

I created a tutorial today, and I'm going around searching trying to find people that have been affected by this issue.

Here's the link to the tutorial I created.

http://rog.asus.com/forum/showthread.php?55507-Rog-Orion-Gaming-Headset-Repair-Tutorial&p=461279

Darkgoo
01-04-2015, 04:18 AM
Sorry I'm late to the party guys, my headset lasted a bit longer than yours did.

I created a tutorial today, and I'm going around searching trying to find people that have been affected by this issue.

Here's the link to the tutorial I created.

http://rog.asus.com/forum/showthread.php?55507-Rog-Orion-Gaming-Headset-Repair-Tutorial&p=461279

Im sitting here with my faulty orion "pro" headset on my lap. Im pissed beyond believe. Left speaker stops if i move my head or wiggle the cable. I wouldn't know how to explain how careful i'm with my stuff, this feels like a 20 or $20 earbud set.

Once again its the community, creative people with problems that give quick and efficient support to others in the same situation. Thank you so much C4RN1 for making that thread. I'll get right on it and try to fix this crap.

I'm even more pissed because a few months ago i got another set for my wife which im sure in time will fail just as well.