View Full Version : G74Sx Slimtype BD (Blu ray drive) issue

08-30-2014, 04:24 PM
This is a problem I've had since nearly the beginning of my time with this machine, dating back to December of 2011. *waves wiggly fingers and boos like a ghost*

I love this computer to bits. It's awesome. I run 3 monitors off of it and do a ton of work on it. This is the only real huge issue I've had with it (with the exception of updating the BIOS and having to unplug one monitor to update graphics drivers).

In said December, I noticed my blu-ray drive wasn't doing what it said on the tin (playing Blu-rays). Moreover, it also didn't play any CDs or DVDs. We decided to talk to Asus support, and they had us bring it in to the manufacturer to see if they could fix it. I got it back about a month later with the description "No problem found" listed on the drive. Later that year, I got a macbook pro (because the college I was going to required it), and also bought an external superdrive, because Apple was stupid and didn't include an internal drive for disks on a computer largely used in post-production. Since then, I've been using that for all my disk viewing, playing, and work.

Fast-forward to about a month AGO. I got a Wacom Intuos tablet that works beautifully with everything else my computer pumps out. This was the last time the drive had worked with any sort of disk, that disk being the one installing the drivers and software for my tablet. I then had to move back to my parent's place, thus dragging along all my gear. I've tried every kind of disk you could think of since then (We're talking the past couple weeks). The same exact thing happens with every disk: Pop in the disk, see the light go on for 2 seconds, and then see the light go out. Nothing more. No fancy sounds, no recognizing a disk.

I've just tried the "Go into Device Manager and try reinstalling the drive via uninstall and reboot" technique, and that didn't seem to work. So are there any other ideas besides taking an otherwise perfectly good machine to the manufacturer and them telling me I haven't had any problems and nothing's wrong with something that clearly doesn't work?

Specs are:

Intel processor i7-2630QM
CPU@ 2.00GHz (so I haven't overclocked it. It's still at default)
Display Adapter: NVIDIA GeForce GTX 560M