PDA

View Full Version : Bizarre framerate issues with some games.



georgeli94@yahoo.com
09-06-2014, 01:35 AM
So I have a Asus G750JW (great computer, btw) for a while now (been lurking in these forums to try and figure out a solution to my issues, with no success so far), and games were running very well for the most part. However, for some odd reason, in these past few months, games have started to dip FPS in certain areas. I have absolutely no idea why. These games ran fine before, but now they're running slow. Not everywhere, mind you, but in certain areas, even for games that should be able to run at a consistent 60fps. Right now, Doom 3 slows down a bit at certain areas, and the only mods I've downloaded were texture packs and a particle effects mod, and even when I removed the particle effects mod, the game STILL dipped a bit in FPS (Mostly in areas with lots of smoke or explosions or something), like when two Revenant rockets detonate in my face (that causes enough of a dip that it'd bump my framerate down to 30 with vsync on and sometimes even with vsync off). And this is a game that's 10 years old that I ran completely fine beforehand. That's not even getting into the huge dips in framerate in a game released 10 years later, like Wolfenstein The New Order. That game was running quite well, but in these past few months, the game was also starting to slow a bit.

I've fiddled around with different nVidia drivers, I've tried changing the compatibility, and I've tried changing the files and tweaking the settings best I could, but I still can't get these random dips in framerate to go away. Once again, it's not all bad, but these little dips can get very annoying, especially when these games worked perfectly fine a few months ago.

I'm starting to suspect that it has something to do with Windows 8.1. It was around the time I upgraded to 8.1 did I really notice a lot of these issues, but I have no idea how to rollback (Windows 8 came installed on my computer and I upgraded to 8.1 via the Windows store).

If anyone knows anything, whether it be a driver, a way to go back to Windows 8, or any other solution, it'd be appreciated. It's not a big deal, but if there's a solution, I'd love to know it.

Thanks everyone for the help.

EDIT: Don't know how relevant this is, but I also have issues with an external hard drive that has a very unreliable connection, even when I switched cables. It would take me several insertions in order to get the hard drive to function, and sometimes the connection breaks if I so much as move it. I think this is further indication that something's wrong and I'd like some help, please. Thanks again.

hmscott
09-06-2014, 04:31 AM
So I have a Asus G750JW (great computer, btw) for a while now (been lurking in these forums to try and figure out a solution to my issues, with no success so far), and games were running very well for the most part. However, for some odd reason, in these past few months, games have started to dip FPS in certain areas. I have absolutely no idea why. These games ran fine before, but now they're running slow. Not everywhere, mind you, but in certain areas, even for games that should be able to run at a consistent 60fps. Right now, Doom 3 slows down a bit at certain areas, and the only mods I've downloaded were texture packs and a particle effects mod, and even when I removed the particle effects mod, the game STILL dipped a bit in FPS (Mostly in areas with lots of smoke or explosions or something), like when two Revenant rockets detonate in my face (that causes enough of a dip that it'd bump my framerate down to 30 with vsync on and sometimes even with vsync off). And this is a game that's 10 years old that I ran completely fine beforehand. That's not even getting into the huge dips in framerate in a game released 10 years later, like Wolfenstein The New Order. That game was running quite well, but in these past few months, the game was also starting to slow a bit.

I've fiddled around with different nVidia drivers, I've tried changing the compatibility, and I've tried changing the files and tweaking the settings best I could, but I still can't get these random dips in framerate to go away. Once again, it's not all bad, but these little dips can get very annoying, especially when these games worked perfectly fine a few months ago.

I'm starting to suspect that it has something to do with Windows 8.1. It was around the time I upgraded to 8.1 did I really notice a lot of these issues, but I have no idea how to rollback (Windows 8 came installed on my computer and I upgraded to 8.1 via the Windows store).

If anyone knows anything, whether it be a driver, a way to go back to Windows 8, or any other solution, it'd be appreciated. It's not a big deal, but if there's a solution, I'd love to know it.

Thanks everyone for the help.

EDIT: Don't know how relevant this is, but I also have issues with an external hard drive that has a very unreliable connection, even when I switched cables. It would take me several insertions in order to get the hard drive to function, and sometimes the connection breaks if I so much as move it. I think this is further indication that something's wrong and I'd like some help, please. Thanks again.

georgeli94, it sounds like dips in framerate due to system slowdown, usually due to something else running at the same time - disk indexing, av / anti-spyware scanning, or in your case if you are running material from that flaky disk enclosure/cable - glitches slowing down disk access.

Quite often new slowness over time is from disk lag due to fragmentation. Are you loading the disk / material from the internal or external flaky disk?

PerfectDisk is what I use for HDD and even SSD Optimizing - PerfectDisk has an Optimize SSD template for SSD's

Here are a couple of links to threads with details/results - reading all the thread would be helpful:
http://rog.asus.com/forum/showthread.php?50964-IRST-Install&p=430846&viewfull=1#post430846
http://rog.asus.com/forum/showthread.php?46574-Degrading-RAID0-SSD-performance&p=396693&viewfull=1#post396693

If you are running games from the HDD, then also try quiethdd - it stops pauses due to APM.

https://sites.google.com/site/quiethdd/

Put these config lines in the quiethdd.ini file

FirstRun = 0
AC_APM_Value = 255
DC_APM_Value = 255
AC_AAM_Value = 254
DC_AAM_Value = 254
AAMEnabled = 1
APMEnabled = 1

It will also stop the clicking from the head parking noise.

If wiggling around the cable causes the drive to go on/off line, something is flaky in the USB socket(s), the cable, or the enclosure. I would stop using that set up and move the disk to a new USB socket on the G750 first, then swap for a new USB 3.0 enclosure.

Please come back and let us know how it works out :)

georgeli94@yahoo.com
09-06-2014, 04:48 AM
georgeli94, it sounds like dips in framerate due to system slowdown, usually due to something else running at the same time - disk indexing, av / anti-spyware scanning, or in your case if you are running material from that flaky disk enclosure/cable - glitches slowing down disk access.

Quite often new slowness over time is from disk lag due to fragmentation. Are you loading the disk / material from the internal or external flaky disk?

PerfectDisk is what I use for HDD and even SSD Optimizing - PerfectDisk has an Optimize SSD template for SSD's

Here are a couple of links to threads with details/results - reading all the thread would be helpful:
http://rog.asus.com/forum/showthread.php?50964-IRST-Install&p=430846&viewfull=1#post430846
http://rog.asus.com/forum/showthread.php?46574-Degrading-RAID0-SSD-performance&p=396693&viewfull=1#post396693

If you are running games from the HDD, then also try quiethdd - it stops pauses due to APM.

https://sites.google.com/site/quiethdd/

Put these config lines in the quiethdd.ini file

FirstRun = 0
AC_APM_Value = 255
DC_APM_Value = 255
AC_AAM_Value = 254
DC_AAM_Value = 254
AAMEnabled = 1
APMEnabled = 1

It will also stop the clicking from the head parking noise.

If wiggling around the cable causes the drive to go on/off line, something is flaky in the USB socket(s), the cable, or the enclosure. I would stop using that set up and move the disk to a new USB socket on the G750 first, then swap for a new USB 3.0 enclosure.

Please come back and let us know how it works out :)

Thanks for responding. The games are on the built in hard drive. That's why the external hard drive thing was added in as an edit. So I don't think it's the flaky disk edit. Also, I know it slows down when the game starts heating up (you know, combat situations with lots of explosions, projectiles, and other particle effects), but I don't know if background processes are hurting my computer's ability to process those effects. When moving normally through the environment, the framerate continues to be silky smooth.

Now I have checked the fragmentation of the disk with the windows defragmenter, and it came up with 0% fragmented, but I don't know how reliable that one is.

But the point is everything game related is on the internal hard drive, so I'm gonna try and fiddle around with your suggestion that a background program is screwing up my game.

Now regarding the external hard drive issue: I have moved the hard drive around the various usb ports, as well as replacing the cable once. So far, it's still far from reliably connecting. So I'm guessing it's either something wrong with the hard drive itself or something in the computer.

Thanks again for your help!

hmscott
09-06-2014, 06:00 AM
Thanks for responding. The games are on the built in hard drive. That's why the external hard drive thing was added in as an edit. So I don't think it's the flaky disk edit. Also, I know it slows down when the game starts heating up (you know, combat situations with lots of explosions, projectiles, and other particle effects), but I don't know if background processes are hurting my computer's ability to process those effects. When moving normally through the environment, the framerate continues to be silky smooth.
Now I have checked the fragmentation of the disk with the windows defragmenter, and it came up with 0% fragmented, but I don't know how reliable that one is.
But the point is everything game related is on the internal hard drive, so I'm gonna try and fiddle around with your suggestion that a background program is screwing up my game.
Now regarding the external hard drive issue: I have moved the hard drive around the various usb ports, as well as replacing the cable once. So far, it's still far from reliably connecting. So I'm guessing it's either something wrong with the hard drive itself or something in the computer.
Thanks again for your help!

georgeli94, skip the Windows defragmenter, and use the PerfectDisk free trial to do a SMARTOptimize on the boot disk / game disk, it doesn't cost anything.

If you have been installing/uninstalling for months, it can help.

You described the Bizarre Framerate issues as "certain areas" are now described as "when the game starts heating up - combat situations with lots of explosions" - it's more like FPS slowdowns during complex scenes, which is more Normal than Bizarre :)

A JW is awesome, but it has it's limits. Have you been upgrading the Nvidia drivers as Clean Installs? That clears out all Nvidia tweaks or settings you may have set - that is part of the Clean in Clean install - it clears out the preferences.

You can re-set the highlighted in Yellow settings that will improve Nvidia performance:

40825

You can also set them in the game/app - here is 3dmark as an example:

40826

Don't forget to set the global setting to use these settings:

40827

You can get a nice fps bump by tuning the GPU/memory frequency with Asus GPU Tweak Tool for Graphics cards - for the JW/JX/JH

Asus GPU Tweak for Graphics Cards, currently at release 2.6.9.0 for the G750JW/JX/JH
http://support.asus.com/download.aspx?SLanguage=en&p=9&m=ASUS%20GPU%20Tweak%20for%20Graphics%20cards&hashedid=n/a

Here are the settings I used on my JW as a guideline, start at the same GPU speed, but a bit down on the memory speed:

40828

Ignore the voltage setting, it doesn't do anything.

You can also get a little bump by unlocking the multi's on the CPU with Intel XTU. Set the Cores to 36x,35x,34x,34x and CPU cache to 36x

Intel XTU
https://downloadcenter.intel.com/SearchResult.aspx?lang=eng&keyword=xtu

Once that is set, try the game(s) again :)

If you still get FPS drag, try either installing the newest Nvidia driver 340.53 as a Custom=>Clean Install (set the Nvidia preferences again) or go back a version or two until you get the smooth FPS you remember - sometimes Nvidia driver upgrades downgrade some game performance - bugs get introduced.

Let us know how it works for you!

georgeli94@yahoo.com
09-06-2014, 03:27 PM
georgeli94, skip the Windows defragmenter, and use the PerfectDisk free trial to do a SMARTOptimize on the boot disk / game disk, it doesn't cost anything.

If you have been installing/uninstalling for months, it can help.

You described the Bizarre Framerate issues as "certain areas" are now described as "when the game starts heating up - combat situations with lots of explosions" - it's more like FPS slowdowns during complex scenes, which is more Normal than Bizarre :)

A JW is awesome, but it has it's limits. Have you been upgrading the Nvidia drivers as Clean Installs? That clears out all Nvidia tweaks or settings you may have set - that is part of the Clean in Clean install - it clears out the preferences.

You can re-set the highlighted in Yellow settings that will improve Nvidia performance:

40825

You can also set them in the game/app - here is 3dmark as an example:

40826

Don't forget to set the global setting to use these settings:

40827

You can get a nice fps bump by tuning the GPU/memory frequency with Asus GPU Tweak Tool for Graphics cards - for the JW/JX/JH

Asus GPU Tweak for Graphics Cards, currently at release 2.6.9.0 for the G750JW/JX/JH
http://support.asus.com/download.aspx?SLanguage=en&p=9&m=ASUS%20GPU%20Tweak%20for%20Graphics%20cards&hashedid=n/a

Here are the settings I used on my JW as a guideline, start at the same GPU speed, but a bit down on the memory speed:

40828

Ignore the voltage setting, it doesn't do anything.

You can also get a little bump by unlocking the multi's on the CPU with Intel XTU. Set the Cores to 36x,35x,34x,34x and CPU cache to 36x

Intel XTU
https://downloadcenter.intel.com/SearchResult.aspx?lang=eng&keyword=xtu

Once that is set, try the game(s) again :)

If you still get FPS drag, try either installing the newest Nvidia driver 340.53 as a Custom=>Clean Install (set the Nvidia preferences again) or go back a version or two until you get the smooth FPS you remember - sometimes Nvidia driver upgrades downgrade some game performance - bugs get introduced.

Let us know how it works for you!

I know it's normal for really graphically intensive games, but this is a game from 2004 (so I should have more than enough power to run the entire thing at full specs with zero slowdown), and not only that, but it was working perfectly fine before. That's why I thought it was bizarre. I have rolled back drivers before and performed clean installs. The problem still persists.

I have also overclocked both my GPU and my CPU, so I don't think that's an issue as well.

I'll try your defragmentation idea. Maybe that'll work.

Thanks again for the reply.

hmscott
09-07-2014, 03:38 AM
I know it's normal for really graphically intensive games, but this is a game from 2004 (so I should have more than enough power to run the entire thing at full specs with zero slowdown), and not only that, but it was working perfectly fine before. That's why I thought it was bizarre. I have rolled back drivers before and performed clean installs. The problem still persists.
I have also overclocked both my GPU and my CPU, so I don't think that's an issue as well.
I'll try your defragmentation idea. Maybe that'll work.
Thanks again for the reply.

georgeli94, did you check your Nvidia 3D settings as above? They do get cleared each time you do a Clean Install of the Nvidia drivers.

What you are describing could also be a crashed Nvidia driver - it runs at 1/10 speed after crashing, until you reboot, so even an old game will slow down as you describe.

I understand what you are saying about an old game that should be 100's of FPS, so I would monitor FPS with FRAPs or? and monitor GPU/memory speed with GPU-Z to see if the GPU clock dropped, like after a driver crash.

georgeli94@yahoo.com
09-07-2014, 06:36 AM
georgeli94, did you check your Nvidia 3D settings as above? They do get cleared each time you do a Clean Install of the Nvidia drivers.

What you are describing could also be a crashed Nvidia driver - it runs at 1/10 speed after crashing, until you reboot, so even an old game will slow down as you describe.

I understand what you are saying about an old game that should be 100's of FPS, so I would monitor FPS with FRAPs or? and monitor GPU/memory speed with GPU-Z to see if the GPU clock dropped, like after a driver crash.

Defragging made it better from what I tested afterwards, though I'll have to give you a conclusive report later. Also, I have performed clean Nvidia installs several times, so I don't believe that's the issue. I think it may have been fragmented drivers, but I'll be back if the problem persists.

Thanks a bunch for the help.

EDIT: I fiddled around with the settings a bit and apparently, turning off Shader Cache boost my framerate a bit for Doom 3. I'm really wondering why, considering the description for Shader Cache doesn't really mention any benefits for turning it off, and you'd figure a shadow heavy game like Doom 3 would work well with it. Is there something wrong with Shader Cache and older games? Or maybe just OpenGL games (most id games are OpenGL based)?

EDIT 2: I changed my Texture Filtering -Quality setting to "High Performance" and got an even bigger boost. Why did that happen? What does this setting do? Does it significantly affect texture quality? I haven't noticed much of anything, but the framerate boost was quite significant. What's strange is that I've always left it on "High Quality" with no issue before, but now it's starting to have issues with various games.

EDIT 3: Ok, this is really weird. If I keep my original Nvidia settings for what I had previously, and then change the game to run in windowed mode instead of fullscreen, the problem goes away and the framerate stays at a silky smooth 60 fps, including areas that would drop in frames if I so much as stare at it. I did not change anything else but changing to windowed mode and the resolution is the exact same. Does anyone know what's going on?

hmscott
09-08-2014, 01:22 AM
Defragging made it better from what I tested afterwards, though I'll have to give you a conclusive report later. Also, I have performed clean Nvidia installs several times, so I don't believe that's the issue. I think it may have been fragmented drivers, but I'll be back if the problem persists.

Thanks a bunch for the help.

EDIT: I fiddled around with the settings a bit and apparently, turning off Shader Cache boost my framerate a bit for Doom 3. I'm really wondering why, considering the description for Shader Cache doesn't really mention any benefits for turning it off, and you'd figure a shadow heavy game like Doom 3 would work well with it. Is there something wrong with Shader Cache and older games? Or maybe just OpenGL games (most id games are OpenGL based)?

EDIT 2: I changed my Texture Filtering -Quality setting to "High Performance" and got an even bigger boost. Why did that happen? What does this setting do? Does it significantly affect texture quality? I haven't noticed much of anything, but the framerate boost was quite significant. What's strange is that I've always left it on "High Quality" with no issue before, but now it's starting to have issues with various games.

EDIT 3: Ok, this is really weird. If I keep my original Nvidia settings for what I had previously, and then change the game to run in windowed mode instead of fullscreen, the problem goes away and the framerate stays at a silky smooth 60 fps, including areas that would drop in frames if I so much as stare at it. I did not change anything else but changing to windowed mode and the resolution is the exact same. Does anyone know what's going on?

georgeli94, now we get to game specific issues :)

Fix for the OpenGL issue. Should work for most of you.
http://steamcommunity.com/app/208200/discussions/0/864949037794399234/?l=english

That's the first hit on the google search for doom 3 windowed vs fullscreen mode

https://www.google.com/search?num=50&safe=off&q=doom+3+windowed+vs+fullscreen+mode&spell=1&sa=X&ei=xAQNVJfhBtTYoAT__4LYBg&ved=0CBwQBSgA&biw=1023&bih=551

When you finally derive the optimal settings for Windows/Nvidia/Doom3 please post the summary :)

georgeli94@yahoo.com
09-08-2014, 01:38 AM
georgeli94, now we get to game specific issues :)

Fix for the OpenGL issue. Should work for most of you.
http://steamcommunity.com/app/208200/discussions/0/864949037794399234/?l=english

That's the first hit on the google search for doom 3 windowed vs fullscreen mode

https://www.google.com/search?num=50&safe=off&q=doom+3+windowed+vs+fullscreen+mode&spell=1&sa=X&ei=xAQNVJfhBtTYoAT__4LYBg&ved=0CBwQBSgA&biw=1023&bih=551

When you finally derive the optimal settings for Windows/Nvidia/Doom3 please post the summary :)

Changing r_fullscreen to 3 didn't work. Changing Texture Quality to High Performance did, but I used to have it on High Quality with zero issues before.

I'm seriously beginning to suspect it might have something to do with Windows 8.1...

EDIT: Well, I finally figured it out. I went into the config files again and changed some things around. I made sure image_roundDown was set to 1, and the issue went away. I remember screwing around with the settings a bit a few months ago, and completely forgot about it. Well, it seems like the issue was solved, for the most part.

Thanks a ton for the help!

hmscott
09-08-2014, 01:42 AM
Changing r_fullscreen to 3 didn't work. Changing Texture Quality to High Performance did, but I used to have it on High Quality with zero issues before.
I'm seriously beginning to suspect it might have something to do with Windows 8.1...

georgeli94, that first link was an example, not necessarily the final answer. There have been Nvidia driver updates since that thread was started in 2012, as well as Windows updates, and even game changes - so there is likely a progression of "fixes" over time that you can track to your present configuration for the current optimal solution(s)/tweak(s).

Game tweaks / problems are something best resolved in that game support forums or sites dedicated to that game.

georgeli94@yahoo.com
09-08-2014, 01:50 AM
georgeli94, that first link was an example, not necessarily the final answer. There have been Nvidia driver updates since that thread was started in 2012, as well as Windows updates, and even game changes - so there is likely a progression of "fixes" over time that you can track to your present configuration for the current optimal solution(s)/tweak(s).

Game tweaks / problems are something best resolved in that game support forums or sites dedicated to that game.

Yeah, I probably should've gone there, but while Doom 3 was the main game that was having issues, I've been having some issues with other games as well. It seems defragging and putting Texture Quality to High Performance fixed most of those issues.

Thanks for the help, once again!

hmscott
09-08-2014, 01:53 AM
Changing r_fullscreen to 3 didn't work. Changing Texture Quality to High Performance did, but I used to have it on High Quality with zero issues before.

I'm seriously beginning to suspect it might have something to do with Windows 8.1...

EDIT: Well, I finally figured it out. I went into the config files again and changed some things around. I made sure image_roundDown and useCompression were set to 1, and the issue went away. I remember screwing around with the settings a bit a few months ago, and completely forgot about it. Well, it seems like the issue was solved, for the most part.

Thanks a ton for the help!

Awesome! :)

hmscott
09-08-2014, 02:02 AM
Yeah, I probably should've gone there, but while Doom 3 was the main game that was having issues, I've been having some issues with other games as well. It seems defragging and putting Texture Quality to High Performance fixed most of those issues.

Thanks for the help, once again!

georgeli94, thanks for asking, and please do ask specific game questions here too - it helps to ask on the hardware support forum too, as specific issues might exist, but the game sites have insights across lots of hardware types and you might find things there that you won't find here, and visa versa.

Those 3 Global Nvidia settings are simple yet effective. I often forget myself to reset them after a new driver clean install, but when I run the first benchmarks to check out the new driver performance I notice the drop in performance, and then remember to go back and make the changes, reboot, and voila! big boost in performance :)