PDA

View Full Version : Battery and mini-DisplayPort issues with new G550JK



rblt550
09-09-2014, 08:17 PM
Bought a new G550JK less than three months ago, and last week the battery indicator in the windows 8.1 taskbar began displaying something like "battery not present" and the orange light on the front of the laptop was flashing orange as if the battery was extremely low.

Laptop was running on line power at the time, so I unplugged it and it continued to run although the above to symptoms did not change. I contacted the retail store where I purchased the laptop and they advised me to restore windows to factory config ( thus losing all my apps/data ) and if the symptom persists, bring the laptop back for potential exchange.
They also suggested removing the battery and re-inserting it but I reminded them that the G550JK does not have a consumer removable battery.

I did completely power cycle the laptop a few times and the orange light continues to flash but the windows task bar battery indicator now displays "82%, plugged in, not charging".

I have some critical path work that I am using the laptop for at this moment, so not able to restore to factory windows install just yet, so I wonder if this is a known issue that may have been addressed with a firmware update, etc.?

Also, this G550JK is replacing a DELL XPS laptop that supported two unique displays on external monitors by way of a VGA and an HDMI port. As the G550JK has an HDMI and a mini-DisplayPort, I am using both of them for my extended display, however the mini-DisplayPort is extremely difficult to get working ( using a mini_DP to HDMI adapter ). After the laptop is power-cycled, or returns from sleep, or even unlocking the screen lock, I can spend 30+ minutes trying various sequences of plugging in the two monitors, power-cycling the monitors, etc. to finally get the mini-DisplayPort to work. The only way I can expect to quickly resume work after being away from the laptop ( and having some semblance of securing the windows session ), is to have the laptop "do nothing when lid closed", close the lid and power off the external monitors - then when I return, I power on the monitors and open the lid to an unlocked windows session which continues to display on both monitors.

The two monitors are identical and the mini-DisplayPort issue follows the mini-DisplayPort connection, so is not monitor or HDMI cable related ( could be mini-DisplayPort to HDMI adapter, or the mini-DisplayPort itself ).

I have not used mini-DisplayPort before, but I sincerely hope that I can get it to readily connect to a display, otherwise this G550JK will not be usable in my required dual external display environment.

Any suggestions/comment on the above to issues ( battery and/or mini-DisplayPort ) would be greatly appreciated.

Thanks in advance!