PDA

View Full Version : Overclocking utilities not working with G-sync on



gridironcpj
09-10-2014, 02:45 AM
Hey guys, I just picked up my Asus ROG Swift today and I've come across a bit of an issue. MSI Afterburner and EVGA Precision X cause Battlefield 4 to crash when G-sync is enabled. If I turn G-sync off, there are no problems and the software work fine. Has anyone else come across this issue and does anyone know of a fix? I've updated each utility to their most recent versions. My GPU setup is two GTX Titans in SLI.

class101
09-10-2014, 10:36 AM
A lot reported out of range issues in BF4, some people seems to actually workaround this by downgrading the nvidia driver, try the 337.88 clean install

gridironcpj
09-11-2014, 04:43 AM
Thank you for your advice. Before downgrading to the driver you mentioned, I tried out my other games. Everything else seems to work okay, except the following:

- Battlefield 4 runs perfectly fine with G-sync enabled if I do not have an overclocking utility running (most likely due to Rivatuner). I prefer playing with my cards overclocked and my own custom fan profile.

- 3D Mark 2013 is capped at 60FPS, making it a useless benchmark with this monitor. This is regardless of having an overclocking utility running.

- Unigine benchmarks have the same issue as Battlefield.

After downgrading the driver, nothing has changed. Also, I have noticed a few annoyances with G-sync. It seems to just act as v-sync, as it forces my GPUs clocks and usage to go down just to keep the FPS below 144. Unfortunately, the FPS drops a bit lower when the demand suddenly increases. Grid 2 usually runs well-over 144FPS, but is stuck between 100 and 143 FPS with G-sync. This seems like a cheap way to get "smooth" gameplay. Additionally, Batman AO and ACIV Black Flag run like complete **** with G-sync enabled due to the downclocking. I am quite disappointed with G-sync, but I do love this monitor, as 144Hz at 2560x1440 is what I've wanted for a very long time. Does anyone have any fixes for the problems I've mentioned?

jgonz
09-13-2014, 12:53 AM
I am running MSI Afterbuner with all my games especially BF4 with gsync and 144hz. No issues here. My 680 SLI set up is running at default clocks and I have a custom fan profile. Using latest nvidia drivers. No crashing at all.

class101
09-15-2014, 12:51 PM
This seems like a cheap way to get "smooth" gameplay.

Yes exactly that is for what it is designed for as far I have read, G-Sync benefit is seen when you run high demanding games configuration and you fps rate is inside 30-60. But if you top near 144 fps it is probably not worth to activate,

At least for me if you ask me I will never consider playing without G-Sync again huhu. It is a blast for playing on highest quality possible never rendered at 144fps anyway without a costly SLI.


I am running MSI Afterbuner with all my games especially BF4 with gsync and 144hz. No issues here. My 680 SLI set up is running at default clocks and I have a custom fan profile. Using latest nvidia drivers. No crashing at all.

For me except in DayZ I can't have it to work properly for a long period, it enables fine but from time to time I get the screen flickering, but DayZ is in Alpha and not really well optimized and I'm playing with high settings so one of them is probably causing this, haven't really played that much to see how one setting can impact the gsync renderer, so currently I'm disabling gsync for that game as quick workaround. Else I have tried in GTAIV, Left 4 Dead 2 and Dead Rising 3, no problems, very useful for DR3 when a GTX780 on high quality can only get a ~50fps max

With 340.52 drivers, I never downgrade too I prefer to wait for futur nvidia drivers and I disable G-Sync for the game in the control panel if any problem is found.

With Msi Afterburner overclocking utility

//edit: Found a way to stabilize G-Sync flickering in DayZ, just had to downgrade to 120MHz and now no more flickering all so smoother than before, so happy ;)

icikk
09-16-2014, 11:04 AM
For OP:
First of all please understand how and why g-sync is working.

As stated on other threads:
High FPS = Turn off G-sync, Turn on ULMB
60 FPS = Turn on G-sync

G-sync on = FPS Stucked between 100-143 FPS is normal and it should work this way. You can never get higher than 144FPS with gsync on. Why? Gsync send frames created by GPUs to monitor at exactly same refresh rate which then removes stuttering and tearing etc.

3D Mark capped @60FPS - you're probably running it in 1080p resolution with G-sync on. For more accurate numbers run on native resolution, For exact numbers you need to disable G-sync completely