PDA

View Full Version : G750JZ no power, I have no idea what happened.



alexophobia
09-21-2014, 06:35 PM
I'm actually considered computer-stupid and have no idea what I did wrong, it was fine when I was using it halfway then my g750 just turned off. Thinking it was a random restart, I tried to turn it back on, but I can't even press the power on button. Not even a sound or anything. I'm really confused and this laptop is only 2 months old. Did I do something wrong with it?

chrsplmr
09-21-2014, 07:00 PM
Welcome to ROG.

You didn't say what you were doing 'halfway' when it turned off.
Does the 'brick' get warm ? Is there power to it ?
Take the battery out with it unplugged and push the power button ..
then plug it in and try to boot it.
What were you doing ? Gaming ? Did it get real hot ? or was it (excuse me for asking)
on a pillow or something ?
I really think its a power issue.
Best of Luck. Keep us 'Posted'. .c.

hmscott
09-21-2014, 07:30 PM
I'm actually considered computer-stupid and have no idea what I did wrong, it was fine when I was using it halfway then my g750 just turned off. Thinking it was a random restart, I tried to turn it back on, but I can't even press the power on button. Not even a sound or anything. I'm really confused and this laptop is only 2 months old. Did I do something wrong with it?

alexophobia, are you using your G750 on battery, or is it plugged in? Check to make sure the cord didn't get kicked / worked out at the laptop / adapter / wall - it almost sounds like you ran out of battery and the laptop shutdown.

Which G750 do you have? I have a G750JH

alexophobia
09-21-2014, 11:18 PM
Welcome to ROG.

You didn't say what you were doing 'halfway' when it turned off.
Does the 'brick' get warm ? Is there power to it ?
Take the battery out with it unplugged and push the power button ..
then plug it in and try to boot it.
What were you doing ? Gaming ? Did it get real hot ? or was it (excuse me for asking)
on a pillow or something ?
I really think its a power issue.
Best of Luck. Keep us 'Posted'. .c.

Hi thanks for your reply.
Yes I was gaming, the brick was warm in a sense, the same temperature it has always been whenever I use it.
Yes there was power to it.
Tried, no response at all.
No the laptop was on top of a table.
I'm not so sure either, am I the only one that experienced this?

alexophobia
09-21-2014, 11:21 PM
alexophobia, are you using your G750 on battery, or is it plugged in? Check to make sure the cord didn't get kicked / worked out at the laptop / adapter / wall - it almost sounds like you ran out of battery and the laptop shutdown.

Which G750 do you have? I have a G750JH

Hey, it was both on battery and plugged in, the brick was untouched, it is definitely not "ran out of battery"
G750JZ

hmscott
09-21-2014, 11:26 PM
Hey, it was both on battery and plugged in, the brick was untouched, it is definitely not "ran out of battery"
G750JZ

alexophobia, it's not supposed to do that then :)

You can file a Technical Inquiry with Asus with the details you provided here, and ask for an RMA to debug / fix the problem.

It sounds like a part(s) failure while powered on. If it won't power back up, there isn't much you can do.

You could try to find another power adapter and battery and swap them in to see if one of those two items failed, but it is likely problem is in the laptop motherboard - or some other internal component.

You will most likely need to send it all in to Asus for debugging and repair.

The only other thing I can think of to try, is to pull the battery, unplug the AC adapter, and press and hold down the Power Button for 30 seconds, and see if a power reset helps.

You can create a login here, register your laptop, and file a Technical Inquiry for RMA here:

https://vip.asus.com

Please come back and let us know how Asus treats you and how long it takes to get RMA'd and back to you fixed.

Bdtry
09-22-2014, 07:46 AM
I kind of had the same thing happen the day before. Laptop just turned off.

I don't think it shutdown since it never did all of the "Shutting down" screens but just turned straight off when I was playing a game. When I pushed the power button a little bar of text came up (before the ROG logo) that said "Upgrading/Updating system" or something like that. It was not the normal windows update thing. After that it turned off (just dead) and then restarted and went through the normal windows update "configuring updates" stuff.

Darnassus
09-22-2014, 08:38 AM
Alex have you tried holding the power button down for 5 seconds+ (hard)? ;x

amitabhbansal
09-22-2014, 06:10 PM
it happened with me but with sony vaio, and i found the solution like Darnassus said, but the difference is, Unplugged it, remove battery and hold down the power button for 1 minute, then insert the battery and plugged it then try power on, if it doesnt work then u have to hold the power button for 2 minutes, i worked with me many times, i hope u also get it worked,
if 1 minute and 2 minute doesnt work then try power on on battery only if not then plugged in power on, this is what I know, if nothing works then u have to visit support center

pokerface
09-22-2014, 07:53 PM
happened to me as well on my previous G750JX, it just died, ASUS had to replace the motherboard for me which took 7 days to order