PDA

View Full Version : New g74sx not booting



Gemt
10-25-2011, 10:48 AM
Hey,

I just picked up my new G74SX, but was deeply dissapointed when I noticed it wont boot.

When starting it, the Power on lamp is glowing, but the HDD lamp only blinks once before it goes dead. The monitor never seems to come on.

I tried to change the HDD just in case, as I bought an SSD to use with the computer, but no change. I also tried to remove one by one of the two RAM sticks, but no luck there either.

I was wondering if there are anything else I could try before inevitably sending it back where I bought it. I would very much prefer not to do that as it would probably mean several weeks of waitin :(

Any input is appreciated.


Edit:
My G74sx is the version with following specs:
120Hz 3D monitor (1920x1080)
I7 2670QM CPU
8gig ram
500gb SSH

JRd1st
10-25-2011, 10:59 AM
Try removing the other HDD. Or the other ramstick.

Either way, return it for an exchange.

Gemt
10-25-2011, 11:06 AM
Tried changing the hdd and the ramsticks as I mentioned.

Depressing kickoff with new laptop

BrodyBoy
10-25-2011, 11:18 AM
If you have a bootable CD (like maybe a Windows installations disc), try booting from that.

Gemt
10-25-2011, 11:24 AM
No able to open bios or anything. The monitor looks dead.

JRd1st
10-25-2011, 11:31 AM
Did it boot before you tried changing components?

Gemt
10-25-2011, 11:33 AM
Yes. Took it out of the packing, plugged the power adapter inn, tried to start it but nothing. Then I started changing components etc just in case, but no luck. I dont suppose there are any reset buttons for bios/ram or anything I can try?

JRd1st
10-25-2011, 11:37 AM
Remove the battery and try with just the adapter.

If that doesn't work, remove the charger cable and depress the power button for a full minute. Then try the adapter again.

I'd really get an exchange, dude. You shouldn't be paying $1600 more or less for a problem unit.

Gemt
10-25-2011, 11:47 AM
Tried this as well. Seems I just have to send it back inn and cross fingers it wont take too meny weeks to get a new one... Norwegian customer support is not the best in most of these cases :p

JRd1st
10-25-2011, 11:49 AM
Send it to the retailer.

Post their name here if they give you problems. ;)

Good Luck!

BrodyBoy
10-25-2011, 07:52 PM
Tried this as well. Seems I just have to send it back inn and cross fingers it wont take too meny weeks to get a new one... Norwegian customer support is not the best in most of these cases :p
Sounds like a defective video subsystem to me. Since it's brand new, I wouldn't try to get it fixed.....I'd just exchange it for a new one.

Gemt
10-26-2011, 12:05 PM
Just delivered it at the store I ordered it (Spaceworld). Got nice service, just reminds to see how long it takes for them to send me a new one :)

Thanks for the help anyway, and lets hope the next one will work!

JRd1st
10-26-2011, 12:22 PM
Good luck!