PDA

View Full Version : G750JX Keyboard missing keystrokes



yogiwolfman
10-08-2014, 07:54 PM
Hey everyone. I just got my G750J last week and I love the rig. From the moment I started using it I noticed the keyboard missing keystrokes. It's not a big deal if I'm typing slowly, but if I let 'er rip, I have to go back and correct multiple errors. I've ruled out sloppy form and this seems to be something internal. My last Asus laptop, a G72GX had a similar error, where it'd double type every 100 characters or so. Both issues are annoying and I'm wondering if this is an Asus error at-large. I've never run into other laptops or desktops with anything similar.

So, anyone having similar issues with the 750 series? And if so, how in the world do I fix it? I'd prefer not to use a USB keyboard to avoid the error. Thanks!

hmscott
10-08-2014, 08:15 PM
Hey everyone. I just got my G750J last week and I love the rig. From the moment I started using it I noticed the keyboard missing keystrokes. It's not a big deal if I'm typing slowly, but if I let 'er rip, I have to go back and correct multiple errors. I've ruled out sloppy form and this seems to be something internal. My last Asus laptop, a G72GX had a similar error, where it'd double type every 100 characters or so. Both issues are annoying and I'm wondering if this is an Asus error at-large. I've never run into other laptops or desktops with anything similar.
So, anyone having similar issues with the 750 series? And if so, how in the world do I fix it? I'd prefer not to use a USB keyboard to avoid the error. Thanks!

yogiwolfman, the consensus seems to be that it is the Elantech Touchpad driver interfering with the keyboard - disable the Touchpad in the BIOS, and the problem goes away.

I haven't seen any postings of the problem being solved with updated Elantech/Smart Gesture drivers.

You might also try plugging in a mouse and use the Smart Gesture setting to disable the Touchpad while the mouse is plugged it - that might be enough.

41918

I have that set, but rarely use the keyboard, as over the years, and many keyboard replacements later, it is way cheaper to use a nice external keyboard wired/wireless than deal with the finger prints, food particles, failed keycaps, and occasional spills into the laptop keyboard :)

I use a Logitech K400r for travel, it fits in the laptop bag along with the G750JH... btw, what model G750 do you have?

Logitech K400R
http://www.logitech.com/product/wireless-touch-keyboard-k400r
http://www.amazon.com/dp/B005DKZTMG/ref=twister_B00FIYEBK8

For home I use a Razor keyboard/mouse. I helps make typing more consistent if I use the same keyboard on all my systems.

yogiwolfman
10-08-2014, 09:37 PM
Thanks for the response! I have a G750J...i7 2.4, 16GB RAM and replaced the HDD with a Samsung 500GB SSD...in love! I'll try disabling the touchpad and let you know how it goes. Thanks!

yogiwolfman
10-08-2014, 09:45 PM
My bad...G750JX.

hmscott
10-08-2014, 09:49 PM
My bad...G750JX.

yogiwolfman, after 5 or more posts you can upload images and edit your posts.

The JX is awesome :)

yogiwolfman
10-08-2014, 10:30 PM
Yeah I'm loving it. I use it primarily for photo editing because I'm a photographer by trade. I don't do a ton of gaming but Borderlands 2 with all settings on high made the rig laugh a little. With the SSD, photoshop literally loads in 3 seconds. That was a 2+ minute job for my previous computer. Gotta love it!

Darnassus
10-09-2014, 12:10 AM
I thought it was the key hold option in

Charm Bar > Settings > Change PC Settings > PC and Devices > Mouse and Touchpad > Mouse 'Delay timer'

I changed my option to 'Short delay'

hmscott
10-09-2014, 12:21 AM
I thought it was the key hold option in
Charm Bar > Settings > Change PC Settings > PC and Devices > Mouse and Touchpad > Mouse 'Delay timer'
I changed my option to 'Short delay'

Darnassus, that's worth a try too :)

yogiwolfman
10-09-2014, 02:04 AM
Disabling the touchpad worked like a charm. Thanks everyone!

x7007
10-29-2015, 05:52 AM
Disabling the touchpad worked like a charm. Thanks everyone!

Ye I had the issue with Asus G750JH with 7970 ATI . and now I have it with G751JT windows 8. I think the short delay fix the issue.