PDA

View Full Version : Sonic radar 2 not working?



DuckTakula
10-18-2014, 01:09 PM
Hey I just re-installed and formatted everything from my PC and I re-downloaded all the drivers and applications, but when I started upSuper Sonic Radar 2 and i started Cs:go and I realized that the radar is visible but the radar does not detect any sounds and it does not show that there is any Gun sounds, foot steps etc. And once I start up Sonic Radar, it says to go on Sonic Studio and change the settings to virtual surrounding for better gaming experience, but I don't even have Sonic Studio installed! I had tried everything but I did not find any solutions! What am I suppose to do? I'm still using the same headphones and all but once i formatted my driver and reinitialized everything, it just doesnt work now from some reasons, including Keybot!

toronto699
10-18-2014, 02:21 PM
http://rog.asus.com/forum/showthread.php?52579-Sonic-Radar-2-not-working read 7th post here

DuckTakula
10-18-2014, 02:37 PM
It didnt work for me, I tried. It's rather im doing it wrong, or just doesn't work for me, as i said, it used to work before i formatted my hard drive and re-installed everything again.

toronto699
10-18-2014, 07:47 PM
why not make a post " Sonic Studio not found , working , not installed or something similar " as its part of the hardware in the MB

WCPredator
12-13-2014, 02:08 PM
It didnt work for me, I tried. It's rather im doing it wrong, or just doesn't work for me, as i said, it used to work before i formatted my hard drive and re-installed everything again.
Sonic Radar worked for you once? was it an older version? I had to install the mobo drivers from the website in specific order to make mt board work (mostly anyway). Perhaps the problem lies there?