PDA

View Full Version : G750J USB ports stopped working



thisistough
10-24-2014, 05:48 AM
I have a G750J and am running Windows8.1 and yesterday my USB ports stopped working. At first I thought it was the mouse and wasted time troubleshooting that. If I plug in my TARDIS thumb drive the light comes on for 1 second and no sounds come from plugging it in. When I open the device manager there is an unknown device under Other devices with a yellow exclamation sign.

Under properties it says "Location: on Intel(R) USB 3.0 eXtensible Host Controller - 0100 (Microsoft)" and device status reads:"

The drivers for this device are not installed. (Code28)

There are no compatible drivers for this device.

To find a driver for this device, click Update Driver."

When I click Update Driver and select Search automatically it tells me "Windows could not find driver software for your device."
I have googled this problem and tried the following:

removing battery for 10 minutes (before I found unknown device)

check usb is enabled in BIOS (it's on Smart-auto when I put it on enabled all but one of my USB controllers went away)

update drivers through Intel

update drivers through ASUS

uninstalling device and rebooting

uninstalling USB Charger Plus.

As evidenced by making this post none of the above has helped.

hmscott
10-24-2014, 06:17 AM
I have a G750J and am running Windows8.1 and yesterday my USB ports stopped working. At first I thought it was the mouse and wasted time troubleshooting that. If I plug in my TARDIS thumb drive the light comes on for 1 second and no sounds come from plugging it in. When I open the device manager there is an unknown device under Other devices with a yellow exclamation sign.

Under properties it says "Location: on Intel(R) USB 3.0 eXtensible Host Controller - 0100 (Microsoft)" and device status reads:"

The drivers for this device are not installed. (Code28)

There are no compatible drivers for this device.

To find a driver for this device, click Update Driver."

When I click Update Driver and select Search automatically it tells me "Windows could not find driver software for your device."
I have googled this problem and tried the following:

removing battery for 10 minutes (before I found unknown device)

check usb is enabled in BIOS (it's on Smart-auto when I put it on enabled all but one of my USB controllers went away)

update drivers through Intel

update drivers through ASUS

uninstalling device and rebooting

uninstalling USB Charger Plus.

As evidenced by making this post none of the above has helped.

thisistough, nice debugging, you can put that all in the RMA request to Asus via a Technical Inquiry. It will help move things along quickly.

https://vip.asus.com <== create a login, register your laptop, file Technical Inquiry requesting RMA to repair USB problem.

It sounds like a cable or USB board problem. I wouldn't open it up to check it out, you have to remove too much to get at what you need to check.

Please let us know how it works out :)

Update: the one time I don't suggest checking for recent Windows Updates... :)

HaveANiceDay
10-26-2014, 10:06 AM
Do you have Solved your program ????
Cos my problem same with you
If you solved pls teach/guide me
Thx

MrTwista
10-26-2014, 06:23 PM
I have the same issue with my G750JX and Windows 8.1. The USB devices get power if I reboot to BIOS but once OS starts loading, all power lights go out. Worked OK yesterday. According to log some Windows updates have been done yesterday, so maybe they've come in effect now.

MrTwista
10-26-2014, 07:17 PM
Uninstalled windows update KB2984006 (which got installed yesterday) and now my USB devices are working again. Also uninstalled KB2994897, but the problem disappeared after KB2984006, so this might not be necessary.

thisistough
10-27-2014, 03:44 AM
KB2984006 Was the culprit for me as well. Uninstalled and my USB ports work again! Thank you so very much MrTwista!

For anybody who is here because they have the same problem go to your control panel, go to programs and features, on the side click View Installed Updates, then search for Windows Update KB2984006 and uninstall it.

hmscott
10-27-2014, 09:51 AM
KB2984006 Was the culprit for me as well. Uninstalled and my USB ports work again! Thank you so very much MrTwista!

For anybody who is here because they have the same problem go to your control panel, go to programs and features, on the side click View Installed Updates, then search for Windows Update KB2984006 and uninstall it.

thisistough, the KB2984006 is a roll up with a number of patches included, and none mention USB...

https://support.microsoft.com/kb/2984006#fixed_issues

I wonder if the individual patches can be applied, and that way you could find the specific patch affecting your USB... strangely - I have this rollup installed and no USB problems on a G750JH. I wonder if there is some other software that in combination is causing the conflict...

steveep
11-14-2014, 11:16 PM
Hi guys many thanks for this post, the same thing happened to my sons G750J, I uninstalled this /windows update and the usb ports started to work i cannot thank you enough........

kelleyb102
07-20-2015, 10:56 PM
I have a G750J and am running Windows8.1 and yesterday my USB ports stopped working. At first I thought it was the mouse and wasted time troubleshooting that. If I plug in my TARDIS thumb drive the light comes on for 1 second and no sounds come from plugging it in. When I open the device manager there is an unknown device under Other devices with a yellow exclamation sign.

Under properties it says "Location: on Intel(R) USB 3.0 eXtensible Host Controller - 0100 (Microsoft)" and device status reads:"

The drivers for this device are not installed. (Code28)

There are no compatible drivers for this device.

To find a driver for this device, click Update Driver."

When I click Update Driver and select Search automatically it tells me "Windows could not find driver software for your device."
I have googled this problem and tried the following:

removing battery for 10 minutes (before I found unknown device)

check usb is enabled in BIOS (it's on Smart-auto when I put it on enabled all but one of my USB controllers went away)

update drivers through Intel

update drivers through ASUS

uninstalling device and rebooting

uninstalling USB Charger Plus.

As evidenced by making this post none of the above has helped.


G750J USB ports stopped working

I have a G750J and am running Windows8.1 and yesterday my USB ports stopped working. At first I thought it was the mouse and wasted time troubleshooting that. If I plug in my TARDIS thumb drive the light comes on for 1 second and no sounds come from plugging it in. When I open the device manager there is an unknown device under Other devices with a yellow exclamation sign.

Under properties it says "Location: on Intel(R) USB 3.0 eXtensible Host Controller - 0100 (Microsoft)" and device status reads:"

The drivers for this device are not installed. (Code28)

There are no compatible drivers for this device.

To find a driver for this device, click Update Driver."

When I click Update Driver and select Search automatically it tells me "Windows could not find driver software for your device."
I have googled this problem and tried the following:

removing battery for 10 minutes (before I found unknown device)

check usb is enabled in BIOS (it's on Smart-auto when I put it on enabled all but one of my USB controllers went away)

update drivers through Intel

update drivers through ASUS

uninstalling device and rebooting

uninstalling USB Charger Plus.

As evidenced by making this post none of the above has helped.


G750J USB ports stopped working

I have a G750J and am running Windows8.1 and yesterday my USB ports stopped working. At first I thought it was the mouse and wasted time troubleshooting that. If I plug in my TARDIS thumb drive the light comes on for 1 second and no sounds come from plugging it in. When I open the device manager there is an unknown device under Other devices with a yellow exclamation sign.

Under properties it says "Location: on Intel(R) USB 3.0 eXtensible Host Controller - 0100 (Microsoft)" and device status reads:"

The drivers for this device are not installed. (Code28)

There are no compatible drivers for this device.

To find a driver for this device, click Update Driver."

When I click Update Driver and select Search automatically it tells me "Windows could not find driver software for your device."
I have googled this problem and tried the following:

removing battery for 10 minutes (before I found unknown device)

check usb is enabled in BIOS (it's on Smart-auto when I put it on enabled all but one of my USB controllers went away)

update drivers through Intel

update drivers through ASUS

uninstalling device and rebooting

uninstalling USB Charger Plus.

As evidenced by making this post none of the above has helped.

I have had an eerily similar experience as mentioned almost identical experience shown top comments: 10/24/2014 and have followed exactly same path except I also wasted time troubleshooting for sound and external drives as I also use a usb headset and a mouse but removing the KB2984006 did not help and have updated my BUS from 206 to 207 also no help. I use my computer for work I work from home as am disabled and this is my lively hood and I do not know where or what else to do. Please can anyone help.