PDA

View Full Version : G750JX problems with PhysX



Pairofix
10-27-2014, 12:02 PM
Hello all,
I have a G750JX with GTX770 updated to Win8.1. Since I used the approved driver V9.18.13.3788 (Asus site) everything was ok. Now I've updated to the latest nVidia 344.48 , everything is ok but Mass Effect 2 and Mass Effect 3 doesn't start anymore due to the following problem:"Failed to initialize the physics system. Please ensure you have an updated version of the PhysX System Software installed."
I have now the updated PhysX, so i think that the problem is the opposite and I should restore the previous version. Unfortunately I don't know how to restore PhysX, because if I simply remove the latest driver and I install the previous one, PhysX remains at the latest update. Does someone know how to remove completely the VGA driver including PhysX ? Or , there's perhaps another solution. Thank You for Your help and suggestion. Pairofix

hmscott
10-27-2014, 10:50 PM
Hello all,
I have a G750JX with GTX770 updated to Win8.1. Since I used the approved driver V9.18.13.3788 (Asus site) everything was ok. Now I've updated to the latest nVidia 344.48 , everything is ok but Mass Effect 2 and Mass Effect 3 doesn't start anymore due to the following problem:"Failed to initialize the physics system. Please ensure you have an updated version of the PhysX System Software installed."
I have now the updated PhysX, so i think that the problem is the opposite and I should restore the previous version. Unfortunately I don't know how to restore PhysX, because if I simply remove the latest driver and I install the previous one, PhysX remains at the latest update. Does someone know how to remove completely the VGA driver including PhysX ? Or , there's perhaps another solution. Thank You for Your help and suggestion. Pairofix

Pairofix, you should be able to edit the customization for those games using hte Nvidia Geforce interface - disable the Physx config for those games, rather than uninstall Physx driver completely - but you can do that by doing a Clean Install of the Nvidia driver and uncheck the Physx option.

You might do some googling on Mass Effect's and see if there is a recommended version of Physx..