PDA

View Full Version : Help with G750-JH SD card reader, card not appearing in file explorer



kjancaitis
10-28-2014, 02:18 AM
Last night for the first time I tried to used the SD card reader on my G750-JH. Inserted a known good SD card into the reader and nothing happened. The card did not appear in file explorer. Tried another known good card with the same result.

Checked the BIOS to make sure that the SD card reader was unlocked. Uninstalled and re-installed the card reader software:

CardReader_Genesys_Win7_8_VER4303

No joy - still nothing when I insert an SD card. Checked device manager to verify that there was no problem with any device. However, in device manager I don't see anything that looks like a card reader. Should there be a recognizable entry?

Any help or suggestions would be appreciated. Thanks.

PapiChuloNica
11-02-2014, 12:43 AM
I'm also having the same problem with my card reader not recognizing my samsung sd card.

giffi
03-25-2015, 08:13 AM
I have the same problem and it seems none have a solution to this issue.....

Edit by cl-Albert: For those that are interested check the new thread by giffi at the link below for the G750JZ that reports hmscott's suggestion was able to help (thanks hmscott!).

https://rog.asus.com/forum/showthread.php?59445-SD-Card-Reader-issue-G750-JZ-card-does-not-appear-in-file-explorer-solved

hmscott
03-25-2015, 12:41 PM
Guys, for me the Genesys driver exhibited the same behavior, and I found that if I inserted the SD card, then ejected it, and inserted it one more time, the SD card would mount. This works consistently.

But, that is annoying, so I went looking for a better solution.

As I have posted many times, the newest drivers are available via new product releases, and the G501 is no exception, there are several new drivers useful in the G750/G751, and one of them is a newer Card Reader driver:

G501, Windows 8.1, Card Reader section, Realtek Version V6.3.9600.21255
http://support.asus.com/download.aspx?SLanguage=en&p=3&m=G501JW&hashedid=uv3gzPnU54cTZC6Y

I just uninstalled the Genesys driver and installed the Realtek driver, and now the SD card mounts first try every time :)

The only difference is now there isn't a fancy SD Icon for the drive, it is just a plan Icon.

Please let us know how it works out for you :)

BVr77
03-26-2015, 02:56 AM
i tested the Genesys Card reader on my laptop and it works fine.
may be it's the driver your problem, i use version 4.5.0.0

hmscott
03-26-2015, 08:30 AM
i tested the Genesys Card reader on my laptop and it works fine.
may be it's the driver your problem, i use version 4.5.0.0

BVr77, version 4.5.0.0.1003 - 1st insert - no mount, remove and insert 2nd time, mounts fine.

The Realtek Version V6.3.9600.21255 driver mounts on the 1st insert on my G750JH.

giffi reports this fixes his problem too:
http://rog.asus.com/forum/showthread.php?59445-SD-Card-Reader-issue-G750-JZ-card-does-not-appear-in-file-explorer-solved&p=486510&viewfull=1#post486510

Which laptop model do you have?