PDA

View Full Version : Please help me with Refresh Rate



PrincessQuartz
10-29-2014, 04:07 PM
Hi, i have searched my best to find how to change my refresh rate on the g750js model. I have been getting really frustrated with the flickering lines and i have read people saying 85hz is a stable rate...but my laptop only has 40 and 60hz. I even went into the nvidia control panel but there is no options like what people have listed. Can someone please help ?

Maxter
10-29-2014, 07:20 PM
Is that model 3D capable (120Hz screen)? If not, you won't be able to go above 60 Hz (the standard for monitors). If you are only seeing 60 Hz max on the nVidia control panel, then I would probably assume you are not 3D capable. Therefore, you can't go to 85 Hz.
Did you try the windows option? right click desktop>screen resolution>advanced settings>Monitor tab>check screen refresh rate

hmscott
10-29-2014, 07:49 PM
Hi, i have searched my best to find how to change my refresh rate on the g750js model. I have been getting really frustrated with the flickering lines and i have read people saying 85hz is a stable rate...but my laptop only has 40 and 60hz. I even went into the nvidia control panel but there is no options like what people have listed. Can someone please help ?

PrincessQuartz, most screens have a limited ability to run past 60hz, the Chi Mei screens used in most G750's will run up to 100hz and many set it to 85hz to get rid of the flicker you speak of. The AUO screen runs natively at 70hz (Asus runs it at 60hz), and you can set all of this via the Nvidia Control panel in the JW/JX/JH by creating a custom resolution with a custom refresh rate.

42709

42708

42710

Unfortunately the JM/JS/JZ models have the Intel GPU enabled, and use Optimus to switch between the Intel / Nvidia GPU for rendering - but all the video output goes through the Intel iGPU which means you need to use the Intel Control Panel to control the resolution and refresh rate. So far the Intel Control panel doesn't allow custom resolution / refresh settings - I think there is a 60hz/40hz setting only - you could try setting to 40hz to see if that helps reduce the flickering.

You could connect with Asus / Intel support to ask for custom resolutions to solve your issue - more user requests for this might push them to add the feature.

PrincessQuartz
10-30-2014, 01:04 AM
Thanks Maxter & hmscott for the replies.