PDA

View Full Version : CS:GO Stutter G750JZ



dne0gen
11-02-2014, 04:29 AM
Hey guys! I really hope that there are CS:GO players here.

I have been having this issue for so long that I can't even explain how sick I am of it.
Whenever I play CS:GO my fps is not stable. I always use vsync and I cap my fps to 60 (I don't really need 150-200-300).

The problem is that as all is well in random moments my fps drops to about 30-40. It is not unplayable, but the problem is that
there is a big difference between 60 and 40 and that moment(which is less than a second) makes the game stutter, resulting in a like half a second long pause. My friends are playing it on far less powerful computers and they don't have that issue.
Things I have tried:

Minimum settings- same
Maximum settings- same
Nvidia control panel minimum settings- same
Nvidia control panel maximum settings- same
Not capping my fps and disabling vsync- same ( difference is it doesn't drop from 60 to 30 but from 200 to 160-170 which has the same effect)
Capping my fps without vsync- same
Every setting that can affect my gaming experience is set to performance (battery, nvidia control panel)
Reinstalling the game- same
Audio drivers both with latest and uninstalled- same

It happens only in CS:GO. I play far more demanding games without a single drop in my fps, but CS:GO drops often and it doesn't do it on heavy scenes such as shooting 20 people(which would also be weird, because I think my PC should be able to handle that just fine). It happens in random moments.

Anything besides the above ideas will be appreciated.

Thank you!

pokerface
11-02-2014, 03:13 PM
1) Do you have an HDD or SSD? If the game is installed on the HDD that could be the reason

2) When enabling V-Sync, it is advisable to turn on Triple Buffering, try that

3) Only use ASUS drivers listed under your laptop's model. If you are using the latest drivers from nVIDIA, that could also be a reason since the ASUS drivers are optimized to work best with your hardware.

dne0gen
11-02-2014, 07:56 PM
It is on an HDD but all my games are on it as well and it is the only game that it happens in.
It is triple buffered.
It happens with all nvidia drivers I have tried.

hmscott
11-03-2014, 07:28 AM
dne0gen, the last time someone came here with a CS:GO problem, it was solved by disabling the hyper-threaded "cores".

Disabling the odd numbered cores by disabling then through Windows Affinity. If you disable them for Steam processes, any game you start from Steam will also run with the cores assigned by Affinity.

G750JM high temperature on CS:GO - you could PM Extrymas21 and ask for his config tips.
http://rog.asus.com/forum/showthread.php?50742-G750JM-high-temperature-on-CS-GO&p=429501&viewfull=1#post429501

I know this was to reduce heat from running CS:GO without vsync or other fps limitations. I am thinking if you run wide open, but reduce the number of cores running with Affinity, it will run smoothly by not trying to throttle the fps.

It might be worth a try :)

I also looked at some other links, a couple of suggestions you didn't mention, but read the whole thread - OP comments especially for other tweaks:

1) disconnect any USB game controllers
https://www.reddit.com/r/GlobalOffensive/comments/2e6xsr/potential_fix_for_those_experiencing_fps_lag_and/

2) disable network throttling - by default Windows holds back 10%
https://us.battle.net/d3/en/forum/topic/5979220662

Lots more from google:

https://www.google.com/search?q=cs%3Ago+lag+fast+computer&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a&channel=sb

If you are stuck on an HDD, it could be caused by the HDD APM lag - even if other games aren't affected some are. You can use quiethdd to disable APM/AAM:


https://sites.google.com/site/quiethdd/

Put these config lines in the quiethdd.ini file

FirstRun = 0
AC_APM_Value = 255
DC_APM_Value = 255
AC_AAM_Value = 254
DC_AAM_Value = 254
AAMEnabled = 1
APMEnabled = 1

It will also stop the clicking from the head parking noise.

The real cure for HDD induced lags / pauses / freezes is to get an SSD drive, it gets rid of this problem

You could also run from a RAM disk. Copy all the game folder and run from there.

Raxco RamDisk Plus - free trial
http://www.raxco.com/products/ramdisk-plus

The Raxco RamDisk is one of the fastest, and the trial is free. If this works, an SSD would likely fix the stutter too.

When you finally find the tweak(s) that get rid of the stutter, please come back and let us know :)

dne0gen
11-05-2014, 02:51 PM
Well I installed CS:GO on my SSD, did the network throttling thing, and repaired steam.exe. I don't know which of these worked, but apparently (hopefully) it worked. 3 days now and no stutter. hmscott I am pretty sure this forum loves you. At least I do.

hmscott
11-06-2014, 09:49 AM
Well I installed CS:GO on my SSD, did the network throttling thing, and repaired steam.exe. I don't know which of these worked, but apparently (hopefully) it worked. 3 days now and no stutter. hmscott I am pretty sure this forum loves you. At least I do.

dne0gen, that's awesome :)

If you want to tune your TCP Stack options, TCP Optimizer does it for your download speed. Save your existing settings - after all you are happy right now - and then following the instructions here to tune with TCP Optimizer.

TCP Optimizer - Reduce lag, Increase throughput
http://rog.asus.com/forum/showthread.php?45433-TCP-Optimizer-Reduce-lag-Increase-throughput&p=386351&viewfull=1#post386351

You can take the settings as is, and/or read more of the docs to come up to speed on the settings and then make your own tunings. Save options between tests to be able to Rollback to previous good settings. And, you can always start back at Windows defaults, where you are now.

Please come back and let us know how it goes if you get a chance to test it out. :)