PDA

View Full Version : New G750JZ help?



nwreed
11-07-2014, 05:56 PM
I recently purchased a new G750JZ and I'm incredibly frustrated by it and annoyed with myself that I didn't do more research prior to purchasing it. I have several other gaming laptops in my house and they all have either hardware or software switches to switch from the onboard intel video card to the dedicated card. This Asus lovely piece of engineering does not.

I can set the global default to "high performance nvidia processor" in the nvidia control panel but as soon as I reboot the laptop for any reason, it defaults it back to the craptastic intel chip. I can set individual games to run on the nvidia chip in the control panel. but again as soon as the laptop is rebooted it resets to using the intel chip. It is incredibly frustrating to have to go into the control panel each and every time I reboot and reset every game and application to the use nvidia chip.

Anyone have any suggestions on a fix? Besides seeing if CDW will take this back and buying another alienware?

:mad:

kobby2k6
11-07-2014, 08:02 PM
I recently purchased a new G750JZ and I'm incredibly frustrated by it and annoyed with myself that I didn't do more research prior to purchasing it. I have several other gaming laptops in my house and they all have either hardware or software switches to switch from the onboard intel video card to the dedicated card. This Asus lovely piece of engineering does not.

I can set the global default to "high performance nvidia processor" in the nvidia control panel but as soon as I reboot the laptop for any reason, it defaults it back to the craptastic intel chip. I can set individual games to run on the nvidia chip in the control panel. but again as soon as the laptop is rebooted it resets to using the intel chip. It is incredibly frustrating to have to go into the control panel each and every time I reboot and reset every game and application to the use nvidia chip.

Anyone have any suggestions on a fix? Besides seeing if CDW will take this back and buying another alienware?

:mad:

Are you making sure to click "apply" when you choose your desired "GPU" and make sure to wait about 10 seconds after clicking "apply". this is just an example. I never came across the problem since i got this PC in June of this year ( I have the G750JM-DS71)

p.s. I am sure not about the global settings issue because I have never used that otpionbefore but selecting a specifc gpu for a specific game shouldn't be an issue.

42906

nwreed
11-07-2014, 08:10 PM
Yup. And it shows as set to high performance Nivdia processor. But then if I launch a game and alt tab out and check, it's reverted back to integrated. Or as soon as I reboot it reverts back to integrated.

Both of my Alienware's I can set which option to use in BIOS and it works great. Definitely wishing I'd stuck with Alienware for this laptop as well now.

kobby2k6
11-07-2014, 08:37 PM
that's weird and sorry to hear about that. Try and return it (if you are still under the return policy) and get a different one and see if the issue still persists.