PDA

View Full Version : Why is Asus so partition happy. ARGH! (Please Help)



Budco2000
11-08-2014, 07:54 PM
10/2012 I bought a G75VW
10/2013 I bought a G750JX
11/2014 I just got my G751JY

Every attempt at trying to get rid of the split partition on the OS drive using EASEUS partition manger results in the computer never booting again lol. I open EASEUS, I right click on the D: partition and delete it. It now becomes unallocated space. I then right click on C: partition which of coarse houses the OS, and I click extend volume and drag the slider to use all the unallocated space, click save, and EASEUS then reboots the computer, does it's thing then never boots up again. Attempts at repairing never work either. It always finds an error after trying to extend partition but refuse to boot. Error always states OS not found.

The problem I've described above was for my G75VW and my G750JX. I ended up just formatting the SSD and installing my own copy of windows 8. I use the ASUS backtracker software, and as soon as I get a new ROG laptop I run it and save the system restore on a flash drive and then eliminate the 20 to 30 GB restore partition.

On my G75 and my G750 I run dual Samsung EVO 512GB SSD's and run the restore flash drive to system restore on my EVO's. Of coarse system restore restore all them partitions that I don't won't or need. I don't need a 30GB system restore when I have the restore backed up on an external drive as well as the flash drive. Nothing I do seems to work to eliminate all these partitions ASUS is creating. Maybe I"m OCD lol, but I don't want my main drive spit into several partitions. One SSD needs to be C: the other SSD needs to be D: My blue-ray drive is E: and my network drive is Z:

My new G751 just arrived to today. I haven't even opened it yet. But I know it's going to be the same crap as the other 2. Only this time I do not want to install my own OS. I don't have an 8.1 disk, I don't want to buy one, and I don't want to put a fresh install of windows 8 just to upgrade that to 8.1. I like 8.1 and have no problems or issues. I have over 125 games in my steam library and they all ran flawlessly on the G750. The only reason I got the new G751 is because my 7 year old daughter needs a laptop to do her school homework and make up assignments on. Starting 2015 most Florida schools is moving all homework and assignments online and no paper homework will be issued. After looking and looking for the right laptop for her there was always something I didn't like about each one. So I decided to give her my G750 which was basically to talk myself into getting the latest and greatest G751 lol. My G750 will do everything she needs it to including flash heavy children websites and some games.

When I open my G751 the first thing I'm going to do is run ASUS Backtracker and put the system recovery on a flash drive and a spare copy on my external drive. I'll then pull both drives that come with it out and insert my 2 Samsung EVO SSD's. I'll format the one that windows goes on, the other one I won't. It just contains documents, pictures, movies, music, game saves etc. After system restore does it's thing the OS SSD with be partitioned as C: and D:. I want to be able to delete the D: extend the C: to use the unallocated space I just gained by deleting the D: partition and actually have windows boot up when I'm finished. Does anyone know the correct way of doing this or have a way that was done successfully for them. Lots of research online and following detailed directions correctly results in OS not found, not booting, and un-repairable. I've tried 3 or 4 times in a row with each of my last to ROG laptops and always end up with the same result, having to restore and not accomplishing nothing but waiting time and wear and tear on my SSD.

Sorry this is so long, just trying to be specific I guess.

hmscott
11-08-2014, 11:41 PM
Budco2000, it's been that way for so long now. But, I wanted to mention that I saw an image of an Asus F9 recovery show up in a google search and that shows it offer to not split the partitions, it wasn't an ROG, but it is encouraging that one day it might be available for us too :)

Until then I do what you do and make it as I need it, 1 large C partition on the boot drive, and 1 large D partition on the 2nd Bay drive.

tl;dr

Budco2000
11-09-2014, 03:05 AM
The G751 is set up differently then what I thought, And after doing some research the ssd's are faster in this format. One of the 128 SSD will be my OS, the second will be OS programs, and I'll put my samsung EVO 512 SSD in bay 2 and install games to it as well as my pics, vids, mp3's and docs

42936

hmscott
11-09-2014, 04:20 AM
The G751 is set up differently then what I thought, And after doing some research the ssd's are faster in this format. One of the 128 SSD will be my OS, the second will be OS programs, and I'll put my samsung EVO 512 SSD in bay 2 and install games to it as well as my pics, vids, mp3's and docs

Budco2000, that M.2 PCIE is 20mbit/s vs SATA III 6mbit/s, so I would invest in a new M.2 PCIE 1TB as soon as they come out.

The 2nd Bay in a JY should be a SATA III - you could try getting a like 1TB 2.5" - maybe both Samsung, and try RAID0 - it might be worth it. If not the M.2 PCIE 1TB should be 1.6GB/sec by itself.

The 128GB is too small even for OS, and splitting it across 2 x 128 as C/D partitions won't be helpful - one or the other will fill up first and negate using the remaining space on the other - programs always install something on the C partition even when directing the install to the D partition.

Maybe you can try RAID0 on the 2 128GB drives to get 256GB?

kennycol
11-09-2014, 09:35 AM
Budco2000, if you manage to get the backtracker software to restore the original install to a PCIe M.2 drive and have the restored OS be bootable and work, please let me know how you did it, regardless of whether you are able to successfully combine two main partition Asus likes to make out of the boot drive. I tried several different ways of restoring the original install via backtracker to a new PCIe M.2 drive and, while it would always report success, booting to the newly restored OS partition always resulted in an error. I was only able to successfully use the PCIe M.2 drive as a boot drive by doing a fresh install to it from 8.1 media.