PDA

View Full Version : Several Annoying Problems on G750JM



scarletvan
11-21-2014, 12:02 PM
Hello, i'm new to ROG as i just bought this laptop ( G750JM ) a week ago. I love it's powerful gaming performance but i encountered several annoying problems.
1. Slow Startup on battery and occasionally when plugged
The ROG logo appears, and the screen goes black. Nothing happens. Then i need to force shut down it, and turn it on again, and it's up and running.
2. Blue Screen
I'm updating my Nvidia driver via GeForce Experience and playing PES 2015 at the same time. They still run fine and when the update is done, i closed pes, and install the driver. afterwards, the laptop is getting slow with GeForce Experience and Google Chrome are not responding. So i decided to restart, and when it's RESTARTING, it goes blue screen all of sudden. This also happen occasionally when i boot my laptop up, black screen for too long, and it goes blue screen.
3. Please explain the downsides of GPU Overclocking as i fear that i am harming the GPU.

Those are my problems and please provide me with good solutions as i really need to get rid of these problems fast.
Thank You

qiliangpei
11-23-2014, 08:01 AM
the 1st one is not a "slow startup", it is a "black screen" problem, it is dead nowhere and no one knows what is wrong. because it doesnot happened everytime or with same appearance, so it is hard to say where is the problem...

rexscooby
11-24-2014, 06:21 AM
Im having the same problem with "scarletvan" too . Black screen then blue screen .
Problem is its getting more and more frequent . Forgot to add that mines a G750JS
Sometimes after the BSOD , i take at a look at the DEVICE in system settings and notice that the GTX870 hardware is not there , only the intel built in graphic card .After which , i reboot again and it comes back . Sometimes after starting my game "Farcry 4" the BSOD comes back again . Then the process repeats . Restart and pray the GTX870 hardware is back ....

I've been reading on ways to get rid of the BSOD from the sticky tread and i've tried many methods including using 332.60 version and still it does not work ..... Should i actually bring it down to the service center already ? Could it be that my GTX870 is totalled ?

beatc
11-24-2014, 11:54 AM
I seen others encountered the same problem like yours. They have BSOD after upgrading via the Geforce Experience. So, my suggestion is avoid the GE at all cost. Rollback your version to the previous working one.

scarletvan
11-25-2014, 05:32 AM
Hello mates, thanks for the reply
anyway, i found a great solution for this not long ago
you guys might be interested to try this
download CCleaner, scan the registry, fix ( repeat till there is no problems found )
restart your laptop, and do the scan again to see if there's still any problems
i did this and now my laptop is functioning without problems :)
i scan the registry daily from now on and this laptop offers me great performance in any ocassions :)