PDA

View Full Version : Was Windows 8.1 defragging my SSD?



Torpedo499
11-23-2014, 06:57 PM
So I was running maintenance tasks today through the action center and it said on my task manager that it was defragging one of my drives.
So I check to see and it said defragging my HDD, however is said that my SSD needs optimization and it said "Drive last optimized 21374858 days ago" which is very weird.
Anyway when I went back to the windows defrag menu it didn't say anything about the TRIMM command it showed my SSD being defragged like "Pass 1: 0% Consolidated"

Was Windows defragging my SSD?

Maxter
11-23-2014, 07:28 PM
So I was running maintenance tasks today through the action center and it said on my task manager that it was defragging one of my drives.
So I check to see and it said defragging my HDD, however is said that my SSD needs optimization and it said "Drive last optimized 21374858 days ago" which is very weird.
Anyway when I went back to the windows defrag menu it didn't say anything about the TRIMM command it showed my SSD being defragged like "Pass 1: 0% Consolidated"

Was Windows defragging my SSD?

make sure that TRIM is "on". Run command prompt: "fsutil behavior query DisableDeleteNotify" if answer is 0, TRIM enabled, if 1, it's dissabled. Usually win8 optimization is really fast. Shouldn't even try to defrag.

Torpedo499
11-23-2014, 07:31 PM
The command shows "0" however, I've done some digging and came up with this: http://www.outsidethebox.ms/why-windows-8-defragments-your-ssd-and-how-you-can-avoid-this/

It seems that Windows defrags SSDs during automatic/manual maintenance.

Maxter
11-24-2014, 09:59 PM
The command shows "0" however, I've done some digging and came up with this: http://www.outsidethebox.ms/why-windows-8-defragments-your-ssd-and-how-you-can-avoid-this/

It seems that Windows defrags SSDs during automatic/manual maintenance.

huh... seems like I'm disabling my auto-maintenance right now. Thanks for the heads up. I'm going to read more about this issue.

Torpedo499
11-24-2014, 10:35 PM
huh... seems like I'm disabling my auto-maintenance right now. Thanks for the heads up. I'm going to read more about this issue.
No problem, really hope they make a fix for this!