View Full Version : Dual-booting Windows 8.1 & Ubuntu 14.04 in G751JT

12-04-2014, 02:56 AM
I looked around a few threads and a couple of website in order to install Ubuntu 15.04 along with the Windows 8.1 which is already installed in my G751JT. I eventually had to mix up a few methods each websites had to make my G751JT dualboot Ubuntu 15.04.

I am not a Linux, computer, or a dual-boot expert but I thought this guide(?) or the steps I took would help others who also want to install another OS in their laptop.

I used 2 HHDs instead of 1. I added my spare HHD into the 2nd bay. My 1st bay has Windows 8.1 installed and the 2nd bay would have Ubuntu 15.04 installed.


I've been dual booting Linux a couple of times before on a Legacy BIOS and this was my first time trying to install it from a UEFI.
Apparently there were some extra steps I had to do.

Complete Step by Step Instructions:

1. Downloading the Ubuntu ISO you need.
The link above is where you would download your ISO file you will need.
I recommend downloading the ISO file via bittorrent. It was way more faster for me.

2. Disabling Fast Startup on Windows.
I am not sure if this is essential but I read a few webpages that if you do not disable Fastboot and enter into a different OS, your system could potentially crash. To make it safe, I disabled it.
I used OPTION ONE in that web page.

For those who doesn't want to bother going to an external link!
Go to Power Options from Control Panel.
Click Choose what the power buttons do.
Click Change settings that are currently unavailable.
Untick Turn on fast start up.

3.Creating a Ubuntu installer using a USB.
After several months, I noticed that burning the iso on a CD works much better than using a USB. I recommend to use a CD instead of a USB. Simply burn the ISO using UltraISO to your CD.
New method I used when I installed Ubuntu 15.04.
I found out Linux Live USB Creator worked out pretty well and actually faster. I decided to use this one instead of the old method I used before. I recommend using this method or make your own boot CD using UltraISO or something else.

How to make a booting USB using Linux Live USB Creator:
Step 1. Choose your USB.
Step 2. Select the ISO you downloaded.
Step 3. Set the Persistence. I used 1024MB. I recommend setting it higher than 500MB.
Step 4. Format to FAT32 if the USB is not in that format. (BACK UP YOUR DATA FIRST)
Step 5. Click the Lightning bolt image. and wait till everything is done.

Old method I used when I installed Ubuntu 14.04.
I used this tool which is very useful.
Plug a USB and run the Universal USB Installer program. I would recommend using a USB which is at least 4gb. (Depends on your file )
On step 1, choose Ubuntu.
Step2, select the Ubuntu ISO you downloaded from Step1. (Your file name, if you did not modify it, must have "desktop" included in its name. You must have "desktop" somewhere in your name of the ISO file or else the tool will not recognize your ISO file.)
Step3, select the USB you plugged in.
Next, check “Formatting your USB”.
Step4, I'm not sure if this is essential but I set mine to 1024MB. (If you do step 4, the time it takes to make the USB installer would increase a lot.)
Then click "Create".
Patiently wait until it finishes.

4. Enter UEFI settings.
After you make the Ubuntu USB Installer, you would now want to go change your UEFI settings.
To do this, on the start screen, I clicked on the Power button.
Then I clicked Restart while I was holding on the "Shift" key. After your computer restarts, you would click

Troubleshoot - UEFI Firmware Settings.
There are other ways to go into your UEFI settings but this was the easiest way for me.
In the "Security" tab, you would want to disable secure boot which is enabled by default.
Then go to the "Boot" tab and boot from your Ubuntu USB Installer.

For those who have to boot through the BIOS.
If for some reason you want to access the BIOS, spam the "Delete" button after you turn on your laptop. It will let you access your BIOS.

5.Changing command parameter in GRUB.
When I was installing Ubuntu 14.04.
When you boot from your USB you will get the purple colored GRUB screen.
Click "e" key and replace "quiet splash" to "nomodeset".
This is done only for since there is some graphics issue when booting normally. Apparently G751JT's nvidia 970M has some issues with it. After reading some information about it, I assume, the open source driver for the graphics card does not support the normal way of booting.
Then click the "F10"key.
Wait patiently and texts would be flashing. Even though you might think your laptop froze, there's a high chance that it is still running.

When I was installing Ubuntu 15.04.
Without having to replace "quiet splash" to "nomodeset", normally booting it worked fine for me. If it doesn't work, I guess you could change "quiet splash" to "nomodeset" like how I did on Ubuntu 14.04.

6. Installing Ubuntu & Partitioning.
Just normally Install Ubuntu. You can check a video I linked. It does not 100% suit for my purpose but it will give a gist of what to do. Follow what the video does but if you have 2 hard drives and want to install Ubuntu in a seperate hard drive, you should set your bootloader to install in the hard drive where you will install your Ubuntu. (Not in the hard drive where your Windows 8.1 is installed in.)
The video is supposed to start during midway. End watching till 21:25 seconds. After that, we will be doing something else. Just restart your computer so that it would pop up the GRUB screen for the upcoming step.

For Ubuntu 14.04
7. Back in GRUB entering recovery mode to Fix "quiet splash" error.
Mentioned in step 5, our graphics card's driver is causing this issue so we have to install the closed source driver which is in NVIDIA's official website instead of using the open source driver. In the GRUB screen, enter "Advanced Options for Ubuntu" and enter one of the newer versions of the recovery mode.
In the Recovery Menu, select "network" to enable networking.
Then, select "root" to proceed to the next step.

8. Installing the appropriate graphics card driver.
When typing the codes mentioned in the website below, omit "sudo" because you automatically get root access without having to type "sudo".
This website helped me installing the 346.16 version of the nVidia driver. (Beta Version.)
PS. Ubuntu uses Lightdm as its Display Manager so for kiling the display manager, you would want to use,

After executing the .run file using the command below to install the nVidia driver, you will get an installation screen.

Depending on whether you have a 32bit laptop or a 64bit laptop I believe some errors might show up or not. I got some errors (actually warnings) but I just proceeded through the installation.

Since I do not have a VM to look back at what the exact stuff I chose were, I could only say to select OK, yes, continue.

For Ubuntu 15.04
Since I did not experience the "quiet splash" issue, I just normally booted to Ubuntu.
However, I had to install the correct nvidia driver using a different method.

7. Add edger's ppa to install the latest nvidia driver with ! lol
In the terminal type the following codes below.
sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
After doing that, reboot Ubuntu.

8.Install the latest nvidia driver.
Go to Additional Drivers.
Select and install the latest NVIDIA binary driver. At this time, (July 15th 2015) Version 352.21 worked well for me.
Reboot after then.

9. After finishing the installation...
Just type "restart" then you will restart your laptop. You will get GRUB.
Just launch Ubuntu without changing "quiet splash". It will be fixed.
To launch Windows 8.1, select Windows Boot Manager.
At this moment, you can use your Ubuntu however there are some small issues like:
Touchpad doesn't working well
Steam button not functioning
Screen brightness not dimming
Earphone not working well
Follow the BONUS TIPS to fix this!


This was how I dual-booted my G751JT.
I hope this helps alot of people who were confused:)
PS. This used to be a Ubuntu 14.04 dual boot installation guide but I updated it for Ubuntu 15.04. The methods are still the same.

12-04-2014, 08:17 PM
This would make a great sticky, but it needs to be moved to the G751 notebook forum. Thanks for the write-up! :D

12-04-2014, 11:52 PM
This would make a great sticky, but it needs to be moved to the G751 notebook forum. Thanks for the write-up! :D

Oh Sorry! I thought since this was related to Ubuntu Linux I had to post it in this section. I'll move it to the G751 forum:)

01-08-2015, 05:40 AM
I completely install in dual boot Ubuntu on my Asus ROG G751JY-T7004H.
I boot normally ubuntu but there is a problem in ubuntu.
There is no sound.
Help me please.

01-09-2015, 01:08 AM
I installed Mint, and notice that when I reboot (which I did alot during install of drivers, etc), the G751JT does not power down everything, and the result is no sound when booting linux from reboot. If I power down completely, then boot linux, sound seems to work ok.

Note, I installed the 205 BIOS, which causes CSM to act differently then it did on 203 BIOS, so I had to disable CSM to get everything to run clean. I do not recall if the reboot behaviour existed prior. I also am not sure how I feel about 205 BIOS, given the CSM behavior, so I personally can not recomend it.

04-09-2015, 10:19 PM
i want install MacOs on my G751JY-T7004H
can you help me to dump codec please. I need this codec to patch sound card on Yosemite. I can't run live CD ubuntu

sudo -s


cat /proc/asound/card0/codec#1 > ~/Desktop/codec_dump.txt

if it does not work, you probably need to have to get the codec "0", as follows:

cat /proc/asound/card0/codec#0 > ~/Desktop/codec_dump.txt
(This happens if your codec is not 1 but is 0, otherwise it is not found, and generates an empty codec_dump.txt, so check it out!)

please send me this file


05-22-2015, 10:43 AM
I installed Mint, and notice that when I reboot (which I did alot during install of drivers, etc), the G751JT does not power down everything, and the result is no sound when booting linux from reboot. If I power down completely, then boot linux, sound seems to work ok.

Note, I installed the 205 BIOS, which causes CSM to act differently then it did on 203 BIOS, so I had to disable CSM to get everything to run clean. I do not recall if the reboot behaviour existed prior. I also am not sure how I feel about 205 BIOS, given the CSM behavior, so I personally can not recomend it.


I'm trying to install linux mint 17 too, I tried following the steps and when I try to boot, I always get a black screen even if I added the "nomodeset" in the grub settings. If I didn't add it, I still get the black screen. How do I resolve this?

07-15-2015, 04:44 AM
Fixing Touchpad
Check this: https://help.ubuntu.com/community/SynapticsTouchpad/ShortcutKey
The Bash Script method is helpful, but it doesn't seem to work well for me.

My way work around to fix the touchpad:
I'm fine using gnome shell so I installed gnome shell and used the touchpad-indicator plugin. This does not let you to bind a hotkey to toggle the touchpad, but it looks neat so I'm using it.
Fn + F9 doesn't seem to be detected using xbindkeys (showkeys -k detects it though oddly...)
I just binded Super + F9 to run the touchpad script.

So for the scripts...

Create a folder named Scripts in ~/ (or alternatively /home/username/) (to make things clean.)
Create file named touchpad.sh and put the codes below in it.

# toggle synaptic touchpad on/off

# get current state
SYNSTATE=$(synclient -l | grep TouchpadOff | awk '{ print $3 }')

# change to other state
if [ $SYNSTATE = 0 ]; then
synclient touchpadoff=1
elif [ $SYNSTATE = 1 ]; then
synclient touchpadoff=0
echo "Couldn't get touchpad status from synclient"
exit 1
exit 0

Now open gnome-session-properties.
Add a program. You can set the name to whatever you want but set the command as:

sh /home/yourusername/Scripts/touchpad.sh
then save it. Set the hotkey to Super + F9.
Whenever you click the hotkey, it will toggle.

Fixing Steam button
xbindkey was able to detect the steam button so I just binded the steam key to run a script to turn on steam.
The key I binded:

Mod2 + NoSymbol | m:0x10 + c:248
and ran a script to open Linux Steam.
The script literally just has

steam &

Fixing Screen brightness dimming
I was not able to make Fn + F5 or Fn + F6 to work but, I was able to find another way.
Install xbacklight executing the code below.

sudo apt-get install xbacklight
Now go to your keyboard shortcut settings and add 2 shortcuts.
One of the shortcut's command will be:
xbacklight -10
and the other should be
xbacklight +10
Set the keys to whatever you are comfortable with. I'm using Super + F5 and Super + F6.

Fixing Earphone
I looked at this webpage and it said to add the following line to /etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=asus-mode5

Installing Steam
Follow the guide here!
I was not able to run steam even after installing it. This was because I installed steam before installing the nvidia driver.
It seems like the nouveau graphic driver doesn't work well with the steam client. I'm not sure why but installing the nvidia driver solved that issue.

Fixing HDMI Audio
Fixing the HDMI Audio is very easy.
Simply execute the code below and reboot:

sudo adduser your_linux_user_account audio
Don't forget to change your_linux_user_account to your actual linux account.
After rebooting, at your sound settings, select HDMI/DisplayPort instead of your internal speaker.