View Full Version : [Help][G74S]F9 recovery don't work!

12-07-2014, 08:23 PM
How are you today?
3 days ago my Asus G74S stop working(to slow when I use it & on boot)
I try to restore by f9 but the restore always show a big red error after% at that time for some reason so
I download a windows 7 iso legally & install it,
But the laptop still low on boot & when I use it.. .plus I try to play the game"Archeage"
But I can't since it's very slow!

Is there a way to fix this?
I just want my Asus back!

Note: I don't have the recovery disc.

12-08-2014, 01:51 AM
I'm assuming you've tried a system restore to a point before this started? Have you tried a sfc/scannow to check for and possibly repair any corrupt system files? Heres a link to a tutorial on how to do that if you haven't before http://www.sevenforums.com/tutorials/1538-sfc-scannow-command-system-file-checker.html

You could also try a startup repair http://www.sevenforums.com/tutorials/681-startup-repair.html

Have you checked all your drivers? HIt the Start button > type device manager > choose Device manager. Do you see any yellow triangles? If so right click on them and choose update.

If you have recently reinstalled Windows, have you reinstalled the ATK package from Asus? http://www.asus.com/ROG_ROG/G74SX/HelpDesk_Download/

Thats also the place to get drivers for most of your machine.