PDA

View Full Version : Catalyst 14.12 Omega 5870m (G73jh)



Verdict
12-10-2014, 12:06 AM
At the beginning of this month AMD released the 14.12 Omega suite drivers. It says that the Mobility 5000 series is supported and when I install the driver, I do see that it is detecting it needs to install the "AMD Display Driver". Once installed, I restart, only to be met with a very low resolution and AMD popping up saying the driver is not installed or supported.

I've tried several attempts to fix it, including but not limited to, uninstalling the drivers first in safe mode using driver uninstaller.

Does anyone have any issues with this driver on a 5870m platform?

billyray520
12-10-2014, 02:47 PM
Did you uninstall the original drivers first in ordinary Windows mode? THEN you can go to safe mode and use Driver Sweeper, or whatever you use. Then you can reboot, and install the new AMD driver, and then reboot again.

Verdict
12-12-2014, 09:12 AM
Do you have them installed?

roncat
01-02-2015, 09:16 PM
At the beginning of this month AMD released the 14.12 Omega suite drivers. It says that the Mobility 5000 series is supported and when I install the driver, I do see that it is detecting it needs to install the "AMD Display Driver". Once installed, I restart, only to be met with a very low resolution and AMD popping up saying the driver is not installed or supported.

I've tried several attempts to fix it, including but not limited to, uninstalling the drivers first in safe mode using driver uninstaller.

Does anyone have any issues with this driver on a 5870m platform?


Removed original driver, ran ccleaner, installed omega, get low resolution and driver not installed message. Latest BIOS (213), Win7 fully patched and updated.

Verdict
01-03-2015, 12:00 AM
Confirming that 14.12 does NOT work on my G73JH with updated vBIOS and 213 BIOS.

I have the exact same experience.

billyray520
01-04-2015, 05:20 PM
Confirming that 14.12 DOES work on my G73jh with updated vBios (OD2) and 213 system Bios, Windows 7 Pro, SP1.

45026

Just installed it today. File used: amd-catalyst-omega-14.12-with-dotnet45-win7-64bit

Method: Used DDU (http://www.guru3d.com/files-details/display-driver-uninstaller-download.html) to uninstall the old AMD driver in Safe Mode. This program automatically turns off Windows driver updates. Reboot back into normal mode. Turn off anti-virus. Start up driver install. With this latest installation there is a secondary program installed called Raptor for gaming. It will say you need to update your drivers to the latest. Just ignore and close window. Click finish button on driver install, and reboot. Everything went smoothly. :o

Checked HDMI output to 46" Samsung TV. Had to adjust video scan a bit, audio worked great. No problems here either. ;)

I updated my desktop Sapphire HD7970 Dual X OC to new driver 14.12 too! :)